summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-19 18:35:38 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-19 18:35:38 +0000
commit27d086aaacf7a988b150a845a25524dfd75ea68e (patch)
tree44657eaeaf75ffcb554130e3a310bd278831f601 /media-sound/grip
parentsecurity update (diff)
downloadgentoo-2-27d086aaacf7a988b150a845a25524dfd75ea68e.tar.gz
gentoo-2-27d086aaacf7a988b150a845a25524dfd75ea68e.tar.bz2
gentoo-2-27d086aaacf7a988b150a845a25524dfd75ea68e.zip
version bump
Diffstat (limited to 'media-sound/grip')
-rw-r--r--media-sound/grip/ChangeLog8
-rw-r--r--media-sound/grip/files/digest-grip-3.0.01
-rw-r--r--media-sound/grip/grip-3.0.0.ebuild53
3 files changed, 61 insertions, 1 deletions
diff --git a/media-sound/grip/ChangeLog b/media-sound/grip/ChangeLog
index 2aa0b767bc9b..330b62709ba7 100644
--- a/media-sound/grip/ChangeLog
+++ b/media-sound/grip/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/grip
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-sound/grip/ChangeLog,v 1.4 2002/04/12 13:37:07 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/grip/ChangeLog,v 1.5 2002/04/19 18:35:38 seemant Exp $
+
+*grip-3.0.0 (19 Apr 2002)
+
+ 19 Apr 2002; Seemant Kulleen <seemant@gentoo.org> grip-3.0.0.ebuild :
+
+ Version bump to newest stable
*grip-2.98.6-r1 (12 Apr 2002)
diff --git a/media-sound/grip/files/digest-grip-3.0.0 b/media-sound/grip/files/digest-grip-3.0.0
new file mode 100644
index 000000000000..71b2ffcd1d74
--- /dev/null
+++ b/media-sound/grip/files/digest-grip-3.0.0
@@ -0,0 +1 @@
+MD5 a3d0fa657fd7c70656fe6d8b63a75527 grip-3.0.0.tar.gz 829086
diff --git a/media-sound/grip/grip-3.0.0.ebuild b/media-sound/grip/grip-3.0.0.ebuild
new file mode 100644
index 000000000000..a01f8eee3ebd
--- /dev/null
+++ b/media-sound/grip/grip-3.0.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Bruce A. Locke <blocke@shivan.org>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/grip/grip-3.0.0.ebuild,v 1.1 2002/04/19 18:35:38 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GTK+ based Audio CD Ripper"
+SRC_URI="http://www.nostatic.org/grip/${P}.tar.gz"
+HOMEPAGE="http://www.nostatic.org/grip"
+
+DEPEND=">=x11-libs/gtk+-1.2.10
+ media-sound/lame
+ media-sound/cdparanoia
+ media-libs/id3lib
+ gnome-base/gnome-libs
+ gnome-base/ORBit
+ gnome-base/libghttp
+ oggvorbis? ( media-sound/vorbis-tools )
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+
+ use nls || myconf="--disable-nls"
+
+ # apply CFLAGS
+ mv Makefile.in Makefile.in.old
+ sed -e "s/CFLAGS = -g -O2/CFLAGS = ${CFLAGS}/" \
+ Makefile.in.old > Makefile.in
+
+ # fix cdparanoia libs not linking
+ mv src/Makefile.in src/Makefile.in.orig
+ sed -e "s/LDFLAGS =/LDFLAGS = -lcdda_interface -lcdda_paranoia/" \
+ src/Makefile.in.orig > src/Makefile.in
+
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --sysconfdir=/etc \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install () {
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ sysconfdir=${D}/etc \
+ install || die
+
+ dodoc ABOUT-NLS AUTHORS CREDITS LICENSE CHANGES README TODO
+}