summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Lutgens <lamer@gentoo.org>2001-07-01 16:30:18 +0000
committerBen Lutgens <lamer@gentoo.org>2001-07-01 16:30:18 +0000
commitbe0fbbb828bfe9888cb28492dc6ff3b668f74804 (patch)
tree38f71571dec1628321ba553bf238a52394156141 /media-sound/grip
parentUpdated docs to include emerging the kernel, using inet.dhcp_eth0, (diff)
downloadgentoo-2-be0fbbb828bfe9888cb28492dc6ff3b668f74804.tar.gz
gentoo-2-be0fbbb828bfe9888cb28492dc6ff3b668f74804.tar.bz2
gentoo-2-be0fbbb828bfe9888cb28492dc6ff3b668f74804.zip
polaris from #gentoo did a great job on these I think he's prolly ready to
be a developer if he want to.
Diffstat (limited to 'media-sound/grip')
-rw-r--r--media-sound/grip/files/digest-grip-2.951
-rw-r--r--media-sound/grip/grip-2.95.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/media-sound/grip/files/digest-grip-2.95 b/media-sound/grip/files/digest-grip-2.95
new file mode 100644
index 000000000000..a4f9795cdf57
--- /dev/null
+++ b/media-sound/grip/files/digest-grip-2.95
@@ -0,0 +1 @@
+MD5 fabf302f9f35708725415b2d1f7d3602 grip-2.95.tgz
diff --git a/media-sound/grip/grip-2.95.ebuild b/media-sound/grip/grip-2.95.ebuild
new file mode 100644
index 000000000000..e501e06da7d5
--- /dev/null
+++ b/media-sound/grip/grip-2.95.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Bruce A. Locke <blocke@shivan.org>
+
+A=${P}.tgz
+S=${WORKDIR}/${P}
+DESCRIPTION="GTK+ based Audio CD Ripper"
+SRC_URI="http://www.nostatic.org/grip/${A}"
+HOMEPAGE="http://www.nostatic.org/grip"
+
+DEPEND="media-sound/cdparanoia"
+
+src_compile() {
+
+ # grip doesn't have a nice configure script and requires some
+ # symlink love to build
+
+ cd $S
+
+ mkdir cdparanoia
+ mkdir cdparanoia/interface
+ mkdir cdparanoia/paranoia
+ ln -s /usr/lib/libcdda* cdparanoia/interface/
+ ln -s /usr/lib/libcdda* cdparanoia/paranoia/
+ ln -s /usr/include/*cdda* cdparanoia/interface/
+ ln -s /usr/include/*cdda* cdparanoia/paranoia/
+ ln -s /usr/include/utils.h cdparanoia/utils.h
+
+ # apply CFLAGS
+ mv Makefile Makefile.old
+ sed -e "s/-Wall/-Wall ${CFLAGS}/" -e "s/PREFIX=\/usr/PREFIX=\/usr\/X11R6/" Makefile.old > Makefile
+
+ try make all
+
+}
+
+src_install () {
+ cd ${S}
+
+ dodir /usr/X11R6/bin
+
+ cp ${S}/grip ${D}/usr/X11R6/bin
+ cp ${S}/gcd ${D}/usr/X11R6/bin
+
+ dodir /usr/X11R6/man/man1
+
+ cp ${S}/grip.1 ${D}/usr/X11R6/man/man1
+ # make install copies it over....
+ cp ${S}/grip.1 ${D}/usr/X11R6/man/man1/gcd.1
+
+ dodoc README LICENSE TODO CREDITS CHANGES
+
+ insinto /usr/X11R6/include/X11/pixmaps
+ doins pixmaps/*.xpm
+
+}