summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-05-16 08:32:36 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-05-16 08:32:36 +0000
commit49883fdeb6bf8a15b689c912a17fece9c5461469 (patch)
tree1a6adc0b004d5b20bf19ff5688a4b0d35e8676af /media-sound/kradio
parentStable on amd64 and x86. Depend on new ffmpeg as it uses new api. (diff)
downloadgentoo-2-49883fdeb6bf8a15b689c912a17fece9c5461469.tar.gz
gentoo-2-49883fdeb6bf8a15b689c912a17fece9c5461469.tar.bz2
gentoo-2-49883fdeb6bf8a15b689c912a17fece9c5461469.zip
Cleanup
(Portage version: 2.2.0_alpha105/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/kradio')
-rw-r--r--media-sound/kradio/ChangeLog6
-rw-r--r--media-sound/kradio/files/kradio-4.0.2-libav.patch35
-rw-r--r--media-sound/kradio/kradio-4.0.2.ebuild52
-rw-r--r--media-sound/kradio/kradio-4.0.3.ebuild50
4 files changed, 5 insertions, 138 deletions
diff --git a/media-sound/kradio/ChangeLog b/media-sound/kradio/ChangeLog
index 0b2b1a3db669..eb22a4961ae4 100644
--- a/media-sound/kradio/ChangeLog
+++ b/media-sound/kradio/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/kradio
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/kradio/ChangeLog,v 1.32 2012/02/22 15:49:11 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/kradio/ChangeLog,v 1.33 2012/05/16 08:32:36 scarabeus Exp $
+
+ 16 May 2012; Tomáš Chvátal <scarabeus@gentoo.org>
+ -files/kradio-4.0.2-libav.patch, -kradio-4.0.2.ebuild, -kradio-4.0.3.ebuild:
+ Cleanup
*kradio-4.0.4 (22 Feb 2012)
diff --git a/media-sound/kradio/files/kradio-4.0.2-libav.patch b/media-sound/kradio/files/kradio-4.0.2-libav.patch
deleted file mode 100644
index 87d486149144..000000000000
--- a/media-sound/kradio/files/kradio-4.0.2-libav.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-X-Git-Url:
-http://kradio.git.sourceforge.net/git/gitweb.cgi?p=kradio%2Fkradio;a=blobdiff_plain;f=plugins%2Finternetradio%2Fdecoder_thread.cpp;h=c74d6e20578faf3b5dee877aa6de0c9269f49ad9;hp=4cd6cc0543200e9e274e38fa8badb63556a419c3;hb=4f4ec44f49d83b85702bb002455a57374245d825;hpb=c5dea0c01bf5cc16f49cf3d58b837b2fab02d988
-
-diff --git a/plugins/internetradio/decoder_thread.cpp b/plugins/internetradio/decoder_thread.cpp
-index 4cd6cc0..c74d6e2 100644
---- a/plugins/internetradio/decoder_thread.cpp
-+++ b/plugins/internetradio/decoder_thread.cpp
-@@ -373,7 +373,6 @@ void InternetRadioDecoder::openAVStream(const QString &stream, bool warningsNotE
-
- //av_log_set_level(255);
- m_av_pFormatCtx = avformat_alloc_context();
-- memset(m_av_pFormatCtx, 0, sizeof(*m_av_pFormatCtx));
- m_av_pFormatCtx->probesize = m_maxProbeSize;
- m_av_pFormatCtx->max_analyze_duration = m_maxAnalyzeTime * AV_TIME_BASE;
-
-@@ -475,7 +474,6 @@ void InternetRadioDecoder::openAVStream(const QString &stream, bool warningsNotE
- m_av_pFormatCtx_opened = true;
- }
- else {
--
- // IErrorLogClient::staticLogDebug("InternetRadioDecoder::openAVStream: av_open_input_file start");
- if (av_open_input_file(&m_av_pFormatCtx, stream.toUtf8(), iformat, 0, &av_params) != 0) {
- if (warningsNotErrors) {
-@@ -535,7 +533,11 @@ void InternetRadioDecoder::openAVStream(const QString &stream, bool warningsNotE
- m_av_audioStream = -1;
- for (unsigned int i = 0; i < m_av_pFormatCtx->nb_streams; i++) {
- // if (m_av_pFormatCtx->streams[i]->codec->codec_type == CODEC_TYPE_AUDIO && m_av_audioStream < 0) {
-+#if LIBAVCODEC_VERSION_MAJOR < 53
- if (m_av_pFormatCtx->streams[i]->codec->codec_type == CODEC_TYPE_AUDIO) { // take last stream
-+#else
-+ if (m_av_pFormatCtx->streams[i]->codec->codec_type == AVMEDIA_TYPE_AUDIO) { // take last stream
-+#endif
- m_av_audioStream = i;
- break;
- }
diff --git a/media-sound/kradio/kradio-4.0.2.ebuild b/media-sound/kradio/kradio-4.0.2.ebuild
deleted file mode 100644
index d75d8f8c37e8..000000000000
--- a/media-sound/kradio/kradio-4.0.2.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/kradio/kradio-4.0.2.ebuild,v 1.6 2011/12/01 21:55:03 dilfridge Exp $
-
-EAPI=4
-
-KDE_LINGUAS="cs de es is pl pt pt_BR ru uk"
-inherit kde4-base
-
-MY_P=${PN}4-${PV/_/-}
-
-DESCRIPTION="kradio is a radio tuner application for KDE"
-HOMEPAGE="http://kradio.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-SLOT="4"
-IUSE="alsa debug encode ffmpeg lirc +mp3 +vorbis v4l"
-
-DEPEND="
- media-libs/libsndfile
- alsa? ( media-libs/alsa-lib )
- lirc? ( app-misc/lirc )
- mp3? ( media-sound/lame )
- vorbis? (
- media-libs/libvorbis
- media-libs/libogg
- )
- ffmpeg? (
- >=media-libs/libmms-0.4
- virtual/ffmpeg
- )
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=( "${FILESDIR}/${P}-libav.patch" )
-
-S=${WORKDIR}/${MY_P}
-
-src_configure() {
- mycmakeargs=(
- $(cmake-utils_use_with alsa ALSA)
- $(cmake-utils_use_with mp3 LAME)
- $(cmake-utils_use_with vorbis OGG_VORBIS)
- $(cmake-utils_use_with lirc LIRC)
- $(cmake-utils_use_with ffmpeg FFMPEG)
- $(cmake-utils_use_with v4l V4L2)
- )
-
- kde4-base_src_configure
-}
diff --git a/media-sound/kradio/kradio-4.0.3.ebuild b/media-sound/kradio/kradio-4.0.3.ebuild
deleted file mode 100644
index ab9cf4a5b746..000000000000
--- a/media-sound/kradio/kradio-4.0.3.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/kradio/kradio-4.0.3.ebuild,v 1.1 2012/02/15 11:53:09 johu Exp $
-
-EAPI=4
-
-KDE_LINGUAS="cs de es is it pl pt pt_BR ru tr uk"
-inherit kde4-base
-
-MY_P=${PN}4-${PV/_/-}
-
-DESCRIPTION="kradio is a radio tuner application for KDE"
-HOMEPAGE="http://kradio.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-SLOT="4"
-IUSE="alsa debug encode ffmpeg lirc +mp3 +vorbis v4l"
-
-DEPEND="
- media-libs/libsndfile
- alsa? ( media-libs/alsa-lib )
- lirc? ( app-misc/lirc )
- mp3? ( media-sound/lame )
- vorbis? (
- media-libs/libvorbis
- media-libs/libogg
- )
- ffmpeg? (
- >=media-libs/libmms-0.4
- virtual/ffmpeg
- )
-"
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/${MY_P}
-
-src_configure() {
- mycmakeargs=(
- $(cmake-utils_use_with alsa ALSA)
- $(cmake-utils_use_with mp3 LAME)
- $(cmake-utils_use_with vorbis OGG_VORBIS)
- $(cmake-utils_use_with lirc LIRC)
- $(cmake-utils_use_with ffmpeg FFMPEG)
- $(cmake-utils_use_with v4l V4L2)
- )
-
- kde4-base_src_configure
-}