summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2013-01-31 22:42:02 +0000
committerChris Reffett <creffett@gentoo.org>2013-01-31 22:42:02 +0000
commitf6c06445feabf5c054b28c86f728e38e85179683 (patch)
tree52d337ac5766be0a07b14cd5ac8b0c86845e4752 /media-sound/kradio
parentVersion bump (thanks Andrew Savchenko, bug 447204) (diff)
downloadgentoo-2-f6c06445feabf5c054b28c86f728e38e85179683.tar.gz
gentoo-2-f6c06445feabf5c054b28c86f728e38e85179683.tar.bz2
gentoo-2-f6c06445feabf5c054b28c86f728e38e85179683.zip
Version bump wrt bug 454522
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 42618354)
Diffstat (limited to 'media-sound/kradio')
-rw-r--r--media-sound/kradio/ChangeLog9
-rw-r--r--media-sound/kradio/kradio-4.0.7.ebuild72
2 files changed, 79 insertions, 2 deletions
diff --git a/media-sound/kradio/ChangeLog b/media-sound/kradio/ChangeLog
index aa4b1d4886ee..55804f3692d7 100644
--- a/media-sound/kradio/ChangeLog
+++ b/media-sound/kradio/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/kradio
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/kradio/ChangeLog,v 1.34 2012/08/31 11:09:17 johu Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/kradio/ChangeLog,v 1.35 2013/01/31 22:42:02 creffett Exp $
+
+*kradio-4.0.7 (31 Jan 2013)
+
+ 31 Jan 2013; Chris Reffett <creffett@gentoo.org> +kradio-4.0.7.ebuild:
+ Version bump wrt bug 454522
*kradio-4.0.6 (31 Aug 2012)
diff --git a/media-sound/kradio/kradio-4.0.7.ebuild b/media-sound/kradio/kradio-4.0.7.ebuild
new file mode 100644
index 000000000000..906bc1f5ecdb
--- /dev/null
+++ b/media-sound/kradio/kradio-4.0.7.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/kradio/kradio-4.0.7.ebuild,v 1.1 2013/01/31 22:42:02 creffett Exp $
+
+EAPI=5
+
+KDE_LINGUAS_DIR=( po convert-presets/po )
+PLUGINS=(
+ alsa-sound dbus gui-docking-menu gui-error-log gui-quickbar
+ gui-standard-display internetradio lirc oss-sound radio recording shortcuts
+ soundserver streaming timecontrol timeshifter v4lradio
+)
+KDE_LINGUAS="cs de es is it pl pt pt_BR ru sk tr uk"
+inherit kde4-base
+
+MY_P=${PN}4-${PV/_/-}
+
+DESCRIPTION="kradio is a radio tuner application for KDE"
+HOMEPAGE="http://kradio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="4"
+IUSE="alsa debug encode ffmpeg lirc +mp3 +vorbis v4l"
+
+DEPEND="
+ media-libs/libsndfile
+ alsa? ( media-libs/alsa-lib )
+ ffmpeg? (
+ >=media-libs/libmms-0.4
+ virtual/ffmpeg
+ )
+ lirc? ( app-misc/lirc )
+ mp3? ( media-sound/lame )
+ vorbis? (
+ media-libs/libvorbis
+ media-libs/libogg
+ )
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ local lang
+ for lang in ${KDE_LINGUAS} ; do
+ if ! use linguas_${lang} ; then
+ for dir in "${KDE_LINGUAS_DIR[@]}" ; do
+ rm ${dir}/${lang}.po
+ done
+ for plugin in "${PLUGINS[@]}" ; do
+ rm plugins/${plugin}/po/${lang}.po
+ done
+ fi
+ done
+
+ kde4-base_src_prepare
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with alsa)
+ $(cmake-utils_use_with ffmpeg)
+ $(cmake-utils_use_with lirc)
+ $(cmake-utils_use_with mp3 LAME)
+ $(cmake-utils_use_with vorbis OGG_VORBIS)
+ $(cmake-utils_use_with v4l V4L2)
+ )
+
+ kde4-base_src_configure
+}