summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-11-26 15:37:51 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-11-26 15:37:51 +0000
commitf24c0b487485e18f53ed29b47bbea1c99834dcb5 (patch)
tree11f688bb9fc10c07fe01b32b3ea3759657cc45db /media-sound/last-exit/last-exit-6-r1.ebuild
parentMarking enigmail-0.95.7-r2 ppc64 for bug 246628 (diff)
downloadgentoo-2-f24c0b487485e18f53ed29b47bbea1c99834dcb5.tar.gz
gentoo-2-f24c0b487485e18f53ed29b47bbea1c99834dcb5.tar.bz2
gentoo-2-f24c0b487485e18f53ed29b47bbea1c99834dcb5.zip
Fix bug 248892. Also add patch to build against system notify-sharp. Add deps permissive of gtk-sharp-2.12.6.
(Portage version: 2.2_rc16/cvs/Linux 2.6.28-rc4 x86_64)
Diffstat (limited to 'media-sound/last-exit/last-exit-6-r1.ebuild')
-rw-r--r--media-sound/last-exit/last-exit-6-r1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/media-sound/last-exit/last-exit-6-r1.ebuild b/media-sound/last-exit/last-exit-6-r1.ebuild
new file mode 100644
index 000000000000..907e2a32349d
--- /dev/null
+++ b/media-sound/last-exit/last-exit-6-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/last-exit/last-exit-6-r1.ebuild,v 1.1 2008/11/26 15:37:51 loki_val Exp $
+
+EAPI=2
+
+inherit mono gnome2 eutils autotools
+
+DESCRIPTION="Gnome/GTK+ alternative to the last.fm player"
+HOMEPAGE="http://lastexit-player.org/"
+SRC_URI="http://lastexit-player.org/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=gnome-base/gconf-2
+ >=x11-libs/gtk+-2.6
+ >=media-libs/gstreamer-0.10
+ >=media-libs/gst-plugins-base-0.10
+ >=media-plugins/gst-plugins-mad-0.10
+ >=media-plugins/gst-plugins-gconf-0.10
+ >=media-plugins/gst-plugins-gnomevfs-0.10
+ >=dev-lang/mono-1.0
+ || ( >=dev-dotnet/gtk-sharp-2.12.6[glade] ( >=dev-dotnet/gtk-sharp-2 >=dev-dotnet/glade-sharp-2 ) )
+ >=dev-dotnet/gnome-sharp-2
+ >=dev-dotnet/gnomevfs-sharp-2
+ dev-dotnet/notify-sharp
+ >=dev-dotnet/gconf-sharp-2
+ >=dev-libs/dbus-glib-0.71
+ >=dev-dotnet/dbus-sharp-0.6.0
+ >=dev-dotnet/dbus-glib-sharp-0.4.1
+ >=x11-libs/libsexy-0.1.7"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --disable-schemas-install"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+ epatch "${FILESDIR}/${PN}-notify-sharp.patch"
+ eautoreconf
+}
+
+src_configure() {
+ gnome2_src_configure
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+}