summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-07-28 22:36:26 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-07-28 22:36:26 +0000
commite1ab40b7f5522f5c3227b0ef820b2ace2d9233a9 (patch)
treeb130242fb0d9c862def09a594d3c3ada11b6708b /media-sound/lastfmplayer/files
parentMake app-misc/banner block bsd-games. Bug #104086 (diff)
downloadgentoo-2-e1ab40b7f5522f5c3227b0ef820b2ace2d9233a9.tar.gz
gentoo-2-e1ab40b7f5522f5c3227b0ef820b2ace2d9233a9.tar.bz2
gentoo-2-e1ab40b7f5522f5c3227b0ef820b2ace2d9233a9.zip
Add patch to allow compiling on amd64 again thanks to Mehmet Kemal EROL <mehmetkemal@gmx.net> and David Li <matrixhax0r@gmail.com> in bug 141729
(Portage version: 2.1.1_pre3-r5)
Diffstat (limited to 'media-sound/lastfmplayer/files')
-rw-r--r--media-sound/lastfmplayer/files/lastfmplayer-amd64.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-sound/lastfmplayer/files/lastfmplayer-amd64.patch b/media-sound/lastfmplayer/files/lastfmplayer-amd64.patch
new file mode 100644
index 000000000000..bff8283df96a
--- /dev/null
+++ b/media-sound/lastfmplayer/files/lastfmplayer-amd64.patch
@@ -0,0 +1,31 @@
+--- src/Makefile 2006-07-28 00:46:38.325333128 -0400
++++ src/Makefile 2006-07-28 00:46:45.732207112 -0400
+@@ -748,7 +748,7 @@
+ $(CXX) -c $(CXXFLAGS) $(INCPATH) -o build/main.o main.cpp
+
+ build/Loqqer.o: Loqqer.cpp Loqqer.h
+- $(CXX) -c $(CXXFLAGS) $(INCPATH) -o build/Loqqer.o Loqqer.cpp
++ $(CXX) -c $(CXXFLAGS) -fPIC $(INCPATH) -o build/Loqqer.o Loqqer.cpp
+
+ build/container.o: container.cpp container.h \
+ playerlistener.h \
+--- src/wizardselectupdatespage.cpp 2006-07-28 14:32:19.099658720 -0400
++++ src/wizardselectupdatespage.cpp 2006-07-28 15:29:14.400454080 -0400
+@@ -86,7 +86,7 @@
+ item->setCheckState(nCheck == 1 ? Qt::Checked : Qt::Unchecked);
+
+ // Store its pointer along with string
+- item->setData(1, reinterpret_cast<unsigned int>(&current));
++ item->setData(1, reinterpret_cast<unsigned long long>(&current));
+ }
+ }
+
+@@ -122,7 +122,7 @@
+ {
+ CComponentInfo* pComp =
+ reinterpret_cast<CComponentInfo*>(
+- ui.updatesList->item(i)->data(1).toUInt());
++ ui.updatesList->item(i)->data(1).toULongLong());
+ vecChecked.push_back(pComp);
+ }
+ }