summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2009-07-29 20:49:39 +0000
committerRyan Hill <dirtyepic@gentoo.org>2009-07-29 20:49:39 +0000
commitd5e54b00cf4546af09c6105951e5bee26460f714 (patch)
tree5c35f980fc94aad0cf129e4b5feb6bd699496b61 /media-sound/lilypond/lilypond-2.12.2.ebuild
parentThere's no package called alsa-patch-bay in portage anymore. (diff)
downloadgentoo-2-d5e54b00cf4546af09c6105951e5bee26460f714.tar.gz
gentoo-2-d5e54b00cf4546af09c6105951e5bee26460f714.tar.bz2
gentoo-2-d5e54b00cf4546af09c6105951e5bee26460f714.zip
Fix build w/ glibc-2.10. (bug #270718)
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/lilypond/lilypond-2.12.2.ebuild')
-rw-r--r--media-sound/lilypond/lilypond-2.12.2.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/media-sound/lilypond/lilypond-2.12.2.ebuild b/media-sound/lilypond/lilypond-2.12.2.ebuild
index 41612c7130f3..b4547bc1e90f 100644
--- a/media-sound/lilypond/lilypond-2.12.2.ebuild
+++ b/media-sound/lilypond/lilypond-2.12.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lilypond/lilypond-2.12.2.ebuild,v 1.2 2009/05/26 05:56:51 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lilypond/lilypond-2.12.2.ebuild,v 1.3 2009/07/29 20:49:39 dirtyepic Exp $
inherit eutils versionator toolchain-funcs elisp-common
@@ -53,6 +53,12 @@ pkg_setup() {
fi
}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-glibc-2.10.patch
+}
+
src_compile() {
if [[ $(gcc-major-version) -lt 4 ]]; then
eerror "You need GCC 4.x to build this software."