summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2009-04-16 16:39:07 +0000
committerTony Vroon <chainsaw@gentoo.org>2009-04-16 16:39:07 +0000
commitca3a99fae8774844e13c5ba7b52601f82544effd (patch)
tree5479f5fdbec903363584d1713743a2542e6d19c5 /media-sound/mp3gain/mp3gain-1.4.6-r3.ebuild
parentmanifesting (diff)
downloadgentoo-2-ca3a99fae8774844e13c5ba7b52601f82544effd.tar.gz
gentoo-2-ca3a99fae8774844e13c5ba7b52601f82544effd.tar.bz2
gentoo-2-ca3a99fae8774844e13c5ba7b52601f82544effd.zip
Patch by Joshua Rich to respect LDFLAGS, closes bug #264134. Remove old ebuild.
(Portage version: 2.1.6.11/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/mp3gain/mp3gain-1.4.6-r3.ebuild')
-rw-r--r--media-sound/mp3gain/mp3gain-1.4.6-r3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-sound/mp3gain/mp3gain-1.4.6-r3.ebuild b/media-sound/mp3gain/mp3gain-1.4.6-r3.ebuild
new file mode 100644
index 000000000000..a988fdf9225b
--- /dev/null
+++ b/media-sound/mp3gain/mp3gain-1.4.6-r3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mp3gain/mp3gain-1.4.6-r3.ebuild,v 1.1 2009/04/16 16:39:07 chainsaw Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+IUSE=""
+
+MY_P=${P//./_}
+S=${WORKDIR}
+
+DESCRIPTION="MP3Gain automatically adjusts mp3s so that they all have the same volume"
+HOMEPAGE="http://mp3gain.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}-src.zip"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ filter-flags -O*
+ sed -i -e "s:CC=.*:CC=$(tc-getCC):" \
+ -e "s:CFLAGS= -Wall -O3 -DHAVE_MEMCPY:CFLAGS+= -Wall -DHAVE_MEMCPY:" \
+ -e "s:LIBS=.*:LIBS= ${LDFLAGS} -lm:" \
+ "${S}"/Makefile \
+ || die "Unable to adjust build system compiler/flags."
+ epatch "${FILESDIR}"/${PV}-option-parser.patch
+}
+
+src_install () {
+ dobin mp3gain
+}