summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-11-23 20:03:35 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-11-23 20:03:35 +0000
commitcfe4aae04aba18f769688dff94391c9b09de8c7b (patch)
treec9eac2385780b2dbc6f370c32e8422e259558139 /media-sound/mp3splt/mp3splt-2.1.ebuild
parentRecommitting 'cause the manifest didn't get updated. (Manifest recommit) (diff)
downloadgentoo-2-cfe4aae04aba18f769688dff94391c9b09de8c7b.tar.gz
gentoo-2-cfe4aae04aba18f769688dff94391c9b09de8c7b.tar.bz2
gentoo-2-cfe4aae04aba18f769688dff94391c9b09de8c7b.zip
--enable-ogg is broken...
Diffstat (limited to 'media-sound/mp3splt/mp3splt-2.1.ebuild')
-rw-r--r--media-sound/mp3splt/mp3splt-2.1.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/media-sound/mp3splt/mp3splt-2.1.ebuild b/media-sound/mp3splt/mp3splt-2.1.ebuild
index 72dcc6dcc418..5723d6b86d92 100644
--- a/media-sound/mp3splt/mp3splt-2.1.ebuild
+++ b/media-sound/mp3splt/mp3splt-2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mp3splt/mp3splt-2.1.ebuild,v 1.1 2004/11/21 21:41:37 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mp3splt/mp3splt-2.1.ebuild,v 1.2 2004/11/23 20:03:35 eradicator Exp $
IUSE="oggvorbis"
@@ -17,7 +17,11 @@ DEPEND="oggvorbis? ( media-libs/libogg
media-libs/libmad"
src_compile() {
- econf $(use_enable oggvorbis ogg) || die "econf failed"
+ local myconf
+
+ # --enable-ogg doesn't enable ogg...
+ use oggvorbis || myconf="--disable-ogg"
+ econf ${myconf} || die "econf failed"
emake || die "build failed"
}