summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-05-11 17:55:35 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-05-11 17:55:35 +0000
commit7af5c58b574b671ea8a1ccbbda05bb26e6cd2709 (patch)
treefb911cbbd34d6d293f4d1bceab4775b11e594f1f /media-sound/mt-daapd/mt-daapd-0.2.4.2.ebuild
parentActually add the patch files. Nice wildcard handling, CVS! (diff)
downloadgentoo-2-7af5c58b574b671ea8a1ccbbda05bb26e6cd2709.tar.gz
gentoo-2-7af5c58b574b671ea8a1ccbbda05bb26e6cd2709.tar.bz2
gentoo-2-7af5c58b574b671ea8a1ccbbda05bb26e6cd2709.zip
Apply patch to fix compile with USE -vorbis wrt #200629.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/mt-daapd/mt-daapd-0.2.4.2.ebuild')
-rw-r--r--media-sound/mt-daapd/mt-daapd-0.2.4.2.ebuild36
1 files changed, 12 insertions, 24 deletions
diff --git a/media-sound/mt-daapd/mt-daapd-0.2.4.2.ebuild b/media-sound/mt-daapd/mt-daapd-0.2.4.2.ebuild
index 60e12724e1e2..266aa45e590f 100644
--- a/media-sound/mt-daapd/mt-daapd-0.2.4.2.ebuild
+++ b/media-sound/mt-daapd/mt-daapd-0.2.4.2.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mt-daapd/mt-daapd-0.2.4.2.ebuild,v 1.5 2008/09/27 16:25:25 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mt-daapd/mt-daapd-0.2.4.2.ebuild,v 1.6 2009/05/11 17:55:35 ssuominen Exp $
+EAPI=2
inherit autotools eutils
DESCRIPTION="A multi-threaded implementation of Apple's DAAP server"
@@ -11,29 +12,17 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 arm ~mips ppc sh sparc x86"
-IUSE="avahi vorbis"
+IUSE="+avahi vorbis"
RDEPEND="media-libs/libid3tag
sys-libs/gdbm
- avahi? ( net-dns/avahi )
+ avahi? ( net-dns/avahi[dbus] )
!avahi? ( net-misc/mDNSResponder )
vorbis? ( media-libs/libvorbis )"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-pkg_setup() {
- local fail="Re-emerge net-dns/avahi with USE dbus."
-
- if use avahi && ! built_with_use net-dns/avahi dbus; then
- eerror "${fail}"
- die "${fail}"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
cp "${FILESDIR}"/${PN}.init.2 initd
if use avahi; then
@@ -42,14 +31,15 @@ src_unpack() {
sed -i -e 's:#USEHOWL ::' initd
fi
- epatch "${FILESDIR}"/${PN}-0.2.3-sparc.patch
- epatch "${FILESDIR}"/${PN}-0.2.4.1-libsorder.patch
- epatch "${FILESDIR}"/${PN}-0.2.4.1-pidfile.patch
- epatch "${FILESDIR}"/${P}-maintainer-mode.patch
+ epatch "${FILESDIR}"/${PN}-0.2.3-sparc.patch \
+ "${FILESDIR}"/${PN}-0.2.4.1-libsorder.patch \
+ "${FILESDIR}"/${PN}-0.2.4.1-pidfile.patch \
+ "${FILESDIR}"/${P}-maintainer-mode.patch \
+ "${FILESDIR}"/${P}-oggvorbis.patch
eautoreconf
}
-src_compile() {
+src_configure() {
local myconf
if use avahi; then
@@ -61,8 +51,6 @@ src_compile() {
econf $(use_enable vorbis oggvorbis) \
--disable-maintainer-mode \
${myconf}
-
- emake || die "emake failed."
}
src_install() {