summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-08-31 10:21:15 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-08-31 10:21:15 +0000
commit7a70643d9300e2e6d1b3f878add35f2c39ae218c (patch)
tree18cb0d1cf8949bcca7f6af2f60dd22017ef51274 /media-sound/mt-daapd
parentVersion bump, thanks to Thomas in bug #143683. (diff)
downloadgentoo-2-7a70643d9300e2e6d1b3f878add35f2c39ae218c.tar.gz
gentoo-2-7a70643d9300e2e6d1b3f878add35f2c39ae218c.tar.bz2
gentoo-2-7a70643d9300e2e6d1b3f878add35f2c39ae218c.zip
New nightlie.
(Portage version: 2.1.1_rc1-r2)
Diffstat (limited to 'media-sound/mt-daapd')
-rw-r--r--media-sound/mt-daapd/ChangeLog8
-rw-r--r--media-sound/mt-daapd/files/digest-mt-daapd-0.3.0_pre13723
-rw-r--r--media-sound/mt-daapd/mt-daapd-0.3.0_pre1372.ebuild143
3 files changed, 153 insertions, 1 deletions
diff --git a/media-sound/mt-daapd/ChangeLog b/media-sound/mt-daapd/ChangeLog
index 269784e0c743..317b756ca609 100644
--- a/media-sound/mt-daapd/ChangeLog
+++ b/media-sound/mt-daapd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/mt-daapd
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mt-daapd/ChangeLog,v 1.43 2006/07/29 07:34:28 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mt-daapd/ChangeLog,v 1.44 2006/08/31 10:21:15 flameeyes Exp $
+
+*mt-daapd-0.3.0_pre1372 (31 Aug 2006)
+
+ 31 Aug 2006; Diego Pettenò <flameeyes@gentoo.org>
+ -mt-daapd-0.3.0_pre1328.ebuild, +mt-daapd-0.3.0_pre1372.ebuild:
+ New nightlie.
*mt-daapd-0.3.0_pre1328 (29 Jul 2006)
diff --git a/media-sound/mt-daapd/files/digest-mt-daapd-0.3.0_pre1372 b/media-sound/mt-daapd/files/digest-mt-daapd-0.3.0_pre1372
new file mode 100644
index 000000000000..d050ba899077
--- /dev/null
+++ b/media-sound/mt-daapd/files/digest-mt-daapd-0.3.0_pre1372
@@ -0,0 +1,3 @@
+MD5 01914e17668a250aaf5bd508397da1a4 mt-daapd-svn-1372.tar.gz 1131512
+RMD160 1955a54469dfea1978753e6800ea22eac3ac9f01 mt-daapd-svn-1372.tar.gz 1131512
+SHA256 023b217ae0225934b4a4b21013ad3c7c8bb3152db8605559e6c1a72d6f0f011a mt-daapd-svn-1372.tar.gz 1131512
diff --git a/media-sound/mt-daapd/mt-daapd-0.3.0_pre1372.ebuild b/media-sound/mt-daapd/mt-daapd-0.3.0_pre1372.ebuild
new file mode 100644
index 000000000000..87eda185843a
--- /dev/null
+++ b/media-sound/mt-daapd/mt-daapd-0.3.0_pre1372.ebuild
@@ -0,0 +1,143 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mt-daapd/mt-daapd-0.3.0_pre1372.ebuild,v 1.1 2006/08/31 10:21:15 flameeyes Exp $
+
+inherit eutils flag-o-matic base
+
+SVN="${PV#*pre}"
+
+if [[ -n ${SVN} ]] ; then
+ MY_P="${PN}-svn-${SVN}"
+ SRC_URI="http://nightlies.mt-daapd.org/${MY_P}.tar.gz"
+else
+ MY_P="${P/_/-}"
+ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+fi
+
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="A multi-threaded implementation of Apple's DAAP server"
+HOMEPAGE="http://www.mt-daapd.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc-macos ~sh ~sparc ~x86"
+IUSE="howl vorbis avahi sqlite3 flac ffmpeg"
+
+DEPEND="sys-libs/zlib
+ media-libs/libid3tag
+ !sqlite3? ( =dev-db/sqlite-2* )
+ sqlite3? ( =dev-db/sqlite-3* )
+ howl? ( !avahi? ( >=net-misc/howl-0.9.2 )
+ avahi? ( net-dns/avahi ) )
+ vorbis? ( media-libs/libvorbis )
+ flac? ( media-libs/flac )
+ ffmpeg? ( media-video/ffmpeg )"
+
+pkg_setup() {
+ if use howl && use avahi && ! built_with_use net-dns/avahi howl-compat; then
+ eerror "You requested avahi support, but this package requires"
+ eerror "the howl-compat support enabled in net-dns/avahi to work"
+ eerror "with it."
+ eerror
+ eerror "Please recompile net-dns/avahi with +howl-compat."
+ die "Missing howl-compat support in avahi."
+ fi
+}
+
+src_compile() {
+ local myconf=""
+ local howlincludes
+
+ append-flags -fno-strict-aliasing
+
+ # howl support?
+ if use howl; then
+ use avahi && \
+ howlincludes="/usr/include/avahi-compat-howl" || \
+ howlincludes="/usr/include/howl"
+
+ myconf="${myconf}
+ --enable-howl
+ --with-howl-libs=/usr/$(get_libdir)
+ --with-howl-includes=${howlincludes}"
+ fi
+
+ # Bug 65723
+ if use vorbis; then
+ myconf="${myconf} --enable-oggvorbis"
+ fi
+
+ econf \
+ $(use_enable vorbis oggvorbis) \
+ $(use_enable flac) \
+ $(use_enable !sqlite3 sqlite) \
+ $(use_enable sqlite3) \
+ $(use_enable ffmpeg) \
+ --with-ffmpeg-includes=${ROOT}/usr/include/ffmpeg \
+ ${myconf} || die "configure failed"
+ emake || die "make failed"
+
+ cp ${FILESDIR}/${PN}.init.2 ${WORKDIR}/initd
+ if ! use howl; then
+ sed -i -e '/#USEHOWL/d' ${WORKDIR}/initd
+ elif ! use avahi; then
+ sed -i -e 's:#USEHOWL ::' ${WORKDIR}/initd
+ else
+ sed -i -e 's:#USEHOWL ::; s:mDNSResponder:avahi-daemon:' ${WORKDIR}/initd
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+
+ insinto /etc
+ newins ${FILESDIR}/mt-daapd.conf.example mt-daapd.conf.example
+ doins contrib/mt-daapd.playlist
+
+ newinitd ${WORKDIR}/initd ${PN}
+
+ keepdir /var/cache/mt-daapd /etc/mt-daapd.d
+
+ dodoc AUTHORS CREDITS ChangeLog NEWS README TODO
+}
+
+pkg_postinst() {
+ einfo
+ elog "You have to configure your mt-daapd.conf following"
+ elog "/etc/mt-daapd.conf.example file."
+ einfo
+
+ if use howl; then
+ use avahi && \
+ howlservice="avahi-daemon" || \
+ howlservice="mDNSResponder"
+
+ einfo
+ elog "Since you want to use howl instead of the internal mdnsd"
+ elog "you need to make sure that you have ${howlservice} configured"
+ elog "and running to use mt-daapd."
+ einfo
+
+ if use avahi; then
+ elog "Avahi support is currently experimental, it does not work"
+ elog "as intended when using more than one mt-daapd instance."
+ elog "If you want to run more than one mt-daapd, just use the"
+ elog "internal mdnsd by building with -howl flag."
+ fi
+ fi
+
+ if use vorbis; then
+ einfo
+ elog "You need to edit you extensions list in /etc/mt-daapd.conf"
+ elog "if you want your mt-daapd to serve ogg files."
+ einfo
+ fi
+
+ einfo
+ elog "If you want to start more than one ${PN} service, symlink"
+ elog "/etc/init.d/${PN} to /etc/init.d/${PN}.<name>, and it will"
+ elog "load the data from /etc/${PN}.d/<name>.conf."
+ elog "Make sure that you have different cache directories for them."
+ einfo
+}