summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-05-12 11:33:43 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-05-12 11:33:43 +0000
commit243291cd6b3eecd1c66fc1e3c93e3d771cfabd74 (patch)
tree82d71266e08494e606248be243929ea9dfcd02da /media-sound/ogg2mp3
parentFix SRC_URI wrt #250223, thanks to Thomas Beierlein. (diff)
downloadgentoo-2-243291cd6b3eecd1c66fc1e3c93e3d771cfabd74.tar.gz
gentoo-2-243291cd6b3eecd1c66fc1e3c93e3d771cfabd74.tar.bz2
gentoo-2-243291cd6b3eecd1c66fc1e3c93e3d771cfabd74.zip
Patch to prevent endian swapping by Boris Petersen wrt #238855.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/ogg2mp3')
-rw-r--r--media-sound/ogg2mp3/ChangeLog10
-rw-r--r--media-sound/ogg2mp3/files/ogg2mp3-0.5-prevent_endian_swapping.patch12
-rw-r--r--media-sound/ogg2mp3/ogg2mp3-0.5-r1.ebuild29
-rw-r--r--media-sound/ogg2mp3/ogg2mp3-0.5.ebuild13
4 files changed, 55 insertions, 9 deletions
diff --git a/media-sound/ogg2mp3/ChangeLog b/media-sound/ogg2mp3/ChangeLog
index 137a3926585e..7b7b5482f55f 100644
--- a/media-sound/ogg2mp3/ChangeLog
+++ b/media-sound/ogg2mp3/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/ogg2mp3
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ogg2mp3/ChangeLog,v 1.6 2007/02/03 19:51:17 flameeyes Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ogg2mp3/ChangeLog,v 1.7 2009/05/12 11:33:42 ssuominen Exp $
+
+*ogg2mp3-0.5-r1 (12 May 2009)
+
+ 12 May 2009; Samuli Suominen <ssuominen@gentoo.org>
+ +ogg2mp3-0.5-r1.ebuild, +files/ogg2mp3-0.5-prevent_endian_swapping.patch:
+ Patch to prevent endian swapping by Boris Petersen wrt #238855.
03 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/media-sound/ogg2mp3/files/ogg2mp3-0.5-prevent_endian_swapping.patch b/media-sound/ogg2mp3/files/ogg2mp3-0.5-prevent_endian_swapping.patch
new file mode 100644
index 000000000000..024b1b1734eb
--- /dev/null
+++ b/media-sound/ogg2mp3/files/ogg2mp3-0.5-prevent_endian_swapping.patch
@@ -0,0 +1,12 @@
+diff -ur ogg2mp3-0.5.orig/ogg2mp3 ogg2mp3-0.5/ogg2mp3
+--- ogg2mp3-0.5.orig/ogg2mp3 2005-05-16 21:07:33.000000000 +0300
++++ ogg2mp3-0.5/ogg2mp3 2009-05-12 14:30:00.000000000 +0300
+@@ -311,7 +311,7 @@
+ # this took me some time to figure
+ # note that byte order is swapped by lame via -x option
+ # TODO: somebody please tell me how to supress the "Assuming bla bla" output without devnull
+- $result = system("$OGG123 $decquiet -d raw -f - $oggfile_escaped | $MP3ENC $encquiet -r -x -q $quality -b $bitrate -s $frequency -m $channels $infostring - $mp3outputfile_escaped");
++ $result = system("$OGG123 $decquiet -d raw -f - $oggfile_escaped | $MP3ENC $encquiet -r -q $quality -b $bitrate -s $frequency -m $channels $infostring - $mp3outputfile_escaped");
+
+ # TODO: find some widely used mp3 checker
+ # disabled the checking due to lack of checker
diff --git a/media-sound/ogg2mp3/ogg2mp3-0.5-r1.ebuild b/media-sound/ogg2mp3/ogg2mp3-0.5-r1.ebuild
new file mode 100644
index 000000000000..82df61fec6d4
--- /dev/null
+++ b/media-sound/ogg2mp3/ogg2mp3-0.5-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ogg2mp3/ogg2mp3-0.5-r1.ebuild,v 1.1 2009/05/12 11:33:42 ssuominen Exp $
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="A perl script to convert Ogg Vorbis files to MP3 files."
+HOMEPAGE="http://amor.cms.hu-berlin.de/~h0444y2j/linux.html"
+SRC_URI="http://amor.cms.hu-berlin.de/~h0444y2j/pub/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="media-sound/lame
+ dev-perl/String-ShellQuote
+ media-sound/vorbis-tools"
+DEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-prevent_endian_swapping.patch
+}
+
+src_install() {
+ dobin ogg2mp3 || die "dobin failed"
+ dodoc doc/{AUTHORS,ChangeLog,README,TODO}
+}
diff --git a/media-sound/ogg2mp3/ogg2mp3-0.5.ebuild b/media-sound/ogg2mp3/ogg2mp3-0.5.ebuild
index 57bb7287fe8f..ae36e4062978 100644
--- a/media-sound/ogg2mp3/ogg2mp3-0.5.ebuild
+++ b/media-sound/ogg2mp3/ogg2mp3-0.5.ebuild
@@ -1,23 +1,22 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ogg2mp3/ogg2mp3-0.5.ebuild,v 1.3 2005/08/23 22:32:04 chainsaw Exp $
-
-IUSE=""
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ogg2mp3/ogg2mp3-0.5.ebuild,v 1.4 2009/05/12 11:33:42 ssuominen Exp $
DESCRIPTION="A perl script to convert Ogg Vorbis files to MP3 files."
-
HOMEPAGE="http://amor.cms.hu-berlin.de/~h0444y2j/linux.html"
SRC_URI="http://amor.cms.hu-berlin.de/~h0444y2j/pub/${P}.tar.bz2"
LICENSE="GPL-2"
-
SLOT="0"
KEYWORDS="~amd64 ~ppc x86"
+IUSE=""
RDEPEND="media-sound/lame
dev-perl/String-ShellQuote
media-sound/vorbis-tools"
+DEPEND=""
src_install() {
- dobin ogg2mp3
+ dobin ogg2mp3 || die "dobin failed"
+ dodoc doc/{AUTHORS,ChangeLog,README,TODO}
}