summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-01-13 09:00:12 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-01-13 09:00:12 +0000
commit08791b90ee38dd78fe5efda074eec57a5299b96b (patch)
tree565ceacab300f66f795f563ddc61226d8324ed23 /media-sound/patchage/patchage-0.5.0.ebuild
parentversion bump (diff)
downloadgentoo-2-08791b90ee38dd78fe5efda074eec57a5299b96b.tar.gz
gentoo-2-08791b90ee38dd78fe5efda074eec57a5299b96b.tar.bz2
gentoo-2-08791b90ee38dd78fe5efda074eec57a5299b96b.zip
version bump
(Portage version: 2.2.0_alpha15/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/patchage/patchage-0.5.0.ebuild')
-rw-r--r--media-sound/patchage/patchage-0.5.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/media-sound/patchage/patchage-0.5.0.ebuild b/media-sound/patchage/patchage-0.5.0.ebuild
new file mode 100644
index 000000000000..b559cc386223
--- /dev/null
+++ b/media-sound/patchage/patchage-0.5.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/patchage/patchage-0.5.0.ebuild,v 1.1 2011/01/13 09:00:12 aballier Exp $
+
+EAPI=2
+
+inherit toolchain-funcs
+
+DESCRIPTION="Modular patch bay for audio and MIDI systems"
+HOMEPAGE="http://wiki.drobilla.net/Patchage"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa debug lash"
+
+RDEPEND=">=media-libs/raul-0.5.1
+ >=x11-libs/flowcanvas-0.7.1
+ >=dev-cpp/gtkmm-2.11.12
+ >=dev-cpp/glibmm-2.14
+ >=dev-cpp/libglademm-2.6.0
+ dev-cpp/libgnomecanvasmm
+ dev-libs/boost
+ >=media-sound/jack-audio-connection-kit-0.107
+ alsa? ( media-libs/alsa-lib )
+ lash? ( dev-libs/dbus-glib )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ tc-export CC CXX CPP AR RANLIB
+ ./waf configure \
+ --prefix=/usr \
+ $(use debug && echo "--debug") \
+ $(use alsa || echo "--no-alsa") \
+ $(use lash || echo "--no-lash") \
+ || die
+}
+
+src_compile() {
+ ./waf || die
+}
+
+src_install() {
+ ./waf install --destdir="${D}" || die
+ dodoc AUTHORS README ChangeLog || die
+}