summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-05-20 15:26:44 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-05-20 15:26:44 +0000
commit3997cb5d62532cab9e5c3ce3679f180ec6a169ad (patch)
treed308a5c141386e0a309f3fcd32a227fd9e4efd2a /media-sound/picard
parentFix exec_prefix in pkg-config file. (diff)
downloadgentoo-2-3997cb5d62532cab9e5c3ce3679f180ec6a169ad.tar.gz
gentoo-2-3997cb5d62532cab9e5c3ce3679f180ec6a169ad.tar.bz2
gentoo-2-3997cb5d62532cab9e5c3ce3679f180ec6a169ad.zip
version bump, bug #463982
(Portage version: 2.2.0_alpha176/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-sound/picard')
-rw-r--r--media-sound/picard/ChangeLog7
-rw-r--r--media-sound/picard/picard-1.2.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/media-sound/picard/ChangeLog b/media-sound/picard/ChangeLog
index 84eb43bc3bf4..7cc62aeda512 100644
--- a/media-sound/picard/ChangeLog
+++ b/media-sound/picard/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/picard
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/picard/ChangeLog,v 1.44 2013/01/14 04:14:22 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/picard/ChangeLog,v 1.45 2013/05/20 15:26:44 aballier Exp $
+
+*picard-1.2 (20 May 2013)
+
+ 20 May 2013; Alexis Ballier <aballier@gentoo.org> +picard-1.2.ebuild:
+ version bump, bug #463982
14 Jan 2013; Tim Harder <radhermit@gentoo.org> -picard-0.15.1-r1.ebuild,
-picard-0.16.ebuild, -picard-1.0.ebuild, metadata.xml:
diff --git a/media-sound/picard/picard-1.2.ebuild b/media-sound/picard/picard-1.2.ebuild
new file mode 100644
index 000000000000..0f55b9998ff4
--- /dev/null
+++ b/media-sound/picard/picard-1.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/picard/picard-1.2.ebuild,v 1.1 2013/05/20 15:26:44 aballier Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 2.6 3.*"
+
+inherit eutils distutils
+
+MY_P="${P/_/}"
+DESCRIPTION="An improved rewrite/port of the Picard Tagger using Qt"
+HOMEPAGE="http://musicbrainz.org/doc/PicardQt"
+SRC_URI="http://ftp.musicbrainz.org/pub/musicbrainz/picard/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+acoustid +cdda nls"
+
+DEPEND="dev-python/PyQt4[X]
+ media-libs/mutagen
+ acoustid? ( media-libs/chromaprint[tools] )
+ cdda? ( >=media-libs/libdiscid-0.1.1 )
+ "
+RDEPEND="${DEPEND}"
+
+# doesn't work with ebuilds
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="AUTHORS.txt NEWS.txt"
+
+src_compile() {
+ distutils_src_compile $(use nls || echo "--disable-locales")
+}
+
+src_install() {
+ distutils_src_install --disable-autoupdate --skip-build \
+ $(use nls || echo "--disable-locales")
+
+ doicon picard.ico
+ domenu picard.desktop
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ echo
+ ewarn "If you are upgrading Picard and it does not start"
+ ewarn "try removing Picard's settings:"
+ ewarn " rm ~/.config/MusicBrainz/Picard.conf"
+ elog
+ elog "You should set the environment variable BROWSER to something like"
+ elog "\"firefox '%s' &\" to let python know which browser to use."
+}