summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2012-07-12 15:29:33 +0000
committerBen de Groot <yngwin@gentoo.org>2012-07-12 15:29:33 +0000
commit857f7089cbc5bc6b7d98f5a0fabd8b627d626267 (patch)
tree139bc5911ffeaa622c56820f4c975b34289fdf04 /media-sound/picard
parentadded GPL-2 to LICENSE per bug 425888 (diff)
downloadgentoo-2-857f7089cbc5bc6b7d98f5a0fabd8b627d626267.tar.gz
gentoo-2-857f7089cbc5bc6b7d98f5a0fabd8b627d626267.tar.bz2
gentoo-2-857f7089cbc5bc6b7d98f5a0fabd8b627d626267.zip
Version bump, thanks to Benedikt Waldvogel in bug #419425 and Laurent Bachelier in bug #401193 for suggested ebuild improvements. Also fixes bug #323007.
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/picard')
-rw-r--r--media-sound/picard/ChangeLog13
-rw-r--r--media-sound/picard/metadata.xml5
-rw-r--r--media-sound/picard/picard-1.0.ebuild81
3 files changed, 95 insertions, 4 deletions
diff --git a/media-sound/picard/ChangeLog b/media-sound/picard/ChangeLog
index f202b34f7f5f..025adebf8854 100644
--- a/media-sound/picard/ChangeLog
+++ b/media-sound/picard/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-sound/picard
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/picard/ChangeLog,v 1.37 2011/11/04 17:09:06 radhermit Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/picard/ChangeLog,v 1.38 2012/07/12 15:29:33 yngwin Exp $
+
+*picard-1.0 (12 Jul 2012)
+
+ 12 Jul 2012; Ben de Groot <yngwin@gentoo.org> +picard-1.0.ebuild,
+ metadata.xml:
+ Version bump, thanks to Benedikt Waldvogel in bug #419425 and Laurent
+ Bachelier in bug #401193 for suggested ebuild improvements. Also fixes bug
+ #323007.
04 Nov 2011; Tim Harder <radhermit@gentoo.org> -picard-0.12.1-r1.ebuild,
-picard-0.13.ebuild, -files/picard-0.13-ffmpeg.patch, -picard-0.14.ebuild:
@@ -171,4 +179,3 @@
+files/picard-0.9.0_alpha14-disable-locales.patch, +metadata.xml,
+picard-0.9.0_alpha14.ebuild:
Initial ebuild wrt bug #80312. Thanks to Marti Raudsepp.
-
diff --git a/media-sound/picard/metadata.xml b/media-sound/picard/metadata.xml
index 6d0ec7d3fdf1..7576d2c00537 100644
--- a/media-sound/picard/metadata.xml
+++ b/media-sound/picard/metadata.xml
@@ -6,5 +6,8 @@
written in Python. Picard Tagger is intended to be the next generation of
tagger for MusicBrainz, with a focus on album oriented tagging as opposed to
track based tagging and cross platform compatibility.</longdescription>
-<use><flag name='coverart'>Install plugin for direct coverart dowload</flag></use>
+<use>
+ <flag name='acoustid'>Use media-libs/chromaprint for acoustic fingerprinting</flag>
+ <flag name='coverart'>Install plugin for direct coverart dowload</flag>
+</use>
</pkgmetadata>
diff --git a/media-sound/picard/picard-1.0.ebuild b/media-sound/picard/picard-1.0.ebuild
new file mode 100644
index 000000000000..bc90a94921ed
--- /dev/null
+++ b/media-sound/picard/picard-1.0.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/picard/picard-1.0.ebuild,v 1.1 2012/07/12 15:29:33 yngwin Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+
+inherit eutils distutils
+
+MY_P="${P/_/}"
+DESCRIPTION="An improved rewrite/port of the Picard Tagger using Qt"
+HOMEPAGE="http://musicbrainz.org/doc/PicardQt"
+SRC_URI="http://ftp.musicbrainz.org/pub/musicbrainz/picard/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+acoustid +cdda +ffmpeg nls"
+
+DEPEND="dev-python/PyQt4[X]
+ media-libs/mutagen
+ acoustid? ( media-libs/chromaprint[tools] )
+ cdda? ( >=media-libs/libdiscid-0.1.1 )
+ ffmpeg? ( virtual/ffmpeg
+ >=media-libs/libofa-0.9.2 )"
+RDEPEND="${DEPEND}"
+
+# doesn't work with ebuilds
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="AUTHORS.txt NEWS.txt"
+
+pkg_setup() {
+ if ! use acoustid && ! use ffmpeg; then
+ ewarn "The 'acoustid' and 'ffmpeg' USE flag are disabled."
+ ewarn "Acoustic fingerprinting and recognition will not be available."
+ fi
+ if ! use cdda; then
+ ewarn "The 'cdda' USE flag is disabled. CD index lookup and"
+ ewarn "identification will not be available. You can get audio CD support"
+ ewarn "by installing media-libs/libdiscid."
+ fi
+ python_pkg_setup
+}
+
+src_configure() {
+ $(PYTHON -f) setup.py config || die "setup.py config failed"
+ if ! use ffmpeg; then
+ sed -i -e "s:\(^with-avcodec\ =\ \).*:\1False:" \
+ -e "s:\(^with-libofa\ =\ \).*:\1False:" \
+ build.cfg || die "sed failed"
+ fi
+}
+
+src_compile() {
+ distutils_src_compile $(use nls || echo "--disable-locales")
+}
+
+src_install() {
+ distutils_src_install --disable-autoupdate --skip-build \
+ $(use nls || echo "--disable-locales")
+
+ doicon picard.ico
+ domenu picard.desktop
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ echo
+ ewarn "If you are upgrading Picard and it does not start"
+ ewarn "try removing Picard's settings:"
+ ewarn " rm ~/.config/MusicBrainz/Picard.conf"
+ elog
+ elog "You should set the environment variable BROWSER to something like"
+ elog "\"firefox '%s' &\" to let python know which browser to use."
+}