summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2013-07-11 17:06:04 +0000
committerPatrick McLean <chutzpah@gentoo.org>2013-07-11 17:06:04 +0000
commit6997fbebae87bf8d8ff98b44daec6116da542469 (patch)
treee315366d0eecdb072bf75252dedd1764bce042a8 /media-sound/pithos/pithos-99999999.ebuild
parentdev-libs/quazip: Enable testsuite (diff)
downloadgentoo-2-6997fbebae87bf8d8ff98b44daec6116da542469.tar.gz
gentoo-2-6997fbebae87bf8d8ff98b44daec6116da542469.tar.bz2
gentoo-2-6997fbebae87bf8d8ff98b44daec6116da542469.zip
Rename pithos-9999 to pithos-99999999 so the live will have a higher version that the release.
(Portage version: 2.1.12.13/cvs/Linux x86_64, signed Manifest commit with key 5C350883)
Diffstat (limited to 'media-sound/pithos/pithos-99999999.ebuild')
-rw-r--r--media-sound/pithos/pithos-99999999.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/media-sound/pithos/pithos-99999999.ebuild b/media-sound/pithos/pithos-99999999.ebuild
new file mode 100644
index 000000000000..00bea458d062
--- /dev/null
+++ b/media-sound/pithos/pithos-99999999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pithos/pithos-99999999.ebuild,v 1.1 2013/07/11 17:06:04 chutzpah Exp $
+
+EAPI=5
+PYTHON_COMPAT=(python2_7)
+inherit eutils distutils-r1
+
+if [[ ${PV} == 99999999 ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/kevinmehall/pithos.git
+ https://github.com/kevinmehall/pithos.git"
+else
+ MY_PV=""
+ SRC_URI="https://github.com/kevinmehall/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+fi
+
+DESCRIPTION="A Pandora Radio (pandora.com) player for the GNOME Desktop"
+HOMEPAGE="http://kevinmehall.net/p/pithos/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE="gnome"
+
+DEPEND="dev-python/setuptools"
+
+RDEPEND="dev-python/pyxdg
+ dev-python/pygobject:2
+ dev-python/notify-python
+ dev-python/pygtk
+ dev-python/gst-python
+ dev-python/dbus-python
+ media-plugins/gst-plugins-meta[aac,http,mp3]
+ gnome? ( gnome-base/gnome-settings-daemon )
+ !gnome? ( dev-libs/keybinder[python] )"
+
+src_prepare() {
+ # replace the build system with something more sane
+ epatch "${FILESDIR}"/${PN}-detect-datadir.patch
+ cp "${FILESDIR}"/setup.py "${S}"
+
+ distutils-r1_src_prepare
+}