summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2010-06-29 20:44:03 +0000
committerChristoph Mende <angelos@gentoo.org>2010-06-29 20:44:03 +0000
commit5d6ad14ced58d0141e5cc6ea2bce4b85a2c9a080 (patch)
treeede27f96ae4dc24598418fc5c738d399aade3b6b /media-sound/qmpdclient
parentSet PYTHON_DEPEND. Simplify src_test(). Use -fno-strict-aliasing. (diff)
downloadgentoo-2-5d6ad14ced58d0141e5cc6ea2bce4b85a2c9a080.tar.gz
gentoo-2-5d6ad14ced58d0141e5cc6ea2bce4b85a2c9a080.tar.bz2
gentoo-2-5d6ad14ced58d0141e5cc6ea2bce4b85a2c9a080.zip
Removed old
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/qmpdclient')
-rw-r--r--media-sound/qmpdclient/files/directory_listing_gcc44.patch34
-rw-r--r--media-sound/qmpdclient/qmpdclient-1.1.1.ebuild91
-rw-r--r--media-sound/qmpdclient/qmpdclient-1.1.2-r1.ebuild87
-rw-r--r--media-sound/qmpdclient/qmpdclient-1.1.2-r2.ebuild89
4 files changed, 0 insertions, 301 deletions
diff --git a/media-sound/qmpdclient/files/directory_listing_gcc44.patch b/media-sound/qmpdclient/files/directory_listing_gcc44.patch
deleted file mode 100644
index 7c96892f7720..000000000000
--- a/media-sound/qmpdclient/files/directory_listing_gcc44.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-commit d306047d90177900018547610209f2c290794d10
-Author: jb <noobinet@gmail.com>
-Date: Wed Mar 3 01:03:03 2010 +0100
-
- Fix the empty directory view bug.
-
- Dunno at all if it's ok to do that, but at least it works
-
-diff --git a/src/mpddirectory.cpp b/src/mpddirectory.cpp
-index f4ded77..79fa7b0 100644
---- a/src/mpddirectory.cpp
-+++ b/src/mpddirectory.cpp
-@@ -59,7 +59,7 @@ MPDDirectory::MPDDirectory(const MPDDirectory &other) : d(other.d) {}
- MPDDirectory::~MPDDirectory() {}
-
- bool MPDDirectory::isNull() const {
-- return d == NULL;
-+ return !d;
- }
-
- MPDDirectoryPointer *MPDDirectory::pointer() const {
-diff --git a/src/mpddirectory.h b/src/mpddirectory.h
-index a7e4cfd..6042187 100644
---- a/src/mpddirectory.h
-+++ b/src/mpddirectory.h
-@@ -55,7 +55,7 @@ public:
- MPDDirectory &operator=(const MPDDirectory &);
-
- private:
-- QSharedDataPointer<MPDDirectoryPrivate> d;
-+ QExplicitlySharedDataPointer<MPDDirectoryPrivate> d;
- };
-
- class MPDDirectoryPointer {
diff --git a/media-sound/qmpdclient/qmpdclient-1.1.1.ebuild b/media-sound/qmpdclient/qmpdclient-1.1.1.ebuild
deleted file mode 100644
index eeab30b34e73..000000000000
--- a/media-sound/qmpdclient/qmpdclient-1.1.1.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/qmpdclient/qmpdclient-1.1.1.ebuild,v 1.5 2009/10/07 18:37:53 nixnut Exp $
-
-EAPI="2"
-
-inherit qt4
-
-DESCRIPTION="QMPDClient with NBL additions, such as lyrics' display"
-HOMEPAGE="http://bitcheese.net/wiki/QMPDClient"
-SRC_URI="mirror://gentoo/${P}.tar.gz
- http://dev.gentoo.org/~hwoarang/distfiles/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~hppa ppc ~sparc x86"
-IUSE="debug dbus"
-
-DEPEND="x11-libs/qt-gui:4[dbus?,debug?]"
-RDEPEND="${DEPEND}"
-
-LANGSLONG="cs_CZ de_DE fr_FR it_IT nl_NL nn_NO no_NO ru_RU sv_SE tr_TR uk_UA"
-LANGS="zh_CN zh_TW pt_BR "
-
-for X in ${LANGSLONG}; do
- IUSE="${IUSE} linguas_${X%_*}"
-done
-
-for X in ${LANGS};do
- IUSE="${IUSE} linguas_${X}"
-done
-
-src_prepare() {
- # Fix the install path
- sed -i -e "s:PREFIX = /usr/local:PREFIX = /usr:" qmpdclient.pro \
- || die "sed failed (install path)"
-
- # nostrip fix
- sed -i -e "s:CONFIG += :CONFIG += nostrip :" qmpdclient.pro \
- || die "sed failed (nostrip)"
-
- sed -i -e "s:+= -O2 -g0 -s:+= -O2 -g0:" qmpdclient.pro \
- || die "sed failed (nostrip)"
-
- # fix installation folder name
- sed -i "s/share\/QMPDClient/share\/qmpdclient/" src/config.cpp \
- || die "failed to fix installation directory"
-
- # check dbus
- if ! use dbus; then
- sed -i -e "s/message(DBus notifier:\ enabled)/message(DBus notifier:\ disabled)/" \
- -e "s/CONFIG\ +=\ nostrip\ qdbus//" \
- -e "s/SOURCES\ +=\ src\/notifications_dbus.cpp/SOURCES\ +=\ src\/notifications_nodbus.cpp/" \
- ${PN}.pro || die "disabling dbus failed"
- fi
-}
-
-src_configure() {
- eqmake4 qmpdclient.pro
-}
-
-src_compile() {
- emake || die "emake failed"
- # generate translations
- emake translate || die "failed to generate translations"
-}
-
-src_install() {
- emake install INSTALL_ROOT="${D}" || die "emake install failed"
- dodoc README AUTHORS THANKSTO Changelog || die "Installing docs failed"
- for res in 16 22 64 ; do
- insinto /usr/share/icons/hicolor/${res}x${res}/apps/
- newins icons/qmpdclient${res}.png ${PN}.png || die "Installing icons failed"
- done
-
- #install translations
- insinto /usr/share/${PN}/translations/
- local LANG=
- for LANG in ${LINGUAS};do
- for X in ${LANGS};do
- if [[ ${LANG} == ${X%_*} ]];then
- doins -r lang/${X}.qm || die "failed to install translations"
- fi
- done
- for X in ${LANGSLONG};do
- if [[ ${LANG} == ${X} ]]; then
- doins -r lang/${X}.qm || die "failed to install translations"
- fi
- done
- done
-}
diff --git a/media-sound/qmpdclient/qmpdclient-1.1.2-r1.ebuild b/media-sound/qmpdclient/qmpdclient-1.1.2-r1.ebuild
deleted file mode 100644
index eaa4450def8c..000000000000
--- a/media-sound/qmpdclient/qmpdclient-1.1.2-r1.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/qmpdclient/qmpdclient-1.1.2-r1.ebuild,v 1.2 2010/01/14 11:25:36 yngwin Exp $
-
-EAPI="2"
-
-LANGSLONG="cs_CZ de_DE fr_FR it_IT nl_NL nn_NO no_NO ru_RU sv_SE tr_TR uk_UA"
-LANGS="zh_CN zh_TW pt_BR "
-
-inherit qt4-r2
-
-DESCRIPTION="QMPDClient with NBL additions, such as lyrics' display"
-HOMEPAGE="http://bitcheese.net/wiki/QMPDClient"
-SRC_URI="http://dump.bitcheese.net/files/dedycec/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
-IUSE="debug dbus"
-
-DEPEND="x11-libs/qt-gui:4[dbus?]"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${PN}"
-
-DOCS="AUTHORS README THANKSTO Changelog"
-
-src_prepare() {
- # Fix the install path
- sed -i -e "s:PREFIX = /usr/local:PREFIX = /usr:" ${PN}.pro \
- || die "sed failed (install path)"
-
- # Fix package version
- sed -i -e "s:1.1.1:${PV}:" ${PN}.pro || die "failed to fix package version"
- # nostrip fix
- sed -i -e "s:CONFIG += :CONFIG += nostrip :" ${PN}.pro \
- || die "sed failed (nostrip)"
-
- sed -i -e "s:+= -O2 -g0 -s:+= -O2 -g0:" ${PN}.pro \
- || die "sed failed (nostrip)"
-
- # fix installation folder name
- sed -i "s/share\/QMPDClient/share\/qmpdclient/" ${PN}.pro src/config.cpp \
- || die "failed to fix installation directory"
-
- # check dbus
- if ! use dbus; then
- sed -i -e "s/message(DBus notifier:\ enabled)/message(DBus notifier:\ disabled)/" \
- -e "s/CONFIG\ +=\ nostrip\ qdbus//" \
- -e "s/SOURCES\ +=\ src\/notifications_dbus.cpp/SOURCES\ +=\ src\/notifications_nodbus.cpp/" \
- ${PN}.pro || die "disabling dbus failed"
- fi
-}
-
-src_compile() {
- emake || die "emake failed"
- # generate translations
- emake translate || die "failed to generate translations"
- cd "${S}"/lang
- for X in *.ts;do
- lrelease "${X}" || die "lrelease failed"
- done
-}
-
-src_install() {
- qt4-r2_src_install
- for res in 16 22 64 ; do
- insinto /usr/share/icons/hicolor/${res}x${res}/apps/
- newins icons/qmpdclient${res}.png ${PN}.png || die "Installing icons failed"
- done
-
- #install translations
- insinto /usr/share/${PN}/translations/
- local LANG=
- for LANG in ${LINGUAS};do
- for X in ${LANGSLONG};do
- if [[ ${LANG} == ${X%_*} ]];then
- doins -r lang/${X}.qm || die "failed to install translations"
- fi
- done
- for X in ${LANGS};do
- if [[ ${LANG} == ${X} ]]; then
- doins -r lang/${X}.qm || die "failed to install translations"
- fi
- done
- done
-}
diff --git a/media-sound/qmpdclient/qmpdclient-1.1.2-r2.ebuild b/media-sound/qmpdclient/qmpdclient-1.1.2-r2.ebuild
deleted file mode 100644
index b79a68ccfe92..000000000000
--- a/media-sound/qmpdclient/qmpdclient-1.1.2-r2.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/qmpdclient/qmpdclient-1.1.2-r2.ebuild,v 1.2 2010/06/21 16:50:20 ssuominen Exp $
-
-EAPI="2"
-
-LANGSLONG="cs_CZ de_DE fr_FR it_IT nl_NL nn_NO no_NO ru_RU sv_SE tr_TR uk_UA"
-LANGS="zh_CN zh_TW pt_BR "
-
-inherit qt4-r2
-
-DESCRIPTION="QMPDClient with NBL additions, such as lyrics' display"
-HOMEPAGE="http://bitcheese.net/wiki/QMPDClient"
-SRC_URI="http://dump.bitcheese.net/files/dedycec/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
-IUSE="debug dbus"
-
-DEPEND="x11-libs/qt-gui:4[dbus?]"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${PN}"
-
-PATCHES=( "${FILESDIR}/directory_listing_gcc44.patch" )
-DOCS="AUTHORS README THANKSTO Changelog"
-
-src_prepare() {
- # Fix the install path
- sed -i -e "s:PREFIX = /usr/local:PREFIX = /usr:" ${PN}.pro \
- || die "sed failed (install path)"
-
- # Fix package version
- sed -i -e "s:1.1.1:${PV}:" ${PN}.pro || die "failed to fix package version"
- # nostrip fix
- sed -i -e "s:CONFIG += :CONFIG += nostrip :" ${PN}.pro \
- || die "sed failed (nostrip)"
-
- sed -i -e "s:+= -O2 -g0 -s:+= -O2 -g0:" ${PN}.pro \
- || die "sed failed (nostrip)"
-
- # fix installation folder name
- sed -i "s/share\/QMPDClient/share\/qmpdclient/" ${PN}.pro src/config.cpp \
- || die "failed to fix installation directory"
-
- # check dbus
- if ! use dbus; then
- sed -i -e "s/message(DBus notifier:\ enabled)/message(DBus notifier:\ disabled)/" \
- -e "s/CONFIG\ +=\ nostrip\ qdbus//" \
- -e "s/SOURCES\ +=\ src\/notifications_dbus.cpp/SOURCES\ +=\ src\/notifications_nodbus.cpp/" \
- ${PN}.pro || die "disabling dbus failed"
- fi
- qt4-r2_src_prepare
-}
-
-src_compile() {
- emake || die "emake failed"
- # generate translations
- emake translate || die "failed to generate translations"
- cd "${S}"/lang
- for X in *.ts;do
- lrelease "${X}" || die "lrelease failed"
- done
-}
-
-src_install() {
- qt4-r2_src_install
- for res in 16 22 64 ; do
- insinto /usr/share/icons/hicolor/${res}x${res}/apps/
- newins icons/qmpdclient${res}.png ${PN}.png || die "Installing icons failed"
- done
-
- #install translations
- insinto /usr/share/${PN}/translations/
- local LANG=
- for LANG in ${LINGUAS};do
- for X in ${LANGSLONG};do
- if [[ ${LANG} == ${X%_*} ]];then
- doins -r lang/${X}.qm || die "failed to install translations"
- fi
- done
- for X in ${LANGS};do
- if [[ ${LANG} == ${X} ]]; then
- doins -r lang/${X}.qm || die "failed to install translations"
- fi
- done
- done
-}