summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-02-03 12:22:21 +0000
committerJohannes Huber <johu@gentoo.org>2012-02-03 12:22:21 +0000
commit5481da77ce9bb88c8352d308c63e8e015d0f2188 (patch)
tree7de70cb324c5afb3c740afa4b41ff768abfaefb1 /media-sound/qtgain
parentFix the QA_DT_HASH definition (diff)
downloadgentoo-2-5481da77ce9bb88c8352d308c63e8e015d0f2188.tar.gz
gentoo-2-5481da77ce9bb88c8352d308c63e8e015d0f2188.tar.bz2
gentoo-2-5481da77ce9bb88c8352d308c63e8e015d0f2188.zip
Version bump by Ben 'yngwin' de Groot <yngwin@gmail.com> wrt bug #370139.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/qtgain')
-rw-r--r--media-sound/qtgain/ChangeLog9
-rw-r--r--media-sound/qtgain/qtgain-0.9.5.ebuild34
2 files changed, 41 insertions, 2 deletions
diff --git a/media-sound/qtgain/ChangeLog b/media-sound/qtgain/ChangeLog
index 7167dc4d2d97..996a487ae559 100644
--- a/media-sound/qtgain/ChangeLog
+++ b/media-sound/qtgain/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/qtgain
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/qtgain/ChangeLog,v 1.1 2009/12/23 21:57:04 ssuominen Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qtgain/ChangeLog,v 1.2 2012/02/03 12:22:21 johu Exp $
+
+*qtgain-0.9.5 (03 Feb 2012)
+
+ 03 Feb 2012; Johannes Huber <johu@gentoo.org> +qtgain-0.9.5.ebuild:
+ Version bump by Ben 'yngwin' de Groot <yngwin@gmail.com> wrt bug #370139.
*qtgain-0.8.0 (23 Dec 2009)
diff --git a/media-sound/qtgain/qtgain-0.9.5.ebuild b/media-sound/qtgain/qtgain-0.9.5.ebuild
new file mode 100644
index 000000000000..671437b45b65
--- /dev/null
+++ b/media-sound/qtgain/qtgain-0.9.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qtgain/qtgain-0.9.5.ebuild,v 1.1 2012/02/03 12:22:21 johu Exp $
+
+EAPI=4
+
+MY_PN="QtGain"
+inherit qt4-r2
+
+DESCRIPTION="A simple frontend to mp3gain, vorbisgain and metaflac"
+HOMEPAGE="http://www.qt-apps.org/content/show.php/QtGain?content=56842"
+SRC_URI="http://www.qt-apps.org/CONTENT/content-files/56842-${MY_PN}.tar.lzma
+ -> ${P}.tar.lzma"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="flac mp3 mp4 vorbis"
+
+DEPEND="x11-libs/qt-gui:4"
+RDEPEND="${DEPEND}
+ flac? ( media-libs/flac )
+ mp3? ( media-sound/mp3gain )
+ mp4? ( media-sound/aacgain )
+ vorbis? ( media-sound/vorbisgain )
+ media-sound/id3v2"
+
+S="${WORKDIR}/${MY_PN}"
+
+src_install() {
+ dobin bin/${PN}
+ newicon Icons/lsongs.png ${PN}.png
+ make_desktop_entry ${PN} ${MY_PN}
+}