summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2004-02-25 18:43:14 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2004-02-25 18:43:14 +0000
commitb7cb84ed85be5e8b8afb90715cc5121efea20e7a (patch)
tree65f790840439427a338a513bef3275b1e36ac273 /media-sound/rhythmbox
parentAdding amd64 keyword (diff)
downloadgentoo-2-b7cb84ed85be5e8b8afb90715cc5121efea20e7a.tar.gz
gentoo-2-b7cb84ed85be5e8b8afb90715cc5121efea20e7a.tar.bz2
gentoo-2-b7cb84ed85be5e8b8afb90715cc5121efea20e7a.zip
Closing #41509.
Diffstat (limited to 'media-sound/rhythmbox')
-rw-r--r--media-sound/rhythmbox/ChangeLog6
-rw-r--r--media-sound/rhythmbox/files/rhythmbox-0.6.5-amd64.patch64
-rw-r--r--media-sound/rhythmbox/rhythmbox-0.6.5.ebuild8
3 files changed, 75 insertions, 3 deletions
diff --git a/media-sound/rhythmbox/ChangeLog b/media-sound/rhythmbox/ChangeLog
index 2935e5d25546..98bd95999946 100644
--- a/media-sound/rhythmbox/ChangeLog
+++ b/media-sound/rhythmbox/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/rhythmbox
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/ChangeLog,v 1.28 2004/02/12 17:01:22 leonardop Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/ChangeLog,v 1.29 2004/02/25 18:43:14 aliz Exp $
+
+ 25 Feb 2004; Daniel Ahlberg <aliz@gentoo.org> rhythmbox-0.6.5.ebuild:
+ Adding patch from upstream submitted by Benjamin Schindler <config@gmx.ch> in
+ #41509.
12 Feb 2004; L. Boshell <leonardop@gentoo.org> rhythmbox-0.6.5.ebuild,
files/rhythmbox-0.6.5-gcc2_fix.patch:
diff --git a/media-sound/rhythmbox/files/rhythmbox-0.6.5-amd64.patch b/media-sound/rhythmbox/files/rhythmbox-0.6.5-amd64.patch
new file mode 100644
index 000000000000..8b451e38f40f
--- /dev/null
+++ b/media-sound/rhythmbox/files/rhythmbox-0.6.5-amd64.patch
@@ -0,0 +1,64 @@
+Only in rhythmbox-0.6.5/help/C: authors.xml
+diff -ur rhythmbox-0.6.5/lib/rb-util.c rhythmbox-0.6.5-patched/lib/rb-util.c
+--- rhythmbox-0.6.5/lib/rb-util.c 2004-01-18 03:57:40.000000000 +0100
++++ rhythmbox-0.6.5-patched/lib/rb-util.c 2004-02-13 22:52:14.000000000 +0100
+@@ -22,13 +22,13 @@
+ #include "rb-util.h"
+
+ gboolean
+-rb_true_function (gpointer dummy, ...)
++rb_true_function (gpointer dummy)
+ {
+ return TRUE;
+ }
+
+ gboolean
+-rb_false_function (gpointer dummy, ...)
++rb_false_function (gpointer dummy)
+ {
+ return FALSE;
+ }
+diff -ur rhythmbox-0.6.5/lib/rb-util.h rhythmbox-0.6.5-patched/lib/rb-util.h
+--- rhythmbox-0.6.5/lib/rb-util.h 2004-01-18 03:57:40.000000000 +0100
++++ rhythmbox-0.6.5-patched/lib/rb-util.h 2004-02-13 22:51:45.000000000 +0100
+@@ -28,8 +28,8 @@
+
+ G_BEGIN_DECLS
+
+-gboolean rb_true_function (gpointer dummy, ...);
+-gboolean rb_false_function (gpointer dummy, ...);
++gboolean rb_true_function (gpointer dummy);
++gboolean rb_false_function (gpointer dummy);
+
+ gboolean rb_gvalue_compare (GValue *a, GValue *b);
+
+Only in rhythmbox-0.6.5/monkey-media: monkey-media-includes.h
+Only in rhythmbox-0.6.5/monkey-media: monkey-media-marshal.c
+Only in rhythmbox-0.6.5/monkey-media: monkey-media-marshal.h
+diff -ur rhythmbox-0.6.5/monkey-media/monkey-media-player-gst-tmp.c rhythmbox-0.6.5-patched/monkey-media/monkey-media-player-gst-tmp.c
+--- rhythmbox-0.6.5/monkey-media/monkey-media-player-gst-tmp.c 2004-01-18 03:57:40.000000000 +0100
++++ rhythmbox-0.6.5-patched/monkey-media/monkey-media-player-gst-tmp.c 2004-02-13 21:12:12.000000000 +0100
+@@ -347,7 +347,7 @@
+ {
+ char *ret = NULL, *cset;
+ va_list args;
+- int bytes_read, bytes_written;
++ gsize bytes_read, bytes_written;
+
+ if (g_utf8_validate (str, len, NULL))
+ return g_strndup (str, len >= 0 ? len : strlen (str));
+@@ -356,10 +356,10 @@
+ while ((cset = va_arg (args, char *)) != NULL)
+ {
+ if (!strcmp (cset, "locale"))
+- ret = g_locale_to_utf8 (str, len, &bytes_read,
++ ret = g_locale_to_utf8 (str, (gsize) len, &bytes_read,
+ &bytes_written, NULL);
+ else
+- ret = g_convert (str, len, "UTF-8", cset,
++ ret = g_convert (str, (gsize) len, "UTF-8", cset,
+ &bytes_read, &bytes_written, NULL);
+ if (ret)
+ break;
+Only in rhythmbox-0.6.5-patched: readme
+Only in rhythmbox-0.6.5: rhythmbox.spec
diff --git a/media-sound/rhythmbox/rhythmbox-0.6.5.ebuild b/media-sound/rhythmbox/rhythmbox-0.6.5.ebuild
index ac1fee6e33bb..eabaa99a0efb 100644
--- a/media-sound/rhythmbox/rhythmbox-0.6.5.ebuild
+++ b/media-sound/rhythmbox/rhythmbox-0.6.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.6.5.ebuild,v 1.2 2004/02/12 17:01:22 leonardop Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.6.5.ebuild,v 1.3 2004/02/25 18:43:14 aliz Exp $
inherit gnome2
@@ -9,7 +9,7 @@ HOMEPAGE="http://web.rhythmbox.org/"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="~x86 ~ppc ~amd64"
IUSE="oggvorbis mad xine flac faad"
RDEPEND=">=x11-libs/gtk+-2.2.2
@@ -62,6 +62,10 @@ src_unpack( ) {
gnome2_omf_fix ${S}/help/C/Makefile.in
epatch ${FILESDIR}/${P}-gcc2_fix.patch
+
+ if [ "${ARCH}" == "amd64" ]; then
+ epatch ${FILESDIR}/${P}-amd64.patch
+ fi
}
DOCS="AUTHORS COPYING ChangeLog DOCUMENTERS INSTALL INTERNALS \