summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2007-12-14 18:03:11 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2007-12-14 18:03:11 +0000
commit79723af8767c76ddb3da982f1cc0d2b8a51190da (patch)
treed1aa22c8c41da09ecc7dc5326bf32068087305fa /media-sound/rubyripper/rubyripper-0.4.4.ebuild
parentremove unused license (diff)
downloadgentoo-2-79723af8767c76ddb3da982f1cc0d2b8a51190da.tar.gz
gentoo-2-79723af8767c76ddb3da982f1cc0d2b8a51190da.tar.bz2
gentoo-2-79723af8767c76ddb3da982f1cc0d2b8a51190da.zip
Version bump, and add three patches to fix misc glitches.
(Portage version: 2.1.4_rc10)
Diffstat (limited to 'media-sound/rubyripper/rubyripper-0.4.4.ebuild')
-rw-r--r--media-sound/rubyripper/rubyripper-0.4.4.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/media-sound/rubyripper/rubyripper-0.4.4.ebuild b/media-sound/rubyripper/rubyripper-0.4.4.ebuild
new file mode 100644
index 000000000000..ef74d6e45614
--- /dev/null
+++ b/media-sound/rubyripper/rubyripper-0.4.4.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rubyripper/rubyripper-0.4.4.ebuild,v 1.1 2007/12/14 18:03:10 flameeyes Exp $
+EAPI="1"
+
+inherit ruby
+
+DESCRIPTION="a secure audio ripper for linux"
+HOMEPAGE="http://code.google.com/p/rubyripper"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="flac mp3 vorbis +gtk cli"
+
+ILINGUAS="de hu nl ru"
+
+for lingua in $ILINGUAS; do
+ IUSE="${IUSE} linguas_${lingua}"
+done
+
+DEPEND=""
+RDEPEND="gtk? ( dev-ruby/ruby-gtk2 )
+ dev-ruby/ruby-gettext
+ virtual/eject
+ media-sound/cd-discid
+ media-sound/cdparanoia
+ flac? ( media-libs/flac )
+ mp3? ( media-sound/lame )
+ vorbis? ( media-sound/vorbis-tools )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-iconinstall.patch"
+ epatch "${FILESDIR}/${P}-desktopfile.patch"
+ epatch "${FILESDIR}/${P}-editor-environment.patch"
+}
+
+src_compile() {
+ local myconf="--prefix=/usr"
+ local enable_linguas=""
+
+ for lingua in $ILINGUAS; do
+ use linguas_$lingua && enable_linguas="${enable_linguas},${lingua}"
+ done
+
+ [[ -n ${enable_linguas} ]] && myconf="${myconf} --enable-lang=${enable_linguas#,}"
+
+ use gtk && myconf="${myconf} --enable-gtk2"
+ use cli && myconf="${myconf} --enable-cli"
+
+ ./configure ${myconf} || die "./configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}