summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-08-06 22:36:01 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-08-06 22:36:01 +0000
commitc288c9a25a0ca11c6e19e8a0757bc91d2535b216 (patch)
tree8fd818fdab3a4a0fb2fa1e6c1a759f0be351e149 /media-sound/splay
parentfix crash in addressbook, bug #233263. (diff)
downloadgentoo-2-c288c9a25a0ca11c6e19e8a0757bc91d2535b216.tar.gz
gentoo-2-c288c9a25a0ca11c6e19e8a0757bc91d2535b216.tar.bz2
gentoo-2-c288c9a25a0ca11c6e19e8a0757bc91d2535b216.zip
fix build with gcc 4.3, bug #232773
(Portage version: 2.2_rc6/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'media-sound/splay')
-rw-r--r--media-sound/splay/ChangeLog8
-rw-r--r--media-sound/splay/files/splay-0.9.5.2-gcc43.patch113
-rw-r--r--media-sound/splay/splay-0.9.5.2.ebuild9
3 files changed, 124 insertions, 6 deletions
diff --git a/media-sound/splay/ChangeLog b/media-sound/splay/ChangeLog
index 2288500ebf48..6dab448b6589 100644
--- a/media-sound/splay/ChangeLog
+++ b/media-sound/splay/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/splay
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/splay/ChangeLog,v 1.15 2007/03/01 18:08:18 aballier Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/splay/ChangeLog,v 1.16 2008/08/06 22:36:00 aballier Exp $
+
+ 06 Aug 2008; Alexis Ballier <aballier@gentoo.org>
+ +files/splay-0.9.5.2-gcc43.patch, splay-0.9.5.2.ebuild:
+ fix build with gcc 4.3, bug #232773
01 Mar 2007; Alexis Ballier <aballier@gentoo.org> splay-0.9.5.2.ebuild:
Reverting renaming, it breaks cplay, thanks to drac for pointing that quickly
diff --git a/media-sound/splay/files/splay-0.9.5.2-gcc43.patch b/media-sound/splay/files/splay-0.9.5.2-gcc43.patch
new file mode 100644
index 000000000000..70b91137fd75
--- /dev/null
+++ b/media-sound/splay/files/splay-0.9.5.2-gcc43.patch
@@ -0,0 +1,113 @@
+Index: splay-0.9.5.2/apps/splay.cc
+===================================================================
+--- splay-0.9.5.2.orig/apps/splay.cc
++++ splay-0.9.5.2/apps/splay.cc
+@@ -16,14 +16,14 @@
+
+ #include <sys/types.h>
+ #include <sys/wait.h>
+-#include <iostream.h>
++#include <iostream>
+
+ #ifdef HAVE_LIBID3
+ #include <id3/tag.h>
+ #include <id3/misc_support.h>
+ #endif /* HAVE_LIBID3 */
+
+-#include <iomanip.h>
++#include <iomanip>
+
+ #include "mpegsound.h"
+
+@@ -172,7 +172,7 @@ ostream& operator<<(ostream& s, const ID
+ static void play(char *filename)
+ {
+ if( splay_verbose-- )
+- cout << filename << ":" << endl;
++ std::cout << filename << ":" << std::endl;
+ if( splay_verbose>0 )
+ {
+ // cerr << getpid() << endl;
+Index: splay-0.9.5.2/libs/fileplayer.cc
+===================================================================
+--- splay-0.9.5.2.orig/libs/fileplayer.cc
++++ splay-0.9.5.2/libs/fileplayer.cc
+@@ -10,7 +10,7 @@
+ #endif
+
+ #include <string.h>
+-#include <iostream.h>
++#include <iostream>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
+@@ -55,7 +55,7 @@ bool Mpegfileplayer::openfile(char *file
+ fd=open(device, O_WRONLY|O_NDELAY);
+ }
+ if ( fd == -1 ) {
+- cerr << "Cannot open /dev/dsp or /dev/sound/dsp!" << endl;
++ std::cerr << "Cannot open /dev/dsp or /dev/sound/dsp!" << std::endl;
+ return seterrorcode(SOUND_ERROR_DEVOPENFAIL);
+ }
+ close(fd);
+@@ -121,8 +121,8 @@ bool Mpegfileplayer::playing(int verbose
+ int totframes=server->gettotalframe();
+ double tottime=1.0*totframes*pcmperframe/frequency;
+ if(frameinfo) {
+- cout << "Totalframes " << totframes;
+- cout << "; Totaltime " << tominsec(tottime) << endl;
++ std::cout << "Totalframes " << totframes;
++ std::cout << "; Totaltime " << tominsec(tottime) << std::endl;
+ }
+
+ // Playing
+@@ -132,9 +132,9 @@ bool Mpegfileplayer::playing(int verbose
+ if(frameinfo) {
+ int currframe=server-> getcurrentframe();
+ double currtime=1.0*currframe*pcmperframe/frequency;
+- cout << "Frame " << currframe << " [" << totframes-currframe << "]; ";
+- cout << "Time " << tominsec(currtime) << " [" ;
+- cout << tominsec(tottime-currtime) << "]" << endl ;
++ std::cout << "Frame " << currframe << " [" << totframes-currframe << "]; ";
++ std::cout << "Time " << tominsec(currtime) << " [" ;
++ std::cout << tominsec(tottime-currtime) << "]" << std::endl ;
+ }
+ }
+
+@@ -161,8 +161,8 @@ bool Mpegfileplayer::playingwiththread(i
+ int totframes=server->gettotalframe();
+ double tottime=1.0*totframes*pcmperframe/frequency;
+ if(frameinfo) {
+- cout << "Totalframes " << totframes;
+- cout << "; Totaltime " << tominsec(tottime) << endl;
++ std::cout << "Totalframes " << totframes;
++ std::cout << "; Totaltime " << tominsec(tottime) << std::endl;
+ }
+
+ // Playing
+@@ -172,9 +172,9 @@ bool Mpegfileplayer::playingwiththread(i
+ if(frameinfo) {
+ int currframe=server-> getcurrentframe();
+ double currtime=1.0*currframe*pcmperframe/frequency;
+- cout << "Frame " << currframe << " [" << totframes-currframe << "]; ";
+- cout << "Time " << tominsec(currtime) << " [" ;
+- cout << tominsec(tottime-currtime) << "]" << endl ;
++ std::cout << "Frame " << currframe << " [" << totframes-currframe << "]; ";
++ std::cout << "Time " << tominsec(currtime) << " [" ;
++ std::cout << tominsec(tottime-currtime) << "]" << std::endl ;
+ }
+ }
+
+Index: splay-0.9.5.2/libs/mpegtoraw.cc
+===================================================================
+--- splay-0.9.5.2.orig/libs/mpegtoraw.cc
++++ splay-0.9.5.2/libs/mpegtoraw.cc
+@@ -552,7 +552,7 @@ int Mpegtoraw::getframesaved(void)
+ #endif
+
+
+-#include <iostream.h>
++#include <iostream>
+ // Convert mpeg to raw
+ bool Mpegtoraw::run(int frames)
+ {
diff --git a/media-sound/splay/splay-0.9.5.2.ebuild b/media-sound/splay/splay-0.9.5.2.ebuild
index a5b25533f8d7..15ca152999b1 100644
--- a/media-sound/splay/splay-0.9.5.2.ebuild
+++ b/media-sound/splay/splay-0.9.5.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/splay/splay-0.9.5.2.ebuild,v 1.17 2007/03/01 18:08:18 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/splay/splay-0.9.5.2.ebuild,v 1.18 2008/08/06 22:36:00 aballier Exp $
inherit eutils
@@ -16,8 +16,9 @@ KEYWORDS="amd64 ~ppc x86"
src_unpack() {
unpack ${A}
- cd ${S}/apps
- epatch ${FILESDIR}/${P}-external-id3lib.diff
+ epatch "${FILESDIR}/${P}-gcc43.patch"
+ cd "${S}/apps"
+ epatch "${FILESDIR}/${P}-external-id3lib.diff"
}
src_compile() {