summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2012-10-08 15:15:39 +0000
committerSergey Popov <pinkbyte@gentoo.org>2012-10-08 15:15:39 +0000
commit01e91f6c1ce74701d9b90629b438b11b7d551b2f (patch)
treea164c1185ea66ccf1580ac724eaac230adbaaa4c /media-sound
parentstable ppc, bug #431178 (diff)
downloadgentoo-2-01e91f6c1ce74701d9b90629b438b11b7d551b2f.tar.gz
gentoo-2-01e91f6c1ce74701d9b90629b438b11b7d551b2f.tar.bz2
gentoo-2-01e91f6c1ce74701d9b90629b438b11b7d551b2f.zip
Bump LeechCraft to 0.5.85, thanks to 0xd34df00d
(Portage version: 2.2.0_alpha134/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/leechcraft-hotstreams/ChangeLog8
-rw-r--r--media-sound/leechcraft-hotstreams/leechcraft-hotstreams-0.5.85.ebuild26
2 files changed, 33 insertions, 1 deletions
diff --git a/media-sound/leechcraft-hotstreams/ChangeLog b/media-sound/leechcraft-hotstreams/ChangeLog
index 285697fda157..db5d0c21dbf3 100644
--- a/media-sound/leechcraft-hotstreams/ChangeLog
+++ b/media-sound/leechcraft-hotstreams/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/leechcraft-hotstreams
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/leechcraft-hotstreams/ChangeLog,v 1.2 2012/09/04 17:34:37 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/leechcraft-hotstreams/ChangeLog,v 1.3 2012/10/08 15:15:39 pinkbyte Exp $
+
+*leechcraft-hotstreams-0.5.85 (08 Oct 2012)
+
+ 08 Oct 2012; Sergey Popov <pinkbyte@gentoo.org>
+ +leechcraft-hotstreams-0.5.85.ebuild:
+ Bump LeechCraft to 0.5.85, thanks to 0xd34df00d
04 Sep 2012; Sergey Popov <pinkbyte@gentoo.org>
leechcraft-hotstreams-9999.ebuild:
diff --git a/media-sound/leechcraft-hotstreams/leechcraft-hotstreams-0.5.85.ebuild b/media-sound/leechcraft-hotstreams/leechcraft-hotstreams-0.5.85.ebuild
new file mode 100644
index 000000000000..ef8304e2f0a4
--- /dev/null
+++ b/media-sound/leechcraft-hotstreams/leechcraft-hotstreams-0.5.85.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/leechcraft-hotstreams/leechcraft-hotstreams-0.5.85.ebuild,v 1.1 2012/10/08 15:15:39 pinkbyte Exp $
+
+EAPI="4"
+
+inherit eutils leechcraft toolchain-funcs
+
+DESCRIPTION="Provides some cool radio streams to music players like LMP"
+
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="~net-misc/leechcraft-core-${PV}
+ dev-libs/qjson"
+RDEPEND="${DEPEND}"
+
+# TODO: Maybe simplify this or add apropriate function to leechcraft eclass?
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ [[ $(gcc-major-version) -lt 4 ]] || \
+ ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 6 ]] ) \
+ && die "Sorry, but gcc 4.6 or higher is required."
+ fi
+}