summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2012-07-02 15:18:50 +0000
committerChristoph Mende <angelos@gentoo.org>2012-07-02 15:18:50 +0000
commit468249178aa232a0e7450f0d5adfb5bd8f7cd67c (patch)
treeec52073549f007cdb6da971425b837b63cbf20f1 /media-sound
parentVersion bump, remove old. (diff)
downloadgentoo-2-468249178aa232a0e7450f0d5adfb5bd8f7cd67c.tar.gz
gentoo-2-468249178aa232a0e7450f0d5adfb5bd8f7cd67c.tar.bz2
gentoo-2-468249178aa232a0e7450f0d5adfb5bd8f7cd67c.zip
Update 0.17 ebuild and remove outdated live ebuild
(Portage version: 2.2.0_alpha114/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/mpd/ChangeLog6
-rw-r--r--media-sound/mpd/metadata.xml2
-rw-r--r--media-sound/mpd/mpd-0.17.ebuild36
-rw-r--r--media-sound/mpd/mpd-9999.ebuild185
4 files changed, 24 insertions, 205 deletions
diff --git a/media-sound/mpd/ChangeLog b/media-sound/mpd/ChangeLog
index 87a9227c199f..8d6c42f8930e 100644
--- a/media-sound/mpd/ChangeLog
+++ b/media-sound/mpd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/mpd
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpd/ChangeLog,v 1.285 2012/06/27 18:16:37 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpd/ChangeLog,v 1.286 2012/07/02 15:18:50 angelos Exp $
+
+ 02 Jul 2012; Christoph Mende <angelos@gentoo.org> -mpd-9999.ebuild,
+ metadata.xml, mpd-0.17.ebuild:
+ Update 0.17 ebuild and remove outdated live ebuild
*mpd-0.17 (27 Jun 2012)
diff --git a/media-sound/mpd/metadata.xml b/media-sound/mpd/metadata.xml
index 2cbdc1927a22..b8ffbbfa4766 100644
--- a/media-sound/mpd/metadata.xml
+++ b/media-sound/mpd/metadata.xml
@@ -25,6 +25,8 @@
<flag name="network">Enables network streaming support</flag>
<flag name="pipe">Support writing audio to a pipe</flag>
<flag name="sid">Build with SID (Commodore 64 Audio) support</flag>
+ <flag name="soundcloud">Build plugin to access soundcloud</flag>
+ <flag name="soup">Use <pkg>net-libs/libsoup</pkg> for HTTP streaming</flag>
<flag name="wildmidi">Enable MIDI support via wildmidi</flag>
<flag name="zip">Support for ZIP files</flag>
</use>
diff --git a/media-sound/mpd/mpd-0.17.ebuild b/media-sound/mpd/mpd-0.17.ebuild
index ce9d65fb6e14..4d6547585c4b 100644
--- a/media-sound/mpd/mpd-0.17.ebuild
+++ b/media-sound/mpd/mpd-0.17.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpd/mpd-0.17.ebuild,v 1.1 2012/06/27 18:16:37 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpd/mpd-0.17.ebuild,v 1.2 2012/07/02 15:18:50 angelos Exp $
EAPI=4
inherit eutils flag-o-matic linux-info multilib systemd user
@@ -11,11 +11,12 @@ SRC_URI="mirror://sourceforge/musicpd/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x64-macos"
-IUSE="aac +alsa ao audiofile bzip2 cdio cue +curl debug +fifo +ffmpeg flac
-fluidsynth profile +id3tag inotify ipv6 jack lame lastfmradio mms libsamplerate
-+mad mikmod modplug mpg123 musepack +network ogg openal oss pipe pulseaudio sid
-sndfile sqlite tcpd twolame unicode vorbis wavpack wildmidi zeroconf zip"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sh ~x86 ~x86-fbsd ~x64-macos"
+IUSE="aac +alsa ao audiofile bzip2 cdio +curl debug +fifo +ffmpeg flac
+fluidsynth +id3tag inotify ipv6 jack lame lastfmradio mms libsamplerate +mad
+mikmod modplug mpg123 musepack +network ogg openal oss pipe pulseaudio sid
+sndfile soundcloud soup sqlite tcpd twolame unicode vorbis wavpack wildmidi
+zeroconf zip"
REQUIRED_USE="|| ( alsa ao fifo jack network openal oss pipe pulseaudio )
|| ( aac audiofile ffmpeg flac fluidsynth mad mikmod modplug mpg123 musepack
@@ -32,7 +33,6 @@ RDEPEND="!<sys-cluster/mpich2-1.4_rc2
audiofile? ( media-libs/audiofile )
bzip2? ( app-arch/bzip2 )
cdio? ( dev-libs/libcdio[-minimal] )
- cue? ( media-libs/libcue )
curl? ( net-misc/curl )
ffmpeg? ( virtual/ffmpeg )
flac? ( media-libs/flac[ogg?] )
@@ -54,6 +54,8 @@ RDEPEND="!<sys-cluster/mpich2-1.4_rc2
pulseaudio? ( media-sound/pulseaudio )
sid? ( media-libs/libsidplay:2 )
sndfile? ( media-libs/libsndfile )
+ soundcloud? ( >=dev-libs/yajl-2 )
+ soup? ( net-libs/libsoup:2.4 )
sqlite? ( dev-db/sqlite:3 )
tcpd? ( sys-apps/tcp-wrappers )
twolame? ( media-sound/twolame )
@@ -84,9 +86,10 @@ src_prepare() {
}
src_configure() {
- local mpdconf="--enable-tcp --enable-un --disable-documentation
- --disable-ffado --disable-gme --enable-largefile
- --disable-mvp --docdir=${EPREFIX}/usr/share/doc/${PF}"
+ local mpdconf="--disable-despotify --disable-documentation --disable-ffado
+ --disable-gme --disable-mvp --disable-roar --enable-largefile
+ --enable-recorder-output --enable-tcp --enable-un
+ --docdir=${EPREFIX}/usr/share/doc/${PF}"
if use network; then
mpdconf+=" --enable-shout $(use_enable vorbis vorbis-encoder)
@@ -99,12 +102,6 @@ src_configure() {
--disable-twolame-encoder --disable-wave-encoder"
fi
- if use flac && use ogg; then
- mpdconf+=" --enable-oggflac"
- else
- mpdconf+=" --disable-oggflac"
- fi
-
append-lfs-flags
append-ldflags "-L/usr/$(get_libdir)/sidplay/builders"
@@ -114,8 +111,8 @@ src_configure() {
$(use_enable ao) \
$(use_enable audiofile) \
$(use_enable bzip2) \
+ $(use_enable cdio cdio-paranoia) \
$(use_enable cdio iso9660) \
- $(use_enable cue) \
$(use_enable curl) \
$(use_enable debug) \
$(use_enable ffmpeg) \
@@ -127,20 +124,21 @@ src_configure() {
$(use_enable ipv6) \
$(use_enable jack) \
$(use_enable lastfmradio lastfm) \
- $(use_enable mms) \
$(use_enable libsamplerate lsr) \
$(use_enable mad) \
$(use_enable mikmod) \
+ $(use_enable mms) \
$(use_enable modplug) \
$(use_enable mpg123) \
$(use_enable musepack mpc) \
$(use_enable openal) \
$(use_enable oss) \
$(use_enable pipe pipe-output) \
- $(use_enable profile gprof) \
$(use_enable pulseaudio pulse) \
$(use_enable sid sidplay) \
$(use_enable sndfile sndfile) \
+ $(use_enable soundcloud) \
+ $(use_enable soup) \
$(use_enable sqlite) \
$(use_enable tcpd libwrap) \
$(use_enable vorbis) \
diff --git a/media-sound/mpd/mpd-9999.ebuild b/media-sound/mpd/mpd-9999.ebuild
deleted file mode 100644
index 889ab8dbb286..000000000000
--- a/media-sound/mpd/mpd-9999.ebuild
+++ /dev/null
@@ -1,185 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpd/mpd-9999.ebuild,v 1.7 2012/06/01 03:11:53 zmedico Exp $
-
-EAPI=4
-inherit autotools eutils flag-o-matic linux-info multilib systemd user git-2
-
-DESCRIPTION="The Music Player Daemon (mpd)"
-HOMEPAGE="http://www.musicpd.org"
-EGIT_REPO_URI="git://git.musicpd.org/master/${PN}.git"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS=""
-IUSE="aac +alsa ao audiofile bzip2 cdio cue +curl debug +fifo +ffmpeg flac
-fluidsynth profile +id3tag inotify ipv6 jack lame lastfmradio libsamplerate
-+mad mikmod modplug mpg123 mms musepack +network ogg openal oss pipe pulseaudio
-sid sndfile sqlite tcpd twolame unicode vorbis wavpack wildmidi zeroconf zip"
-
-REQUIRED_USE="|| ( alsa ao fifo jack network openal oss pipe pulseaudio )
- || ( aac audiofile ffmpeg flac fluidsynth mad mikmod modplug mpg123 musepack
- ogg flac sid vorbis wavpack wildmidi )
- network? ( || ( audiofile flac lame twolame vorbis ) )
- lastfmradio? ( curl )"
-
-RDEPEND="!<sys-cluster/mpich2-1.4_rc2
- dev-libs/glib:2
- aac? ( media-libs/faad2 )
- alsa? ( media-sound/alsa-utils )
- ao? ( media-libs/libao[alsa?,pulseaudio?] )
- audiofile? ( media-libs/audiofile )
- bzip2? ( app-arch/bzip2 )
- cdio? ( dev-libs/libcdio[-minimal]
- virtual/cdrtools )
- cue? ( media-libs/libcue )
- curl? ( net-misc/curl )
- ffmpeg? ( virtual/ffmpeg )
- flac? ( media-libs/flac[ogg?] )
- fluidsynth? ( media-sound/fluidsynth )
- network? ( >=media-libs/libshout-2 )
- id3tag? ( media-libs/libid3tag )
- jack? ( media-sound/jack-audio-connection-kit )
- lame? ( network? ( media-sound/lame ) )
- libsamplerate? ( media-libs/libsamplerate )
- mad? ( media-libs/libmad )
- mikmod? ( media-libs/libmikmod:0 )
- mms? ( media-libs/libmms )
- modplug? ( media-libs/libmodplug )
- mpg123? ( >=media-sound/mpg123-1.12.2 )
- musepack? ( media-sound/musepack-tools )
- ogg? ( media-libs/libogg )
- openal? ( media-libs/openal )
- pulseaudio? ( media-sound/pulseaudio )
- sid? ( media-libs/libsidplay:2 )
- sndfile? ( media-libs/libsndfile )
- sqlite? ( dev-db/sqlite:3 )
- tcpd? ( sys-apps/tcp-wrappers )
- twolame? ( media-sound/twolame )
- vorbis? ( media-libs/libvorbis )
- wavpack? ( media-sound/wavpack )
- wildmidi? ( media-sound/wildmidi )
- zeroconf? ( net-dns/avahi[dbus] )
- zip? ( dev-libs/zziplib )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-pkg_setup() {
- use network || ewarn "Icecast and Shoutcast streaming needs networking."
- use fluidsynth && ewarn "Using fluidsynth is discouraged by upstream."
-
- enewuser mpd "" "" "/var/lib/mpd" audio
-
- if use inotify; then
- CONFIG_CHECK="~INOTIFY_USER"
- ERROR_INOTIFY_USER="${P} requires inotify in-kernel support."
- linux-info_pkg_setup
- fi
-}
-
-src_prepare() {
- cp -f doc/mpdconf.example doc/mpdconf.dist || die "cp failed"
- epatch "${FILESDIR}"/${PN}-0.16.conf.patch
- eautoreconf
-}
-
-src_configure() {
- local mpdconf="--disable-despotify --disable-documentation --disable-ffado
- --disable-gme --disable-mvp --disable-roar --enable-largefile
- --enable-raop-output --enable-recorder-output --enable-tcp --enable-un
- --docdir=${EPREFIX}/usr/share/doc/${PF}"
-
- if use network; then
- mpdconf+=" --enable-shout $(use_enable vorbis vorbis-encoder)
- --enable-httpd-output $(use_enable lame lame-encoder)
- $(use_enable twolame twolame-encoder)
- $(use_enable audiofile wave-encoder)"
- else
- mpdconf+=" --disable-shout --disable-vorbis-encoder
- --disable-httpd-output --disable-lame-encoder
- --disable-twolame-encoder --disable-wave-encoder"
- fi
-
- if use flac && use ogg; then
- mpdconf+=" --enable-oggflac"
- else
- mpdconf+=" --disable-oggflac"
- fi
-
- append-lfs-flags
- append-ldflags "-L/usr/$(get_libdir)/sidplay/builders"
-
- econf \
- $(use_enable aac) \
- $(use_enable alsa) \
- $(use_enable ao) \
- $(use_enable audiofile) \
- $(use_enable bzip2) \
- $(use_enable cdio iso9660) \
- $(use_enable cdio cdio-paranoia) \
- $(use_enable cue) \
- $(use_enable curl) \
- $(use_enable debug) \
- $(use_enable ffmpeg) \
- $(use_enable fifo) \
- $(use_enable flac) \
- $(use_enable fluidsynth) \
- $(use_enable id3tag id3) \
- $(use_enable inotify) \
- $(use_enable ipv6) \
- $(use_enable jack) \
- $(use_enable lastfmradio lastfm) \
- $(use_enable libsamplerate lsr) \
- $(use_enable mad) \
- $(use_enable mikmod) \
- $(use_enable mms) \
- $(use_enable modplug) \
- $(use_enable mpg123) \
- $(use_enable musepack mpc) \
- $(use_enable openal) \
- $(use_enable oss) \
- $(use_enable pipe pipe-output) \
- $(use_enable profile gprof) \
- $(use_enable pulseaudio pulse) \
- $(use_enable sid sidplay) \
- $(use_enable sndfile) \
- $(use_enable sqlite) \
- $(use_enable tcpd libwrap) \
- $(use_enable vorbis) \
- $(use_enable wavpack) \
- $(use_enable wildmidi) \
- $(use_enable zip zzip) \
- $(use_with zeroconf zeroconf avahi) \
- "$(systemd_with_unitdir)" \
- ${mpdconf}
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- insinto /etc
- newins doc/mpdconf.dist mpd.conf
-
- newinitd "${FILESDIR}"/mpd.init mpd
-
- if use unicode; then
- sed -i -e 's:^#filesystem_charset.*$:filesystem_charset "UTF-8":' \
- "${D}"/etc/mpd.conf || die "sed failed"
- fi
-
- diropts -m0755 -o mpd -g audio
- dodir /var/lib/mpd
- keepdir /var/lib/mpd
- dodir /var/lib/mpd/music
- keepdir /var/lib/mpd/music
- dodir /var/lib/mpd/playlists
- keepdir /var/lib/mpd/playlists
-}
-
-pkg_postinst() {
- elog "If you will be starting mpd via /etc/init.d/mpd, please make"
- elog "sure that MPD's pid_file is unset."
-
- # also change the homedir if the user has existed before
- usermod -d "/var/lib/mpd" mpd
-}