summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2003-08-17 12:06:42 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2003-08-17 12:06:42 +0000
commit7a2aec17390e00cf3a8a78d2d6c8cedbf0a91165 (patch)
tree74aa72152e9f3ca6264ce3ae634c294fee933626 /media-sound
parentNew ebuild. See bug #26789 (diff)
downloadgentoo-2-7a2aec17390e00cf3a8a78d2d6c8cedbf0a91165.tar.gz
gentoo-2-7a2aec17390e00cf3a8a78d2d6c8cedbf0a91165.tar.bz2
gentoo-2-7a2aec17390e00cf3a8a78d2d6c8cedbf0a91165.zip
New ebuild. See bug #26789
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/rhythmbox/ChangeLog10
-rw-r--r--media-sound/rhythmbox/Manifest3
-rw-r--r--media-sound/rhythmbox/files/digest-rhythmbox-0.5.01
-rw-r--r--media-sound/rhythmbox/rhythmbox-0.5.0.ebuild48
4 files changed, 61 insertions, 1 deletions
diff --git a/media-sound/rhythmbox/ChangeLog b/media-sound/rhythmbox/ChangeLog
new file mode 100644
index 000000000000..dd695827019c
--- /dev/null
+++ b/media-sound/rhythmbox/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-sound/rhythmbox
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/ChangeLog,v 1.13 2003/08/17 12:06:38 g2boojum Exp $
+
+*rhythmbox-0.5.0 (17 Aug 2003)
+
+ 17 Aug 2003; Nick Hadaway <raker@gentoo.org> rhythmbox-0.5.0.ebuild:
+ New ebuild. See bug #26789 for the plea. gstreamer support will
+ be added in once gst-plugins-{vorbis,cdparanois} are unmasked and
+ the mad plugin is added to portage.
diff --git a/media-sound/rhythmbox/Manifest b/media-sound/rhythmbox/Manifest
index 6d8168ee1f26..fea133a105fa 100644
--- a/media-sound/rhythmbox/Manifest
+++ b/media-sound/rhythmbox/Manifest
@@ -1,2 +1,3 @@
-MD5 da5e3b7db94edd274ab142d7a042f686 rhythmbox-0.5.0.ebuild 722
+MD5 4ee45389cd703e237bf8979eaf6b47ce rhythmbox-0.5.0.ebuild 1479
+MD5 7a82e29f584483e1da4d8be505bafac1 ChangeLog 504
MD5 ab865b430e07f028d861503a1669dc97 files/digest-rhythmbox-0.5.0 68
diff --git a/media-sound/rhythmbox/files/digest-rhythmbox-0.5.0 b/media-sound/rhythmbox/files/digest-rhythmbox-0.5.0
new file mode 100644
index 000000000000..0863a5b8e93b
--- /dev/null
+++ b/media-sound/rhythmbox/files/digest-rhythmbox-0.5.0
@@ -0,0 +1 @@
+MD5 8c7e460199e36c020a67272b7cc6d095 rhythmbox-0.5.0.tar.gz 1261067
diff --git a/media-sound/rhythmbox/rhythmbox-0.5.0.ebuild b/media-sound/rhythmbox/rhythmbox-0.5.0.ebuild
new file mode 100644
index 000000000000..93513c386338
--- /dev/null
+++ b/media-sound/rhythmbox/rhythmbox-0.5.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.5.0.ebuild,v 1.1 2003/08/17 12:06:38 g2boojum Exp $
+
+# Comments wrt gstreamer are in the build. Not all the gstreamer plugins
+# required for support are in portage yet.
+
+IUSE="mad oggvorbis" # gstreamer
+
+inherit gnome2
+
+DESCRIPTION="An integrated music management application originally inspired by iTunes for GNOME 2"
+HOMEPAGE="http://www.thythmbox.org"
+SRC_URI="mirror://sourceforge/rhythmbox/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+DEPEND="virtual/glibc
+ media-libs/flac
+ media-libs/xine-lib
+ >=media-libs/musicbrainz-2.0.0
+ mad? ( media-sound/mad )
+ oggvorbis? ( media-libs/libogg
+ media-libs/libvorbis )"
+
+# gstreamer? ( >=media-libs/gstreamer-0.6.2
+# >=media-libs/gst-plugins-0.6.2
+# >=media-libs/gst-plugins-cdparanoia-0.6.2 )
+# !gstreamer? ( media-libs/xine-lib )
+# oggvorbis? ( gstreamer? ( >=media-libs/gst-plugins-vorbis-0.6.2 ) )
+# mad? ( gstreamer? ( >=media-libs/gst-plugins-mad-0.6.2 ) )
+
+DOCS="AUTHORS ChangeLog DOCUMENTERS INTERNALS MAINTAINERS NEWS \
+ README THANKS TODO"
+
+src_compile() {
+ local myconf="--with-gnu-ld --enable-xine"
+ #use gstreamer || myconf="${myconf} --enable-xine"
+
+ use mad || myconf="${myconf} --disable-mp3"
+
+ use oggvorbis || myconf="${myconf} --disable-vorbis"
+
+ gnome2_src_configure ${myconf}
+}
+