summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-03-30 20:45:46 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-03-30 20:45:46 +0000
commit7a4dacdad4bda868656bd3d9e168d97aa0d26754 (patch)
treecc10e17832c1645289fefb472303822adcd929f3 /media-sound
parentAdd net-misc/curl, thanks to Tobias Kral <tobias at kral-online dot de>, bug ... (diff)
downloadgentoo-2-7a4dacdad4bda868656bd3d9e168d97aa0d26754.tar.gz
gentoo-2-7a4dacdad4bda868656bd3d9e168d97aa0d26754.tar.bz2
gentoo-2-7a4dacdad4bda868656bd3d9e168d97aa0d26754.zip
Include signal.h to workaround glib not including it causing compile failures on ppc
(Portage version: 2.1.2.3)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/beast/ChangeLog7
-rw-r--r--media-sound/beast/beast-0.7.1.ebuild3
-rw-r--r--media-sound/beast/files/beast-0.7.1-signalheader.patch24
3 files changed, 32 insertions, 2 deletions
diff --git a/media-sound/beast/ChangeLog b/media-sound/beast/ChangeLog
index d1f1de145314..5dfd3f5f9562 100644
--- a/media-sound/beast/ChangeLog
+++ b/media-sound/beast/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/beast
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/beast/ChangeLog,v 1.27 2007/03/27 06:03:40 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/beast/ChangeLog,v 1.28 2007/03/30 20:45:46 aballier Exp $
+
+ 30 Mar 2007; Alexis Ballier <aballier@gentoo.org>
+ +files/beast-0.7.1-signalheader.patch, beast-0.7.1.ebuild:
+ Include signal.h to workaround glib not including it causing compile
+ failures on ppc
27 Mar 2007; Christian Faulhammer <opfer@gentoo.org> beast-0.7.1.ebuild:
stable x86, security bug 163146
diff --git a/media-sound/beast/beast-0.7.1.ebuild b/media-sound/beast/beast-0.7.1.ebuild
index 57e4f22ddab5..c1268d20df53 100644
--- a/media-sound/beast/beast-0.7.1.ebuild
+++ b/media-sound/beast/beast-0.7.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/beast/beast-0.7.1.ebuild,v 1.4 2007/03/27 06:03:40 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/beast/beast-0.7.1.ebuild,v 1.5 2007/03/30 20:45:46 aballier Exp $
inherit eutils flag-o-matic fdo-mime
@@ -44,6 +44,7 @@ src_unpack() {
epatch "${WORKDIR}/${P}-guile-1.8.diff"
epatch "${FILESDIR}/${P}-noinstalltest.patch"
+ epatch "${FILESDIR}/${P}-signalheader.patch"
}
src_compile() {
diff --git a/media-sound/beast/files/beast-0.7.1-signalheader.patch b/media-sound/beast/files/beast-0.7.1-signalheader.patch
new file mode 100644
index 000000000000..e6a00358e416
--- /dev/null
+++ b/media-sound/beast/files/beast-0.7.1-signalheader.patch
@@ -0,0 +1,24 @@
+Index: beast-0.7.1/birnet/birnettests.h
+===================================================================
+--- beast-0.7.1.orig/birnet/birnettests.h
++++ beast-0.7.1/birnet/birnettests.h
+@@ -27,6 +27,7 @@
+
+ #include <glib.h>
+ #include <string.h>
++#include <signal.h>
+
+ BIRNET_EXTERN_C_BEGIN();
+
+Index: beast-0.7.1/tools/bseloopfuncs.c
+===================================================================
+--- beast-0.7.1.orig/tools/bseloopfuncs.c
++++ beast-0.7.1/tools/bseloopfuncs.c
+@@ -21,6 +21,7 @@
+ #include <string.h>
+ #include <stdio.h>
+ #include <math.h>
++#include <signal.h>
+
+ typedef struct {
+ gdouble score;