summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-02-07 05:08:51 +0000
committerTim Harder <radhermit@gentoo.org>2013-02-07 05:08:51 +0000
commitc6d7439e924a0bdc69e1d6c68900f8535bb229e7 (patch)
tree12630393b532d1f36f7e4a78e34b7ea72ff6f620 /media-sound
parentAdd KDE SC 4.10.0 (diff)
downloadgentoo-2-c6d7439e924a0bdc69e1d6c68900f8535bb229e7.tar.gz
gentoo-2-c6d7439e924a0bdc69e1d6c68900f8535bb229e7.tar.bz2
gentoo-2-c6d7439e924a0bdc69e1d6c68900f8535bb229e7.zip
Version bump.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/giada/ChangeLog8
-rw-r--r--media-sound/giada/files/giada-0.5.8-configure.patch50
-rw-r--r--media-sound/giada/giada-0.5.8.ebuild43
3 files changed, 100 insertions, 1 deletions
diff --git a/media-sound/giada/ChangeLog b/media-sound/giada/ChangeLog
index 9ee339bc961e..310a2af1d3a8 100644
--- a/media-sound/giada/ChangeLog
+++ b/media-sound/giada/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/giada
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/giada/ChangeLog,v 1.3 2013/01/22 03:51:00 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/giada/ChangeLog,v 1.4 2013/02/07 05:08:51 radhermit Exp $
+
+*giada-0.5.8 (07 Feb 2013)
+
+ 07 Feb 2013; Tim Harder <radhermit@gentoo.org> +giada-0.5.8.ebuild,
+ +files/giada-0.5.8-configure.patch:
+ Version bump.
*giada-0.5.7 (22 Jan 2013)
diff --git a/media-sound/giada/files/giada-0.5.8-configure.patch b/media-sound/giada/files/giada-0.5.8-configure.patch
new file mode 100644
index 000000000000..c92ce0a1cc1b
--- /dev/null
+++ b/media-sound/giada/files/giada-0.5.8-configure.patch
@@ -0,0 +1,50 @@
+--- giada-0.5.8/configure.ac
++++ giada-0.5.8/configure.ac
+@@ -52,6 +52,27 @@
+ [AC_DEFINE(WITH_VST)]
+ )
+
++AC_ARG_ENABLE(
++ alsa,
++ AS_HELP_STRING([--disable-alsa], [disable alsa support]),
++ [AC_DEFINE(WITH_ALSA)]
++)
++AM_CONDITIONAL(ALSA, test "x$enable_alsa" = "xtrue")
++
++AC_ARG_ENABLE(
++ jack,
++ AS_HELP_STRING([--enable-jack], [enable jack support]),
++ [AC_DEFINE(WITH_JACK)]
++)
++AM_CONDITIONAL(JACK, test "x$enable_jack" = "xtrue")
++
++AC_ARG_ENABLE(
++ pulse,
++ AS_HELP_STRING([--enable-pulse], [enable pulseaudio support]),
++ [AC_DEFINE(WITH_PULSE)]
++)
++AM_CONDITIONAL(PULSE, test "x$enable_pulse" = "xtrue")
++
+ # ----------------------------------------------------------------------
+
+ # Checks for programs.
+--- giada-0.5.8/src/Makefile.am
++++ giada-0.5.8/src/Makefile.am
+@@ -39,7 +39,16 @@
+ # inside configure.ac
+ if LINUX
+ giada_LDADD = -lsndfile -lfltk -lXext -lX11 -lXft -lXpm -lm -lrtaudio \
+- -ljack -lasound -lpthread -ldl -lpulse-simple -lsamplerate
++ -lpthread -ldl -lsamplerate
++if ALSA
++giada_LDADD += -lasound
++endif
++if JACK
++giada_LDADD += -ljack
++endif
++if PULSE
++giada_LDADD += -lpulse-simple
++endif
+ endif
+ if WINDOWS
+ giada_LDADD = -lole32 -lrtaudio -ldsound -lwinmm -lwsock32 -lm \
diff --git a/media-sound/giada/giada-0.5.8.ebuild b/media-sound/giada/giada-0.5.8.ebuild
new file mode 100644
index 000000000000..d40488dc5fb6
--- /dev/null
+++ b/media-sound/giada/giada-0.5.8.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/giada/giada-0.5.8.ebuild,v 1.1 2013/02/07 05:08:51 radhermit Exp $
+
+EAPI=5
+
+inherit flag-o-matic eutils autotools
+
+DESCRIPTION="A free, minimal, hardcore audio tool for djs and live performers"
+HOMEPAGE="http://www.giadamusic.com/"
+SRC_URI="http://www.giadamusic.com/download-action.php?os=source&version=${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+alsa jack pulseaudio"
+REQUIRED_USE="|| ( alsa jack pulseaudio )"
+
+RDEPEND="media-libs/libsndfile
+ media-libs/libsamplerate
+ media-libs/rtaudio[alsa?,jack?,pulseaudio?]
+ x11-libs/fltk:1
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.5.4-flags.patch
+ epatch "${FILESDIR}"/${P}-configure.patch
+ eautoreconf
+}
+
+src_configure() {
+ append-cppflags -I/usr/include/fltk-1
+ append-ldflags -L/usr/$(get_libdir)/fltk-1
+
+ econf \
+ --target=linux \
+ $(use_enable alsa) \
+ $(use_enable jack) \
+ $(use_enable pulseaudio pulse)
+}