summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2002-12-03 17:13:04 +0000
committerAron Griffis <agriffis@gentoo.org>2002-12-03 17:13:04 +0000
commitc8a048565fc93d269ca89b88765d96f831700612 (patch)
treec281ae0a46e8ffe4e6d4c8fb750b6c801d610ec5 /media-sound
parentFixed a couple of old masks (diff)
downloadgentoo-2-c8a048565fc93d269ca89b88765d96f831700612.tar.gz
gentoo-2-c8a048565fc93d269ca89b88765d96f831700612.tar.bz2
gentoo-2-c8a048565fc93d269ca89b88765d96f831700612.zip
Update to 1.6.6. Fix bug #4682.
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/lilypond/ChangeLog11
-rw-r--r--media-sound/lilypond/files/digest-lilypond-1.6.61
-rw-r--r--media-sound/lilypond/lilypond-1.6.6.ebuild102
3 files changed, 113 insertions, 1 deletions
diff --git a/media-sound/lilypond/ChangeLog b/media-sound/lilypond/ChangeLog
index 45b5cc99245d..cab85906f348 100644
--- a/media-sound/lilypond/ChangeLog
+++ b/media-sound/lilypond/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-sound/lilypond
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lilypond/ChangeLog,v 1.1 2002/02/01 21:53:31 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lilypond/ChangeLog,v 1.2 2002/12/03 17:13:04 agriffis Exp $
+
+*lilypond-1.6.6 (03 Dec 2002)
+
+ 03 Dec 2002; Aron Griffis <agriffis@gentoo.org> lilypond-1.6.6.ebuild :
+
+ Update to version 1.6.6 which compiles with at least gcc-2.95.3 and
+ gcc-3.2.1. I put clauses in the ebuild to help compile for gcc-3.[01] but
+ haven't been able to test them. It shouldn't matter (much) since Gentoo 1.2
+ is using gcc-2.95.3 and Gentoo 1.4 is using gcc-3.2. This fixes BUG #4682.
*lilypond-1.5.15 (1 Feb 2002)
diff --git a/media-sound/lilypond/files/digest-lilypond-1.6.6 b/media-sound/lilypond/files/digest-lilypond-1.6.6
new file mode 100644
index 000000000000..4b8f4f383dc8
--- /dev/null
+++ b/media-sound/lilypond/files/digest-lilypond-1.6.6
@@ -0,0 +1 @@
+MD5 8ed5318b49dfee6e9aa4bb2328187c99 lilypond-1.6.6.tar.gz 1595311
diff --git a/media-sound/lilypond/lilypond-1.6.6.ebuild b/media-sound/lilypond/lilypond-1.6.6.ebuild
new file mode 100644
index 000000000000..b667e5c1226b
--- /dev/null
+++ b/media-sound/lilypond/lilypond-1.6.6.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lilypond/lilypond-1.6.6.ebuild,v 1.1 2002/12/03 17:13:04 agriffis Exp $
+
+IUSE="doc"
+
+inherit gcc
+
+MY_PV="v$(echo ${PV} | cut -d. -f1,2)"
+DESCRIPTION="GNU Music Typesetter"
+SRC_URI="http://www.lilypond.org/ftp/${MY_PV}/${P}.tar.gz"
+HOMEPAGE="http://lilypond.org/"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+DEPEND=">=dev-lang/python-2.2.1-r2
+ >=sys-devel/perl-5.6.1-r6
+ >=dev-util/guile-1.4-r3
+ >=sys-devel/bison-1.35
+ >=app-text/tetex-1.0.7-r10
+ >=sys-apps/texinfo-4.2-r5
+ >=sys-devel/flex-2.5.4a-r5
+ doc? ( >=app-text/mftrace-1.0.8
+ >=app-text/ghostscript-7.05.5
+ >=media-libs/netpbm-9.12-r2 )"
+
+RDEPEND=">=dev-util/guile-1.4-r3
+ >=app-text/ghostscript-7.05.5
+ >=app-text/tetex-1.0.7-r10
+ >=dev-lang/python-2.2.1-r2"
+
+src_compile() {
+ # See http://lilypond.org/stable/Documentation/topdocs/out-www/INSTALL.html
+ local flex_version=`flex --version | cut -d' ' -f2`
+ case "$(gcc-version):${flex_version}" in
+ 2.*:*)
+ # Verified by agriffis 03 Dec 2002 using
+ # gcc-2.95.3-r7 with flex-2.5.4a-r5
+ # (i.e. Gentoo 1.2)
+ ./configure --build=${CHOST} --prefix=/usr || die "configure failed"
+ emake || die "emake failed"
+ ;;
+
+ 3.0:*)
+ # Unverified
+ ./configure --build=${CHOST} --prefix=/usr || die "configure failed"
+ make -C lily out/lexer.cc
+ ( cd out; patch -p1 < ../lexer-gcc-3.0.patch; )
+ emake || die "emake failed"
+ ;;
+
+ 3.1:*)
+ # Unverified
+ ./lexer-gcc-3.1.sh
+ CPPFLAGS=-I$(pwd)/lily/out ./configure || die "configure failed"
+ ./lexer-gcc-3.1.sh
+ emake || die "emake failed"
+ ;;
+
+ # Note the following is the DEFAULT if there was no match,
+ # i.e. for gcc >= 3.2
+ 3.2:*|*)
+ # Verified by agriffis 03 Dec 2002 using
+ # gcc-3.2.1 with flex-2.5.4a and flex-2.5.23
+ ./configure --build=${CHOST} --prefix=/usr || die "configure failed"
+ # Fix std::cerr problem in flex 2.5.4a and 2.5.23
+ make -C lily out/lexer.cc
+ perl -i -pe 's/\scerr\s/ std::cerr /g' lily/out/lexer.cc
+ emake || die "emake failed"
+ ;;
+ esac
+ #use doc && make web-doc || "make web-doc failed"
+}
+
+src_install () {
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ datadir=${D}/usr/share \
+ lilypond_datadir=${D}/usr/share/lilypond \
+ local_lilypond_datadir=${D}/usr/share/lilypond/${PV} \
+ install || die "make install failed"
+ dodoc AUTHORS* COPYING ChangeLog DEDICATION NEWS README.txt \
+ ROADMAP THANKS VERSION *.el
+ insinto /usr/share/lilypond/${PV}/buildscripts/out
+ doins buildscripts/out/lilypond-profile \
+ buildscripts/out/lilypond-login \
+ buildscripts/out/clean-fonts
+}
+
+pkg_postinst () {
+ # Cleaning out old fonts is more appropriate in pkg_prerm, but we
+ # also need to clean up after any lilypond installations which may
+ # not have been installed via portage.
+ . /usr/share/lilypond/${PV}/buildscripts/out/clean-fonts
+}
+
+pkg_prerm () {
+ . /usr/share/lilypond/${PV}/buildscripts/out/clean-fonts
+}