summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-10-15 08:59:03 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-10-15 08:59:03 +0000
commitebaa1a5128d112d7a78ace89b9a259d1bbbb4b9e (patch)
tree57d82114299e1fc9d3568c814144934567bf0742 /media-sound
parent (Manifest recommit) (diff)
downloadgentoo-2-ebaa1a5128d112d7a78ace89b9a259d1bbbb4b9e.tar.gz
gentoo-2-ebaa1a5128d112d7a78ace89b9a259d1bbbb4b9e.tar.bz2
gentoo-2-ebaa1a5128d112d7a78ace89b9a259d1bbbb4b9e.zip
Make glame honor user CFLAGS. Closes bug #67070.
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/glame/ChangeLog6
-rw-r--r--media-sound/glame/files/glame-1.0.2-cflags.patch30
-rw-r--r--media-sound/glame/glame-1.0.2.ebuild4
3 files changed, 37 insertions, 3 deletions
diff --git a/media-sound/glame/ChangeLog b/media-sound/glame/ChangeLog
index f25068133f61..f8637416e2de 100644
--- a/media-sound/glame/ChangeLog
+++ b/media-sound/glame/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/glame
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/glame/ChangeLog,v 1.21 2004/09/14 08:09:12 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/glame/ChangeLog,v 1.22 2004/10/15 08:59:03 eradicator Exp $
+
+ 15 Oct 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ +files/glame-1.0.2-cflags.patch:
+ Make glame honor user CFLAGS. Closes bug #67070.
14 Sep 2004; Jeremy Huddleston <eradicator@gentoo.org> glame-1.0.2.ebuild:
Stable amd64, sparc.
diff --git a/media-sound/glame/files/glame-1.0.2-cflags.patch b/media-sound/glame/files/glame-1.0.2-cflags.patch
new file mode 100644
index 000000000000..488871d5573f
--- /dev/null
+++ b/media-sound/glame/files/glame-1.0.2-cflags.patch
@@ -0,0 +1,30 @@
+diff -Naur glame-1.0.2.orig/configure glame-1.0.2.cflags/configure
+--- glame-1.0.2.orig/configure 2004-10-15 01:45:17.713874000 -0700
++++ glame-1.0.2.cflags/configure 2004-10-15 01:52:33.089150474 -0700
+@@ -1994,7 +1994,10 @@
+ #define NDEBUG
+ _ACEOF
+
+- glame_debug_gcc_cflags="-O3 -ffast-math -funroll-loops"
++ if test -z "$CFLAGS"; then
++ CFLAGS="-O2 -ffast-math -funroll-loops"
++ fi
++ glame_debug_gcc_cflags="$CFLAGS"
+ else
+ if test -z "$CFLAGS"; then
+ CFLAGS="-g -O2 -ffast-math"
+diff -Naur glame-1.0.2.orig/configure.ac glame-1.0.2.cflags/configure.ac
+--- glame-1.0.2.orig/configure.ac 2004-01-13 11:54:26.000000000 -0800
++++ glame-1.0.2.cflags/configure.ac 2004-10-15 01:51:48.394512522 -0700
+@@ -33,7 +33,10 @@
+ glame_debug_gcc_cflags="-g3 -O"
+ elif test "$glame_debug" = "no"; then
+ AC_DEFINE(NDEBUG,, [disable debugging code])
+- glame_debug_gcc_cflags="-O3 -ffast-math -funroll-loops"
++ if test -z "$CFLAGS"; then
++ CFLAGS="-O2 -ffast-math"
++ fi
++ glame_debug_gcc_cflags="$CFLAGS"
+ else
+ if test -z "$CFLAGS"; then
+ CFLAGS="-g -O2 -ffast-math"
diff --git a/media-sound/glame/glame-1.0.2.ebuild b/media-sound/glame/glame-1.0.2.ebuild
index a08eb44da2cd..4b824af71b1e 100644
--- a/media-sound/glame/glame-1.0.2.ebuild
+++ b/media-sound/glame/glame-1.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/glame/glame-1.0.2.ebuild,v 1.10 2004/09/14 08:09:12 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/glame/glame-1.0.2.ebuild,v 1.11 2004/10/15 08:59:03 eradicator Exp $
IUSE="nls gnome oggvorbis debug alsa"
@@ -31,7 +31,6 @@ DEPEND="${RDEPEND}
>=sys-devel/autoconf-2.58
nls? ( >=sys-devel/gettext-0.11.3 )"
-
src_unpack() {
unpack ${A}
@@ -50,6 +49,7 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/gentoo.patch
+ epatch ${FILESDIR}/${P}-cflags.patch
}
src_compile() {