summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-09-15 09:54:31 +0000
committerTim Harder <radhermit@gentoo.org>2012-09-15 09:54:31 +0000
commitf9469276cb70d159bffd53c5ff604e3d34ad347d (patch)
tree197fcdb5ed1c1ff791ad40e2f5a837ef1797c664 /media-sound
parentVersion bump, drop old. (diff)
downloadgentoo-2-f9469276cb70d159bffd53c5ff604e3d34ad347d.tar.gz
gentoo-2-f9469276cb70d159bffd53c5ff604e3d34ad347d.tar.bz2
gentoo-2-f9469276cb70d159bffd53c5ff604e3d34ad347d.zip
Version bump.
(Portage version: 2.2.0_alpha128/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/lilypond/ChangeLog8
-rw-r--r--media-sound/lilypond/files/lilypond-2.17.2-tex-docs.patch20
-rw-r--r--media-sound/lilypond/lilypond-2.17.2.ebuild103
3 files changed, 130 insertions, 1 deletions
diff --git a/media-sound/lilypond/ChangeLog b/media-sound/lilypond/ChangeLog
index 319ba8661299..ba70587f3ba8 100644
--- a/media-sound/lilypond/ChangeLog
+++ b/media-sound/lilypond/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/lilypond
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lilypond/ChangeLog,v 1.125 2012/09/05 18:13:53 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lilypond/ChangeLog,v 1.126 2012/09/15 09:54:31 radhermit Exp $
+
+*lilypond-2.17.2 (15 Sep 2012)
+
+ 15 Sep 2012; Tim Harder <radhermit@gentoo.org> +lilypond-2.17.2.ebuild,
+ +files/lilypond-2.17.2-tex-docs.patch:
+ Version bump.
05 Sep 2012; Tim Harder <radhermit@gentoo.org> lilypond-2.16.0.ebuild,
+files/lilypond-2.16.0-tex-docs.patch:
diff --git a/media-sound/lilypond/files/lilypond-2.17.2-tex-docs.patch b/media-sound/lilypond/files/lilypond-2.17.2-tex-docs.patch
new file mode 100644
index 000000000000..9e0d7082c0d8
--- /dev/null
+++ b/media-sound/lilypond/files/lilypond-2.17.2-tex-docs.patch
@@ -0,0 +1,20 @@
+--- lilypond-2.17.2/GNUmakefile.in
++++ lilypond-2.17.2/GNUmakefile.in
+@@ -5,7 +5,7 @@
+ SUBDIRS = python scripts \
+ flower lily \
+ mf ly \
+- tex ps scm \
++ ps scm \
+ po \
+ elisp vim \
+ input \
+@@ -14,7 +14,7 @@
+
+ ## this convoluted construction is necessary, since we don't know the
+ ## value of DOCUMENTATION here.
+-documentation-dir=$(if $(findstring no,$(DOCUMENTATION)),,Documentation)
++documentation-dir=$(if $(findstring no,$(DOCUMENTATION)),,Documentation tex)
+
+ SCRIPTS = configure autogen.sh smart-autogen.sh smart-configure.sh
+ README_FILES = COPYING COPYING.FDL DEDICATION ROADMAP HACKING \
diff --git a/media-sound/lilypond/lilypond-2.17.2.ebuild b/media-sound/lilypond/lilypond-2.17.2.ebuild
new file mode 100644
index 000000000000..0fde209fb933
--- /dev/null
+++ b/media-sound/lilypond/lilypond-2.17.2.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lilypond/lilypond-2.17.2.ebuild,v 1.1 2012/09/15 09:54:31 radhermit Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2"
+
+inherit elisp-common python autotools eutils
+
+DESCRIPTION="GNU Music Typesetter"
+SRC_URI="http://download.linuxaudio.org/lilypond/sources/v${PV:0:4}/${P}.tar.gz"
+HOMEPAGE="http://lilypond.org/"
+
+SLOT="0"
+LICENSE="GPL-3 FDL-1.3"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="debug emacs profile vim-syntax"
+
+RDEPEND=">=app-text/ghostscript-gpl-8.15
+ >=dev-scheme/guile-1.8.2[deprecated,regex]
+ media-fonts/urw-fonts
+ media-libs/fontconfig
+ media-libs/freetype:2
+ >=x11-libs/pango-1.12.3
+ emacs? ( virtual/emacs )"
+DEPEND="${RDEPEND}
+ app-text/t1utils
+ dev-lang/perl
+ dev-texlive/texlive-metapost
+ virtual/pkgconfig
+ media-gfx/fontforge
+ >=sys-apps/texinfo-4.11
+ >=sys-devel/bison-2.0
+ sys-devel/flex
+ sys-devel/gettext
+ sys-devel/make"
+
+# Correct output data for tests isn't bundled with releases
+RESTRICT="test"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-tex-docs.patch
+
+ if ! use vim-syntax ; then
+ sed -i -e "s/vim//" GNUmakefile.in || die
+ fi
+
+ sed -i -e "s/OPTIMIZE -g/OPTIMIZE/" aclocal.m4 || die
+
+ eautoreconf
+}
+
+src_configure() {
+ # documentation generation currently not supported since it requires a newer
+ # version of texi2html than is currently in the tree
+
+ econf \
+ --with-ncsb-dir=/usr/share/fonts/urw-fonts \
+ --disable-documentation \
+ --disable-optimising \
+ --disable-pipe \
+ $(use_enable debug debugging) \
+ $(use_enable profile profiling)
+}
+
+src_compile() {
+ default
+
+ if use emacs ; then
+ elisp-compile elisp/lilypond-{font-lock,indent,mode,what-beat}.el \
+ || die "elisp-compile failed"
+ fi
+}
+
+src_install () {
+ emake DESTDIR="${D}" vimdir=/usr/share/vim/vimfiles install
+
+ # remove elisp files since they are in the wrong directory
+ rm -r "${D}"/usr/share/emacs || die
+
+ if use emacs ; then
+ elisp-install ${PN} elisp/*.{el,elc} elisp/out/*.el \
+ || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}"/50${PN}-gentoo.el
+ fi
+
+ python_convert_shebangs -r 2 "${D}"
+
+ dodoc AUTHORS.txt HACKING NEWS.txt README.txt
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}