summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStanislav Ochotnicky <sochotnicky@gentoo.org>2013-06-08 16:44:20 +0000
committerStanislav Ochotnicky <sochotnicky@gentoo.org>2013-06-08 16:44:20 +0000
commitfe6d8a9591c32379da1c4abce6f675508447d751 (patch)
tree8e704803468c59173eae5a0b33dec574038aa226 /media-sound
parentDo not compress examples (diff)
downloadgentoo-2-fe6d8a9591c32379da1c4abce6f675508447d751.tar.gz
gentoo-2-fe6d8a9591c32379da1c4abce6f675508447d751.tar.bz2
gentoo-2-fe6d8a9591c32379da1c4abce6f675508447d751.zip
Version bump from beta, remove patches included upstream
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 7B087241)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/beets/ChangeLog9
-rw-r--r--media-sound/beets/beets-1.1.0.ebuild (renamed from media-sound/beets/beets-1.1.0_beta3.ebuild)60
-rw-r--r--media-sound/beets/files/0001-fix-VFS-tests.patch30
-rw-r--r--media-sound/beets/files/beets-1.0_rc2-test-namespace.patch17
4 files changed, 29 insertions, 87 deletions
diff --git a/media-sound/beets/ChangeLog b/media-sound/beets/ChangeLog
index c55d4190cbe0..b417b763b350 100644
--- a/media-sound/beets/ChangeLog
+++ b/media-sound/beets/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/beets
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/beets/ChangeLog,v 1.13 2013/04/06 23:56:35 sochotnicky Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/beets/ChangeLog,v 1.14 2013/06/08 16:44:19 sochotnicky Exp $
+
+*beets-1.1.0 (08 Jun 2013)
+
+ 08 Jun 2013; Stanislav Ochotnicky <sochotnicky@gentoo.org>
+ -beets-1.1.0_beta3.ebuild, +beets-1.1.0.ebuild,
+ -files/0001-fix-VFS-tests.patch, -files/beets-1.0_rc2-test-namespace.patch:
+ Version bump from beta, remove patches included upstream
*beets-1.1.0_beta3 (06 Apr 2013)
diff --git a/media-sound/beets/beets-1.1.0_beta3.ebuild b/media-sound/beets/beets-1.1.0.ebuild
index 8db5f9aed1f6..5e047afe9bcc 100644
--- a/media-sound/beets/beets-1.1.0_beta3.ebuild
+++ b/media-sound/beets/beets-1.1.0.ebuild
@@ -1,16 +1,13 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/beets/beets-1.1.0_beta3.ebuild,v 1.1 2013/04/06 23:56:35 sochotnicky Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/beets/beets-1.1.0.ebuild,v 1.1 2013/06/08 16:44:19 sochotnicky Exp $
-EAPI="4"
+EAPI="5"
-PYTHON_DEPEND="2:2.7"
-PYTHON_USE_WITH="sqlite"
-SUPPORT_PYTHON_ABIS="1"
-#There a few test failures with 2.6, worth investigating
-RESTRICT_PYTHON_ABIS="2.5 2.6 3.* 2.7-pypy-*"
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
-inherit distutils eutils
+inherit distutils-r1 eutils
MY_PV=${PV/_beta/-beta.}
MY_P=${PN}-${MY_PV}
@@ -22,40 +19,30 @@ HOMEPAGE="http://beets.radbox.org/"
KEYWORDS="~amd64 ~x86"
SLOT="0"
LICENSE="MIT"
-IUSE="bpd chroma convert doc echonest_tempo lastgenre replaygain web"
+IUSE="bpd chroma convert doc echonest_tempo lastgenre replaygain test web"
RDEPEND="
- dev-python/munkres
- >=dev-python/python-musicbrainz-ngs-0.3
- dev-python/unidecode
- >=media-libs/mutagen-0.21
- dev-python/pyyaml
- bpd? ( dev-python/bluelet )
- chroma? ( dev-python/pyacoustid )
+ dev-python/munkres[${PYTHON_USEDEP}]
+ >=dev-python/python-musicbrainz-ngs-0.3[${PYTHON_USEDEP}]
+ dev-python/unidecode[${PYTHON_USEDEP}]
+ >=media-libs/mutagen-0.21[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ bpd? ( dev-python/bluelet[${PYTHON_USEDEP}] )
+ chroma? ( dev-python/pyacoustid[${PYTHON_USEDEP}] )
convert? ( media-video/ffmpeg[encode] )
doc? ( dev-python/sphinx )
- echonest_tempo? ( dev-python/pyechonest )
- lastgenre? ( dev-python/pylast )
+ echonest_tempo? ( dev-python/pyechonest[${PYTHON_USEDEP}] )
+ lastgenre? ( dev-python/pylast[${PYTHON_USEDEP}] )
replaygain? ( || ( media-sound/mp3gain media-sound/aacgain ) )
- web? ( dev-python/flask )
+ web? ( dev-python/flask[${PYTHON_USEDEP}] )
"
DEPEND="${RDEPEND}
- dev-python/setuptools"
+ dev-python/setuptools[${PYTHON_USEDEP}]"
S=${WORKDIR}/${MY_P}
src_prepare() {
- distutils_src_prepare
-
- # we'll need this as long as portage doesn't have proper python
- # namespace support (without this we would try to load modules from
- # previous installation during updates)
- if use test;then
- epatch "${FILESDIR}/${PN}-1.0_rc2-test-namespace.patch"
- epatch "${FILESDIR}/0001-fix-VFS-tests.patch"
- fi
-
# remove plugins that do not have appropriate dependencies installed
for flag in bpd chroma convert echonest_tempo lastgenre replaygain web;do
if ! use $flag ; then
@@ -75,21 +62,16 @@ src_prepare() {
}
-src_compile() {
- distutils_src_compile
+python_compile_all() {
use doc && emake -C docs html
}
-src_test() {
+python_test() {
cd test
- testing() {
- PYTHONPATH="../build-${PYTHON_ABI}/lib" "$(PYTHON)" testall.py
- }
- python_execute_function testing
+ "${PYTHON}" testall.py || die "Testsuite failed"
}
-src_install() {
- distutils_src_install
+python_install_all() {
doman man/beet.1 man/beetsconfig.5
use doc && dohtml -r docs/_build/html/
diff --git a/media-sound/beets/files/0001-fix-VFS-tests.patch b/media-sound/beets/files/0001-fix-VFS-tests.patch
deleted file mode 100644
index 0c630a22412f..000000000000
--- a/media-sound/beets/files/0001-fix-VFS-tests.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 963b0d11d6f25ec8a8bd95e9fcea2d9933e31bcf Mon Sep 17 00:00:00 2001
-From: Adrian Sampson <adrian@radbox.org>
-Date: Sat, 6 Apr 2013 16:35:17 -0700
-Subject: [PATCH 1/3] fix VFS tests
-
-The configuration was not loaded for these tests because they didn't inherit
-the common test harness. These failures were hidden on my system because of
-some kind of dependency on another test.
----
- test/test_vfs.py | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/test/test_vfs.py b/test/test_vfs.py
-index 04ff3d6..755311b 100644
---- a/test/test_vfs.py
-+++ b/test/test_vfs.py
-@@ -18,8 +18,9 @@ from _common import unittest
- from beets import library
- from beets import vfs
-
--class VFSTest(unittest.TestCase):
-+class VFSTest(_common.TestCase):
- def setUp(self):
-+ super(VFSTest, self).setUp()
- self.lib = library.Library(':memory:', path_formats=[
- ('default', 'albums/$album/$title'),
- ('singleton:true', 'tracks/$artist/$title'),
---
-1.8.1.5
-
diff --git a/media-sound/beets/files/beets-1.0_rc2-test-namespace.patch b/media-sound/beets/files/beets-1.0_rc2-test-namespace.patch
deleted file mode 100644
index 38c341933d1a..000000000000
--- a/media-sound/beets/files/beets-1.0_rc2-test-namespace.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff --git a/test/testall.py b/test/testall.py
-index 3e12d78..6031fc3 100755
---- a/test/testall.py
-+++ b/test/testall.py
-@@ -24,6 +24,12 @@ pkgpath = os.path.dirname(__file__) or '.'
- sys.path.append(pkgpath)
- os.chdir(pkgpath)
-
-+try:
-+ del sys.modules["beetsplug"]
-+except KeyError:
-+ pass
-+
-+
- def suite():
- s = unittest.TestSuite()
- # Get the suite() of every module in this directory beginning with