summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Weiler <pylon@gentoo.org>2008-03-30 14:57:58 +0000
committerLars Weiler <pylon@gentoo.org>2008-03-30 14:57:58 +0000
commitbb9dd14880084803dace1cdc98ff1131a7a391f5 (patch)
treebcb84885fca458d37fff173e9e1f89ebf415dcd4 /media-tv/nxtvepg/nxtvepg-2.8.0.ebuild
parentBuild breaks on newer libdvdnav, add blocker to depend (diff)
downloadgentoo-2-bb9dd14880084803dace1cdc98ff1131a7a391f5.tar.gz
gentoo-2-bb9dd14880084803dace1cdc98ff1131a7a391f5.tar.bz2
gentoo-2-bb9dd14880084803dace1cdc98ff1131a7a391f5.zip
Version bump; fixes tcl8.5-compatibility; bug #212682 and #173467.
Probably the tcl/tk-dependency must be fixed to 8.5, but that version is still masked. (Portage version: 2.1.4.4)
Diffstat (limited to 'media-tv/nxtvepg/nxtvepg-2.8.0.ebuild')
-rw-r--r--media-tv/nxtvepg/nxtvepg-2.8.0.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/media-tv/nxtvepg/nxtvepg-2.8.0.ebuild b/media-tv/nxtvepg/nxtvepg-2.8.0.ebuild
new file mode 100644
index 000000000000..2aa3436bd9c1
--- /dev/null
+++ b/media-tv/nxtvepg/nxtvepg-2.8.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/nxtvepg/nxtvepg-2.8.0.ebuild,v 1.1 2008/03/30 14:57:58 pylon Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="receive and browse free TV programme listings via bttv for tv networks in Europe"
+HOMEPAGE="http://nxtvepg.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="X unicode"
+
+RDEPEND="X? ( >=dev-lang/tcl-8
+ >=dev-lang/tk-8
+ x11-libs/libX11
+ x11-libs/libXmu )"
+
+DEPEND="${RDEPEND}
+ sys-apps/sed
+ sys-kernel/linux-headers
+ X? ( x11-proto/xproto )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/nxtvepg-db.patch" || die "db patch failed"
+ epatch "${FILESDIR}/nxtvepg-daemon-install.patch" || die "daemon patch failed"
+ epatch "${FILESDIR}/nxtvepg-tcl8.5.patch" || die "tcl-8.5 patch failed"
+ ( use unicode && epatch "${FILESDIR}/nxtvepg-unicode.patch" ) || die "unicode patch failed"
+}
+
+src_compile() {
+ if use X; then
+ emake -j1 CC=$(tc-getCC) prefix="/usr" || die "emake failed"
+ else
+ emake -j1 CC=$(tc-getCC) prefix="/usr" daemon || die "emake failed"
+ fi
+}
+
+src_install() {
+ if use X; then
+ emake ROOT="${D}" prefix="/usr" install || die "emake install failed"
+ else
+ emake ROOT="${D}" prefix="/usr" install-daemon || die "emake install failed"
+ fi
+ dodoc README CHANGES TODO
+ dohtml manual*.html
+}