summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Bornkessel <hd_brummy@gentoo.org>2008-01-13 14:28:47 +0000
committerJörg Bornkessel <hd_brummy@gentoo.org>2008-01-13 14:28:47 +0000
commitad546f66ea4579ca054c70b2445f14e9695b9bb5 (patch)
tree6814809a11fa5dbcaeee019dc0f16d5c0215ff47 /media-tv/shoutcast2vdr/shoutcast2vdr-0.0.8.ebuild
parentadd missing pkgconfig dep, bug #205607, make it build with gtk 2.12 (diff)
downloadgentoo-2-ad546f66ea4579ca054c70b2445f14e9695b9bb5.tar.gz
gentoo-2-ad546f66ea4579ca054c70b2445f14e9695b9bb5.tar.bz2
gentoo-2-ad546f66ea4579ca054c70b2445f14e9695b9bb5.zip
initial ebuild; moved from vdr-testing overlay; Thanks to T.Kost for this ebuild
(Portage version: 2.1.3.19)
Diffstat (limited to 'media-tv/shoutcast2vdr/shoutcast2vdr-0.0.8.ebuild')
-rw-r--r--media-tv/shoutcast2vdr/shoutcast2vdr-0.0.8.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-tv/shoutcast2vdr/shoutcast2vdr-0.0.8.ebuild b/media-tv/shoutcast2vdr/shoutcast2vdr-0.0.8.ebuild
new file mode 100644
index 000000000000..c1ee7b6bec44
--- /dev/null
+++ b/media-tv/shoutcast2vdr/shoutcast2vdr-0.0.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2003-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/shoutcast2vdr/shoutcast2vdr-0.0.8.ebuild,v 1.1 2008/01/13 14:28:46 hd_brummy Exp $
+
+DESCRIPTION="VDR script: generate shoutcast playlists"
+HOMEPAGE="http://www.vdr-portal.de/board/thread.php?threadid=19478"
+SRC_URI="http://www.kost.sh/vdr/${P}.gz"
+
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND="media-video/vdr"
+
+S="${WORKDIR}"
+
+PLAYLIST_DIR="/var/cache/vdr/music/playlists"
+
+src_unpack() {
+
+ unpack ${A}
+ cd "${S}"
+
+ sed -i shoutcast2vdr-0.0.8 -e "s:outputdir=/home/volker/vdr/radio:outputdir=${PLAYLIST_DIR}:"
+}
+
+src_install() {
+
+ exeinto /usr/share/vdr/shoutcast2vdr
+ newexe shoutcast2vdr-0.0.8 shoutcast2vdr
+
+ keepdir ${PLAYLIST_DIR}
+}