summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2008-04-01 16:50:58 +0000
committerDoug Goldstein <cardoe@gentoo.org>2008-04-01 16:50:58 +0000
commit3dcad2d704eb8a5f1a5f60f50dab597df2fb65fe (patch)
tree50de2ee5bded86930b3d55bb88ee3bb7b98963db /media-tv
parentremove ivtv depend and USE since MythTV no longer builds against ivtv header ... (diff)
downloadgentoo-2-3dcad2d704eb8a5f1a5f60f50dab597df2fb65fe.tar.gz
gentoo-2-3dcad2d704eb8a5f1a5f60f50dab597df2fb65fe.tar.bz2
gentoo-2-3dcad2d704eb8a5f1a5f60f50dab597df2fb65fe.zip
remove dbox2, hdhomerun, and iptv USE flags since the build system seems to build their support anyway
(Portage version: 2.1.4.4)
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/mythtv/ChangeLog7
-rw-r--r--media-tv/mythtv/mythtv-0.21_p16867.ebuild10
-rw-r--r--media-tv/mythtv/mythtv-0.22_alpha16870.ebuild10
3 files changed, 12 insertions, 15 deletions
diff --git a/media-tv/mythtv/ChangeLog b/media-tv/mythtv/ChangeLog
index 6629b285125d..19a301c610c7 100644
--- a/media-tv/mythtv/ChangeLog
+++ b/media-tv/mythtv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-tv/mythtv
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.232 2008/04/01 16:43:15 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.233 2008/04/01 16:50:58 cardoe Exp $
+
+ 01 Apr 2008; Doug Goldstein <cardoe@gentoo.org> mythtv-0.21_p16867.ebuild,
+ mythtv-0.22_alpha16870.ebuild:
+ remove dbox2, hdhomerun, and iptv USE flags since the build system seems
+ to build their support anyway
01 Apr 2008; Doug Goldstein <cardoe@gentoo.org> mythtv-0.21_p16867.ebuild,
mythtv-0.22_alpha16870.ebuild:
diff --git a/media-tv/mythtv/mythtv-0.21_p16867.ebuild b/media-tv/mythtv/mythtv-0.21_p16867.ebuild
index 42702565d57c..eff0f8b4ee7e 100644
--- a/media-tv/mythtv/mythtv-0.21_p16867.ebuild
+++ b/media-tv/mythtv/mythtv-0.21_p16867.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.21_p16867.ebuild,v 1.2 2008/04/01 16:43:15 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.21_p16867.ebuild,v 1.3 2008/04/01 16:50:58 cardoe Exp $
EAPI=1
inherit flag-o-matic multilib eutils qt3 mythtv toolchain-funcs python
@@ -10,8 +10,8 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE_VIDEO_CARDS="video_cards_nvidia video_cards_via"
-IUSE="aac alsa altivec autostart dbox2 debug directv dvb dvd hdhomerun \
-ieee1394 iptv jack joystick lcd lirc mmx opengl opengl-video opengl-xvmc \
+IUSE="aac alsa altivec autostart debug directv dvb dvd \
+ieee1394 jack lcd lirc mmx opengl opengl-video opengl-xvmc \
perl python xvmc ${IUSE_VIDEO_CARDS}"
RDEPEND=">=media-libs/freetype-2.0
@@ -115,8 +115,6 @@ src_compile() {
use aac && myconf="${myconf} --enable-libfaad"
use alsa || myconf="${myconf} --disable-audio-alsa"
use altivec || myconf="${myconf} --disable-altivec"
- use dbox2 || myconf="${myconf} --disable-dbox2"
- use hdhomerun || myconf="${myconf} --disable-hdhomerun"
use jack || myconf="${myconf} --disable-audio-jack"
use opengl-video && myconf="${myconf} --enable-opengl-video"
use xvmc && ! use video_cards_via ! use opengl-xvmc && myconf="${myconf} --enable-xvmc --xvmc-lib=XvMCW"
@@ -125,8 +123,6 @@ src_compile() {
myconf="${myconf}
$(use_enable dvb)
$(use_enable ieee1394 firewire)
- $(use_enable iptv)
- $(use_enable joystick joystick-menu)
$(use_enable lirc)
--disable-audio-arts
--disable-directfb
diff --git a/media-tv/mythtv/mythtv-0.22_alpha16870.ebuild b/media-tv/mythtv/mythtv-0.22_alpha16870.ebuild
index b901000d9bf5..3179771afd72 100644
--- a/media-tv/mythtv/mythtv-0.22_alpha16870.ebuild
+++ b/media-tv/mythtv/mythtv-0.22_alpha16870.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.22_alpha16870.ebuild,v 1.4 2008/04/01 16:43:15 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.22_alpha16870.ebuild,v 1.5 2008/04/01 16:50:58 cardoe Exp $
EAPI=1
inherit flag-o-matic multilib eutils qt4 mythtv toolchain-funcs python
@@ -10,8 +10,8 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE_VIDEO_CARDS="video_cards_nvidia video_cards_via"
-IUSE="alsa altivec autostart dbox2 debug directv dvb dvd hdhomerun \
-ieee1394 iptv jack joystick lcd lirc mmx opengl opengl-video
+IUSE="alsa altivec autostart debug directv dvb dvd \
+ieee1394 jack lcd lirc mmx opengl opengl-video \
opengl-xvmc perl python xvmc ${IUSE_VIDEO_CARDS}"
RDEPEND=">=media-libs/freetype-2.0
@@ -114,8 +114,6 @@ src_compile() {
--libdir-name=$(get_libdir)"
use alsa || myconf="${myconf} --disable-audio-alsa"
use altivec || myconf="${myconf} --disable-altivec"
- use dbox2 || myconf="${myconf} --disable-dbox2"
- use hdhomerun || myconf="${myconf} --disable-hdhomerun"
use jack || myconf="${myconf} --disable-audio-jack"
use opengl-video && myconf="${myconf} --enable-opengl-video"
use xvmc && ! use video_cards_via ! use opengl-xvmc && myconf="${myconf} --enable-xvmc --xvmc-lib=XvMCW"
@@ -124,8 +122,6 @@ src_compile() {
myconf="${myconf}
$(use_enable dvb)
$(use_enable ieee1394 firewire)
- $(use_enable iptv)
- $(use_enable joystick joystick-menu)
$(use_enable lirc)
--disable-audio-arts
--disable-directfb