summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-01-26 12:39:15 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-01-26 12:39:15 +0000
commit908e815694690bb16c139d291191082c6d05bf28 (patch)
treeaa732841725641574d1096f5226e7ffeb69c3150 /media-tv
parentCheck that ${PREFIX} is non-empty before using it. (diff)
downloadgentoo-2-908e815694690bb16c139d291191082c6d05bf28.tar.gz
gentoo-2-908e815694690bb16c139d291191082c6d05bf28.tar.bz2
gentoo-2-908e815694690bb16c139d291191082c6d05bf28.zip
Add patch to link with non-lazy bindings kdetvv4lsetup binary.
(Portage version: 2529-svn)
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/kdetv/ChangeLog6
-rw-r--r--media-tv/kdetv/files/kdetv-0.8.8-bindnow.patch19
-rw-r--r--media-tv/kdetv/kdetv-0.8.8-r1.ebuild9
3 files changed, 30 insertions, 4 deletions
diff --git a/media-tv/kdetv/ChangeLog b/media-tv/kdetv/ChangeLog
index 5e538ba86132..e4d714e37b2e 100644
--- a/media-tv/kdetv/ChangeLog
+++ b/media-tv/kdetv/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-tv/kdetv
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/kdetv/ChangeLog,v 1.19 2006/01/26 12:03:50 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/kdetv/ChangeLog,v 1.20 2006/01/26 12:39:15 flameeyes Exp $
+
+ 26 Jan 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/kdetv-0.8.8-bindnow.patch, kdetv-0.8.8-r1.ebuild:
+ Add patch to link with non-lazy bindings kdetvv4lsetup binary.
26 Jan 2006; Diego Pettenò <flameeyes@gentoo.org> kdetv-0.8.8-r1.ebuild:
Change Makefile.am and not Makefile.in as we have to re-run autotools anyway.
diff --git a/media-tv/kdetv/files/kdetv-0.8.8-bindnow.patch b/media-tv/kdetv/files/kdetv-0.8.8-bindnow.patch
new file mode 100644
index 000000000000..edba44eb0a8f
--- /dev/null
+++ b/media-tv/kdetv/files/kdetv-0.8.8-bindnow.patch
@@ -0,0 +1,19 @@
+Add support for BINDNOW_FLAGS to build kdetvv4lsetup with
+non-lazy bindings, to improve security and fix installation on
+FEATURES=stricter.
+
+Requires the ebuild to export BINDNOW_FLAGS="$(bindnow-flags)".
+
+Index: kdetv-0.8.8/kdetv/kvideoio/kdetvv4lsetup/Makefile.am
+===================================================================
+--- kdetv-0.8.8.orig/kdetv/kvideoio/kdetvv4lsetup/Makefile.am
++++ kdetv-0.8.8/kdetv/kvideoio/kdetvv4lsetup/Makefile.am
+@@ -8,7 +8,7 @@ kdetvv4lsetup_SOURCES = kdetvv4lsetup.c
+ kdetvv4lsetup_CFLAGS = $(KDE_USE_FPIE)
+
+ # the library search path
+-kdetvv4lsetup_LDFLAGS = $(KDE_USE_PIE) $(all_libraries)
++kdetvv4lsetup_LDFLAGS = $(KDE_USE_PIE) $(all_libraries) $(BINDNOW_FLAGS)
+
+ # the libraries to link against. Be aware of the order. First the libraries,
+ # that depend on the following ones.
diff --git a/media-tv/kdetv/kdetv-0.8.8-r1.ebuild b/media-tv/kdetv/kdetv-0.8.8-r1.ebuild
index d9e11ae71002..ad481cc92380 100644
--- a/media-tv/kdetv/kdetv-0.8.8-r1.ebuild
+++ b/media-tv/kdetv/kdetv-0.8.8-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/kdetv/kdetv-0.8.8-r1.ebuild,v 1.4 2006/01/26 12:03:50 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/kdetv/kdetv-0.8.8-r1.ebuild,v 1.5 2006/01/26 12:39:15 flameeyes Exp $
-inherit kde
+inherit kde flag-o-matic
DESCRIPTION="A TV application for KDE"
HOMEPAGE="http://www.kwintv.org/"
@@ -38,7 +38,8 @@ DEPEND="${RDEPEND}
need-kde 3.2
-PATCHES="${FILESDIR}/${P}-xinerama.patch"
+PATCHES="${FILESDIR}/${P}-xinerama.patch
+ ${FILESDIR}/${P}-bindnow.patch"
src_unpack() {
LANGS="bg ca br da de cs cy el es et fi ga fr gl hu is it lt nb mt nl pa pl pt ro ru rw ta sr sv tr en_GB pt_BR zh_CN sr@Latn"
@@ -57,5 +58,7 @@ src_unpack() {
src_compile() {
local myconf="$(use_enable arts) $(use_enable lirc kdetv-lirc)
$(use_with zvbi) $(use_with opengl gl)"
+
+ export BINDNOW_FLAGS="$(bindnow-flags)"
kde_src_compile all
}