summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-08 02:05:09 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-08 02:05:09 +0000
commit9f1a46799419fd5fbc5ac12e560e7952ebb39eab (patch)
treedb9e83e59d07da15988dbbcdfc62caf2798330b2 /media-tv
parentfinish trimming out the old (diff)
downloadgentoo-2-9f1a46799419fd5fbc5ac12e560e7952ebb39eab.tar.gz
gentoo-2-9f1a46799419fd5fbc5ac12e560e7952ebb39eab.tar.bz2
gentoo-2-9f1a46799419fd5fbc5ac12e560e7952ebb39eab.zip
Fix use invocation
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/freevo/ChangeLog6
-rw-r--r--media-tv/freevo/freevo-1.4.1.ebuild6
-rw-r--r--media-tv/freevo/freevo-1.4.ebuild6
-rw-r--r--media-tv/mythfrontend/ChangeLog6
-rw-r--r--media-tv/mythfrontend/mythfrontend-0.13.ebuild12
-rw-r--r--media-tv/mythfrontend/mythfrontend-0.14-r1.ebuild18
-rw-r--r--media-tv/mythfrontend/mythfrontend-0.15.1.ebuild22
-rw-r--r--media-tv/mythtv/ChangeLog6
-rw-r--r--media-tv/mythtv/mythtv-0.13-r1.ebuild14
-rw-r--r--media-tv/mythtv/mythtv-0.14-r1.ebuild18
-rw-r--r--media-tv/mythtv/mythtv-0.15.1.ebuild22
-rw-r--r--media-tv/xawtv/ChangeLog7
-rw-r--r--media-tv/xawtv/xawtv-3.86-r1.ebuild4
-rw-r--r--media-tv/xawtv/xawtv-3.88.1.ebuild4
-rw-r--r--media-tv/xawtv/xawtv-3.88.ebuild4
-rw-r--r--media-tv/xawtv/xawtv-3.90-r1.ebuild4
-rw-r--r--media-tv/xawtv/xawtv-3.90.ebuild4
-rw-r--r--media-tv/xawtv/xawtv-3.91-r1.ebuild4
-rw-r--r--media-tv/xawtv/xawtv-3.91.ebuild4
19 files changed, 94 insertions, 77 deletions
diff --git a/media-tv/freevo/ChangeLog b/media-tv/freevo/ChangeLog
index d9bd69b2a702..a687a84ffe96 100644
--- a/media-tv/freevo/ChangeLog
+++ b/media-tv/freevo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-tv/freevo
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/freevo/ChangeLog,v 1.14 2004/05/29 22:31:42 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/freevo/ChangeLog,v 1.15 2004/06/08 02:04:33 agriffis Exp $
+
+ 07 Jun 2004; Aron Griffis <agriffis@gentoo.org> freevo-1.4.1.ebuild,
+ freevo-1.4.ebuild:
+ Fix use invocation
30 May 2004; David Holm <dholm@gentoo.org> freevo-1.4.1.ebuild:
Added to ~ppc.
diff --git a/media-tv/freevo/freevo-1.4.1.ebuild b/media-tv/freevo/freevo-1.4.1.ebuild
index a52e4e28b23c..4c07c3119f93 100644
--- a/media-tv/freevo/freevo-1.4.1.ebuild
+++ b/media-tv/freevo/freevo-1.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/freevo/freevo-1.4.1.ebuild,v 1.3 2004/05/29 22:31:42 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/freevo/freevo-1.4.1.ebuild,v 1.4 2004/06/08 02:04:33 agriffis Exp $
inherit distutils
@@ -39,9 +39,9 @@ src_compile() {
if [ "`/bin/ls -l /etc/localtime | grep Europe`" ] ; then
myconf="${myconf} --tv=pal"
fi
- if [ "`use matrox`" ] ; then
+ if use matrox ; then
myconf="${myconf} --geometry=768x576 --display=mga"
- elif [ "`use X`" ] ; then
+ elif use X ; then
myconf="${myconf} --geometry=800x600 --display=x11"
else
myconf="${myconf} --geometry=800x600 --display=fbdev"
diff --git a/media-tv/freevo/freevo-1.4.ebuild b/media-tv/freevo/freevo-1.4.ebuild
index eb9b3892e9f8..e2504cd39014 100644
--- a/media-tv/freevo/freevo-1.4.ebuild
+++ b/media-tv/freevo/freevo-1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/freevo/freevo-1.4.ebuild,v 1.4 2004/05/27 06:58:31 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/freevo/freevo-1.4.ebuild,v 1.5 2004/06/08 02:04:33 agriffis Exp $
inherit distutils
@@ -39,9 +39,9 @@ src_compile() {
if [ "`/bin/ls -l /etc/localtime | grep Europe`" ] ; then
myconf="${myconf} --tv=pal"
fi
- if [ "`use matrox`" ] ; then
+ if use matrox ; then
myconf="${myconf} --geometry=768x576 --display=mga"
- elif [ "`use X`" ] ; then
+ elif use X ; then
myconf="${myconf} --geometry=800x600 --display=x11"
else
myconf="${myconf} --geometry=800x600 --display=fbdev"
diff --git a/media-tv/mythfrontend/ChangeLog b/media-tv/mythfrontend/ChangeLog
index a0ff869a437e..ff31d328e933 100644
--- a/media-tv/mythfrontend/ChangeLog
+++ b/media-tv/mythfrontend/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-tv/mythfrontend
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/ChangeLog,v 1.16 2004/06/02 21:45:18 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/ChangeLog,v 1.17 2004/06/08 02:02:04 agriffis Exp $
+
+ 07 Jun 2004; Aron Griffis <agriffis@gentoo.org> mythfrontend-0.13.ebuild,
+ mythfrontend-0.14-r1.ebuild, mythfrontend-0.15.1.ebuild:
+ Fix use invocation
02 Jun 2004; Daniel Ahlberg <aliz@gentoo.org> mythfrontend-0.15.1.ebuild:
+ Added check for OpenGL implementation, closing #52722.
diff --git a/media-tv/mythfrontend/mythfrontend-0.13.ebuild b/media-tv/mythfrontend/mythfrontend-0.13.ebuild
index 2cbb21c7d7f5..3c5a8f89f5b5 100644
--- a/media-tv/mythfrontend/mythfrontend-0.13.ebuild
+++ b/media-tv/mythfrontend/mythfrontend-0.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/mythfrontend-0.13.ebuild,v 1.3 2004/04/26 04:07:44 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/mythfrontend-0.13.ebuild,v 1.4 2004/06/08 02:02:04 agriffis Exp $
inherit flag-o-matic
@@ -53,27 +53,27 @@ src_compile() {
sed -e "s:pentiumpro:${cpu}:g" -i "settings.pro" || die "sed failed"
fi
- if [ "`use alsa`" ] ; then
+ if use alsa ; then
sed -e "s:#CONFIG += using_alsa:CONFIG += using_alsa:" \
-e "s:#ALSA_LIBS = -lasound:ALSA_LIBS = -lasound:" \
-i "settings.pro" || die "enable alsa sed failed"
fi
- if [ "`use lcd`" ] ; then
+ if use lcd ; then
sed -e "s:#DEFINES += LCD_DEVICE:DEFINES += LCD_DEVICE:" \
-i "settings.pro" || die "enable lcd sed failed"
fi
- if [ "`use lirc`" ] ; then
+ if use lirc ; then
sed -e "s:#CONFIG += using_lirc:CONFIG += using_lirc:" \
-e "s:#LIRC_LIBS = -llirc_client:LIRC_LIBS = -llirc_client:" \
-i "settings.pro" || die "enable lirc sed failed"
fi
- if [ "`use nvidia`" ] ; then
+ if use nvidia ; then
sed -e "s:#CONFIG += using_xvmc:CONFIG += using_xvmc:" \
-e "s:#EXTRA_LIBS += -lXvMCNVIDIA:EXTRA_LIBS += -lXvMCNVIDIA:" \
-i "settings.pro" || die "enable xvmc sed failed"
fi
# Needs a VIA supported kernel driver.
- #if [ "`use via`" ] ; then
+ #if use via ; then
# sed -e "s:#CONFIG += using_via:CONFIG += using_via:"
# -e "s:#EXTRA_LIBS += -lddmpeg:EXTRA_LIBS += -lddmpeg:"
# -i "settings.pro" || die "enable lirc sed failed"
diff --git a/media-tv/mythfrontend/mythfrontend-0.14-r1.ebuild b/media-tv/mythfrontend/mythfrontend-0.14-r1.ebuild
index 2b55e94a6564..1c26288c46a8 100644
--- a/media-tv/mythfrontend/mythfrontend-0.14-r1.ebuild
+++ b/media-tv/mythfrontend/mythfrontend-0.14-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/mythfrontend-0.14-r1.ebuild,v 1.3 2004/04/26 18:36:23 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/mythfrontend-0.14-r1.ebuild,v 1.4 2004/06/08 02:02:04 agriffis Exp $
inherit flag-o-matic
@@ -64,12 +64,12 @@ src_compile() {
fi
fi
- if [ "`use alsa`" ] ; then
+ if use alsa ; then
sed -e 's:#CONFIG += using_alsa:CONFIG += using_alsa:' \
-e 's:#ALSA_LIBS = -lasound:ALSA_LIBS = -lasound:' \
-i 'settings.pro' || die "enable alsa sed failed"
fi
- if [ "`use arts`" ] ; then
+ if use arts ; then
sed -e 's:artsc/artsc.h:artsc.h:' \
-i "libs/libmyth/audiooutputarts.h" || die "sed failed"
sed -e 's:#CONFIG += using_arts:CONFIG += using_arts:' \
@@ -78,34 +78,34 @@ src_compile() {
-e 's:#INCLUDEPATH += /opt/.*:QMAKE_CXXFLAGS += `artsc-config --cflags`:' \
-i 'settings.pro' || die "enable arts sed failed"
fi
- if [ "`use directfb`" ] ; then
+ if use directfb ; then
sed -e 's:#CONFIG += using_directfb:CONFIG += using_directfb:' \
-e 's:#EXTRA_LIBS += `directfb:EXTRA_LIBS += `directfb:' \
-e 's:#QMAKE_CXXFLAGS += `directfb:QMAKE_CXXFLAGS += `directfb:' \
-i 'settings.pro' || die "enable arts sed failed"
fi
- if [ "`use dvb`" ] ; then
+ if use dvb ; then
sed -e 's:#CONFIG += using_dvb:CONFIG += using_dvb:' \
-e 's:#DEFINES += USING_DVB:DEFINES += USING_DVB:' \
-e 's:#INCLUDEPATH += /usr/src/.*:INCLUDEPATH += /usr/include:' \
-i 'settings.pro' || die "enable dvb sed failed"
fi
- if [ "`use lcd`" ] ; then
+ if use lcd ; then
sed -e 's:#DEFINES += LCD_DEVICE:DEFINES += LCD_DEVICE:' \
-i 'settings.pro' || die "enable lcd sed failed"
fi
- if [ "`use lirc`" ] ; then
+ if use lirc ; then
sed -e 's:#CONFIG += using_lirc:CONFIG += using_lirc:' \
-e 's:#LIRC_LIBS = -llirc_client:LIRC_LIBS = -llirc_client:' \
-i 'settings.pro' || die "enable lirc sed failed"
fi
- if [ "`use nvidia`" ] ; then
+ if use nvidia ; then
sed -e 's:#CONFIG += using_xvmc:CONFIG += using_xvmc:' \
-e 's:#DEFINES += USING_XVMC:DEFINES += USING_XVMC:' \
-e 's:#EXTRA_LIBS += -lXvMCNVIDIA:EXTRA_LIBS += -lXvMCNVIDIA:' \
-i 'settings.pro' || die "enable xvmc sed failed"
fi
- if [ "`use cle266`" ] ; then
+ if use cle266 ; then
sed -e 's:#CONFIG += using_viahwslice:CONFIG += using_viahwslice:' \
-e 's:#DEFINES += USING_VIASLICE:DEFINES += USING_VIASLICE:' \
-e 's:#EXTRA_LIBS += -lddmpeg:EXTRA_LIBS += -lddmpeg:' \
diff --git a/media-tv/mythfrontend/mythfrontend-0.15.1.ebuild b/media-tv/mythfrontend/mythfrontend-0.15.1.ebuild
index 9776d81e44b5..583eac16b9e9 100644
--- a/media-tv/mythfrontend/mythfrontend-0.15.1.ebuild
+++ b/media-tv/mythfrontend/mythfrontend-0.15.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/mythfrontend-0.15.1.ebuild,v 1.2 2004/06/02 21:45:18 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/mythfrontend-0.15.1.ebuild,v 1.3 2004/06/08 02:02:04 agriffis Exp $
inherit flag-o-matic eutils
@@ -41,7 +41,7 @@ pkg_setup() {
die "Qt needs MySQL support"
fi
- if [ `use opengl` ] ; then
+ if use opengl ; then
local gl_implementation="$( opengl-update --get-implementation )"
if [ "$gl_implementation" == "xfree" ] || [ "$gl_implementation" == "xorg-x11" ] ; then
return 0
@@ -78,12 +78,12 @@ src_compile() {
fi
fi
- if [ "`use alsa`" ] ; then
+ if use alsa ; then
sed -e 's:#CONFIG += using_alsa:CONFIG += using_alsa:' \
-e 's:#ALSA_LIBS = -lasound:ALSA_LIBS = -lasound:' \
-i 'settings.pro' || die "enable alsa sed failed"
fi
- if [ "`use arts`" ] ; then
+ if use arts ; then
sed -e 's:artsc/artsc.h:artsc.h:' \
-i "libs/libmyth/audiooutputarts.h" || die "sed failed"
sed -e 's:#CONFIG += using_arts:CONFIG += using_arts:' \
@@ -92,40 +92,40 @@ src_compile() {
-e 's:#INCLUDEPATH += /opt/.*:QMAKE_CXXFLAGS += `artsc-config --cflags`:' \
-i 'settings.pro' || die "enable arts sed failed"
fi
- if [ "`use directfb`" ] ; then
+ if use directfb ; then
sed -e 's:#CONFIG += using_directfb:CONFIG += using_directfb:' \
-e 's:#EXTRA_LIBS += `directfb:EXTRA_LIBS += `directfb:' \
-e 's:#QMAKE_CXXFLAGS += `directfb:QMAKE_CXXFLAGS += `directfb:' \
-i 'settings.pro' || die "enable arts sed failed"
fi
- if [ "`use dvb`" ] ; then
+ if use dvb ; then
sed -e 's:#CONFIG += using_dvb:CONFIG += using_dvb:' \
-e 's:#DEFINES += USING_DVB:DEFINES += USING_DVB:' \
-e 's:#INCLUDEPATH += /usr/src/.*:INCLUDEPATH += /usr/include:' \
-i 'settings.pro' || die "enable dvb sed failed"
fi
- if [ "`use lcd`" ] ; then
+ if use lcd ; then
sed -e 's:#DEFINES += LCD_DEVICE:DEFINES += LCD_DEVICE:' \
-i 'settings.pro' || die "enable lcd sed failed"
fi
- if [ "`use lirc`" ] ; then
+ if use lirc ; then
sed -e 's:#CONFIG += using_lirc:CONFIG += using_lirc:' \
-e 's:#LIRC_LIBS = -llirc_client:LIRC_LIBS = -llirc_client:' \
-i 'settings.pro' || die "enable lirc sed failed"
fi
- if [ "`use nvidia`" ] ; then
+ if use nvidia ; then
sed -e 's:#CONFIG += using_xvmc:CONFIG += using_xvmc:' \
-e 's:#DEFINES += USING_XVMC:DEFINES += USING_XVMC:' \
-e 's:#EXTRA_LIBS += -lXvMCNVIDIA:EXTRA_LIBS += -lXvMCNVIDIA:' \
-i 'settings.pro' || die "enable xvmc sed failed"
fi
- if [ "`use cle266`" ] ; then
+ if use cle266 ; then
sed -e 's:#CONFIG += using_viahwslice:CONFIG += using_viahwslice:' \
-e 's:#DEFINES += USING_VIASLICE:DEFINES += USING_VIASLICE:' \
-e 's:#EXTRA_LIBS += -lddmpeg:EXTRA_LIBS += -lddmpeg:' \
-i 'settings.pro' || die "enable lirc sed failed"
fi
- if [ "`use opengl`" ] ; then
+ if use opengl ; then
sed -e 's:#DEFINES += USING_OPENGL_VSYNC:DEFINES += USING_OPENGL_VSYNC:' \
-e 's:#EXTRA_LIBS += -lGL -lGLU:EXTRA_LIBS += -lGL -lGLU:' \
-i 'settings.pro' || die "enable opgenl sed failed"
diff --git a/media-tv/mythtv/ChangeLog b/media-tv/mythtv/ChangeLog
index b2d22f88c163..3803f7f64728 100644
--- a/media-tv/mythtv/ChangeLog
+++ b/media-tv/mythtv/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-tv/mythtv
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.22 2004/06/02 21:45:17 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.23 2004/06/08 02:05:09 agriffis Exp $
+
+ 07 Jun 2004; Aron Griffis <agriffis@gentoo.org> mythtv-0.13-r1.ebuild,
+ mythtv-0.14-r1.ebuild, mythtv-0.15.1.ebuild:
+ Fix use invocation
02 Jun 2004; Daniel Ahlberg <aliz@gentoo.org> mythtv-0.15.1.ebuild:
+ Added check for OpenGL implementation, closing #52722.
diff --git a/media-tv/mythtv/mythtv-0.13-r1.ebuild b/media-tv/mythtv/mythtv-0.13-r1.ebuild
index df66df05dd86..560554dd0262 100644
--- a/media-tv/mythtv/mythtv-0.13-r1.ebuild
+++ b/media-tv/mythtv/mythtv-0.13-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.13-r1.ebuild,v 1.4 2004/04/27 20:46:03 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.13-r1.ebuild,v 1.5 2004/06/08 02:05:09 agriffis Exp $
inherit flag-o-matic eutils
@@ -55,34 +55,34 @@ src_compile() {
sed -e "s:pentiumpro:${cpu}:g" -i "settings.pro" || die "sed failed"
fi
- if [ "`use alsa`" ] ; then
+ if use alsa ; then
sed -e "s:#CONFIG += using_alsa:CONFIG += using_alsa:" \
-e "s:#ALSA_LIBS = -lasound:ALSA_LIBS = -lasound:" \
-i "settings.pro" || die "enable alsa sed failed"
fi
# Not quite ready for prime time.
- #if [ "`use dvb`" ] ; then
+ #if use dvb ; then
# sed -e "s:#CONFIG += using_dvb:CONFIG += using_dvb:" \
# -e "s:#DEFINES += USING_DVB:DEFINES += USING_DVB:" \
# -e "s:#INCLUDEPATH += /usr/src:INCLUDEPATH += /usr:" \
# -i "settings.pro" || die "enable dvb sed failed"
#fi
- if [ "`use lcd`" ] ; then
+ if use lcd ; then
sed -e "s:#DEFINES += LCD_DEVICE:DEFINES += LCD_DEVICE:" \
-i "settings.pro" || die "enable lcd sed failed"
fi
- if [ "`use lirc`" ] ; then
+ if use lirc ; then
sed -e "s:#CONFIG += using_lirc:CONFIG += using_lirc:" \
-e "s:#LIRC_LIBS = -llirc_client:LIRC_LIBS = -llirc_client:" \
-i "settings.pro" || die "enable lirc sed failed"
fi
- if [ "`use nvidia`" ] ; then
+ if use nvidia ; then
sed -e "s:#CONFIG += using_xvmc:CONFIG += using_xvmc:" \
-e "s:#EXTRA_LIBS += -lXvMCNVIDIA:EXTRA_LIBS += -lXvMCNVIDIA:" \
-i "settings.pro" || die "enable xvmc sed failed"
fi
# Needs a VIA supported kernel driver.
- #if [ "`use via`" ] ; then
+ #if use via ; then
# sed -e "s:#CONFIG += using_via:CONFIG += using_via:"
# -e "s:#EXTRA_LIBS += -lddmpeg:EXTRA_LIBS += -lddmpeg:"
# -i "settings.pro" || die "enable lirc sed failed"
diff --git a/media-tv/mythtv/mythtv-0.14-r1.ebuild b/media-tv/mythtv/mythtv-0.14-r1.ebuild
index 2d4ffcb76d54..57402798464f 100644
--- a/media-tv/mythtv/mythtv-0.14-r1.ebuild
+++ b/media-tv/mythtv/mythtv-0.14-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.14-r1.ebuild,v 1.5 2004/04/26 18:38:25 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.14-r1.ebuild,v 1.6 2004/06/08 02:05:09 agriffis Exp $
inherit flag-o-matic
@@ -63,12 +63,12 @@ src_compile() {
fi
fi
- if [ "`use alsa`" ] ; then
+ if use alsa ; then
sed -e 's:#CONFIG += using_alsa:CONFIG += using_alsa:' \
-e 's:#ALSA_LIBS = -lasound:ALSA_LIBS = -lasound:' \
-i 'settings.pro' || die "enable alsa sed failed"
fi
- if [ "`use arts`" ] ; then
+ if use arts ; then
sed -e 's:artsc/artsc.h:artsc.h:' \
-i "libs/libmyth/audiooutputarts.h" || die "sed failed"
sed -e 's:#CONFIG += using_arts:CONFIG += using_arts:' \
@@ -77,34 +77,34 @@ src_compile() {
-e 's:#INCLUDEPATH += /opt/.*:QMAKE_CXXFLAGS += `artsc-config --cflags`:' \
-i 'settings.pro' || die "enable arts sed failed"
fi
- if [ "`use directfb`" ] ; then
+ if use directfb ; then
sed -e 's:#CONFIG += using_directfb:CONFIG += using_directfb:' \
-e 's:#EXTRA_LIBS += `directfb:EXTRA_LIBS += `directfb:' \
-e 's:#QMAKE_CXXFLAGS += `directfb:QMAKE_CXXFLAGS += `directfb:' \
-i 'settings.pro' || die "enable arts sed failed"
fi
- if [ "`use dvb`" ] ; then
+ if use dvb ; then
sed -e 's:#CONFIG += using_dvb:CONFIG += using_dvb:' \
-e 's:#DEFINES += USING_DVB:DEFINES += USING_DVB:' \
-e 's:#INCLUDEPATH += /usr/src/.*:INCLUDEPATH += /usr/include:' \
-i 'settings.pro' || die "enable dvb sed failed"
fi
- if [ "`use lcd`" ] ; then
+ if use lcd ; then
sed -e 's:#DEFINES += LCD_DEVICE:DEFINES += LCD_DEVICE:' \
-i 'settings.pro' || die "enable lcd sed failed"
fi
- if [ "`use lirc`" ] ; then
+ if use lirc ; then
sed -e 's:#CONFIG += using_lirc:CONFIG += using_lirc:' \
-e 's:#LIRC_LIBS = -llirc_client:LIRC_LIBS = -llirc_client:' \
-i 'settings.pro' || die "enable lirc sed failed"
fi
- if [ "`use nvidia`" ] ; then
+ if use nvidia ; then
sed -e 's:#CONFIG += using_xvmc:CONFIG += using_xvmc:' \
-e 's:#DEFINES += USING_XVMC:DEFINES += USING_XVMC:' \
-e 's:#EXTRA_LIBS += -lXvMCNVIDIA:EXTRA_LIBS += -lXvMCNVIDIA:' \
-i 'settings.pro' || die "enable xvmc sed failed"
fi
- if [ "`use cle266`" ] ; then
+ if use cle266 ; then
sed -e 's:#CONFIG += using_viahwslice:CONFIG += using_viahwslice:' \
-e 's:#DEFINES += USING_VIASLICE:DEFINES += USING_VIASLICE:' \
-e 's:#EXTRA_LIBS += -lddmpeg:EXTRA_LIBS += -lddmpeg:' \
diff --git a/media-tv/mythtv/mythtv-0.15.1.ebuild b/media-tv/mythtv/mythtv-0.15.1.ebuild
index 710689359085..b09164d02f08 100644
--- a/media-tv/mythtv/mythtv-0.15.1.ebuild
+++ b/media-tv/mythtv/mythtv-0.15.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.15.1.ebuild,v 1.2 2004/06/02 21:45:17 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.15.1.ebuild,v 1.3 2004/06/08 02:05:09 agriffis Exp $
inherit flag-o-matic eutils
@@ -39,7 +39,7 @@ pkg_setup() {
eerror "'mysql' to your USE flags, and re-emerge Qt."
die "Qt needs MySQL support"
fi
- if [ `use opengl` ] ; then
+ if use opengl ; then
local gl_implementation="$( opengl-update --get-implementation )"
if [ "$gl_implementation" == "xfree" ] || [ "$gl_implementation" == "xorg-x11" ] ; then
return 0
@@ -76,12 +76,12 @@ src_compile() {
fi
fi
- if [ "`use alsa`" ] ; then
+ if use alsa ; then
sed -e 's:#CONFIG += using_alsa:CONFIG += using_alsa:' \
-e 's:#ALSA_LIBS = -lasound:ALSA_LIBS = -lasound:' \
-i 'settings.pro' || die "enable alsa sed failed"
fi
- if [ "`use arts`" ] ; then
+ if use arts ; then
sed -e 's:artsc/artsc.h:artsc.h:' \
-i "libs/libmyth/audiooutputarts.h" || die "sed failed"
sed -e 's:#CONFIG += using_arts:CONFIG += using_arts:' \
@@ -90,40 +90,40 @@ src_compile() {
-e 's:#INCLUDEPATH += /opt/.*:QMAKE_CXXFLAGS += `artsc-config --cflags`:' \
-i 'settings.pro' || die "enable arts sed failed"
fi
- if [ "`use directfb`" ] ; then
+ if use directfb ; then
sed -e 's:#CONFIG += using_directfb:CONFIG += using_directfb:' \
-e 's:#EXTRA_LIBS += `directfb:EXTRA_LIBS += `directfb:' \
-e 's:#QMAKE_CXXFLAGS += `directfb:QMAKE_CXXFLAGS += `directfb:' \
-i 'settings.pro' || die "enable arts sed failed"
fi
- if [ "`use dvb`" ] ; then
+ if use dvb ; then
sed -e 's:#CONFIG += using_dvb:CONFIG += using_dvb:' \
-e 's:#DEFINES += USING_DVB:DEFINES += USING_DVB:' \
-e 's:#INCLUDEPATH += /usr/src/.*:INCLUDEPATH += /usr/include:' \
-i 'settings.pro' || die "enable dvb sed failed"
fi
- if [ "`use lcd`" ] ; then
+ if use lcd ; then
sed -e 's:#DEFINES += LCD_DEVICE:DEFINES += LCD_DEVICE:' \
-i 'settings.pro' || die "enable lcd sed failed"
fi
- if [ "`use lirc`" ] ; then
+ if use lirc ; then
sed -e 's:#CONFIG += using_lirc:CONFIG += using_lirc:' \
-e 's:#LIRC_LIBS = -llirc_client:LIRC_LIBS = -llirc_client:' \
-i 'settings.pro' || die "enable lirc sed failed"
fi
- if [ "`use nvidia`" ] ; then
+ if use nvidia ; then
sed -e 's:#CONFIG += using_xvmc:CONFIG += using_xvmc:' \
-e 's:#DEFINES += USING_XVMC:DEFINES += USING_XVMC:' \
-e 's:#EXTRA_LIBS += -lXvMCNVIDIA:EXTRA_LIBS += -lXvMCNVIDIA:' \
-i 'settings.pro' || die "enable xvmc sed failed"
fi
- if [ "`use cle266`" ] ; then
+ if use cle266 ; then
sed -e 's:#CONFIG += using_viahwslice:CONFIG += using_viahwslice:' \
-e 's:#DEFINES += USING_VIASLICE:DEFINES += USING_VIASLICE:' \
-e 's:#EXTRA_LIBS += -lddmpeg:EXTRA_LIBS += -lddmpeg:' \
-i 'settings.pro' || die "enable lirc sed failed"
fi
- if [ "`use opengl`" ] ; then
+ if use opengl ; then
sed -e 's:#DEFINES += USING_OPENGL_VSYNC:DEFINES += USING_OPENGL_VSYNC:' \
-e 's:#EXTRA_LIBS += -lGL -lGLU:EXTRA_LIBS += -lGL -lGLU:' \
-i 'settings.pro' || die "enable opgenl sed failed"
diff --git a/media-tv/xawtv/ChangeLog b/media-tv/xawtv/ChangeLog
index 0f882537d798..eea9d6985ec2 100644
--- a/media-tv/xawtv/ChangeLog
+++ b/media-tv/xawtv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-tv/xawtv
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/xawtv/ChangeLog,v 1.11 2004/06/04 15:26:29 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/xawtv/ChangeLog,v 1.12 2004/06/08 02:03:24 agriffis Exp $
+
+ 07 Jun 2004; Aron Griffis <agriffis@gentoo.org> xawtv-3.86-r1.ebuild,
+ xawtv-3.88.1.ebuild, xawtv-3.88.ebuild, xawtv-3.90-r1.ebuild,
+ xawtv-3.90.ebuild, xawtv-3.91-r1.ebuild, xawtv-3.91.ebuild:
+ Fix use invocation
*xawtv-3.91-r1 (04 Jun 2004)
diff --git a/media-tv/xawtv/xawtv-3.86-r1.ebuild b/media-tv/xawtv/xawtv-3.86-r1.ebuild
index 6972f84a3464..844b8f8b8fea 100644
--- a/media-tv/xawtv/xawtv-3.86-r1.ebuild
+++ b/media-tv/xawtv/xawtv-3.86-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/xawtv/xawtv-3.86-r1.ebuild,v 1.5 2004/01/11 13:49:58 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/xawtv/xawtv-3.86-r1.ebuild,v 1.6 2004/06/08 02:03:24 agriffis Exp $
inherit virtualx
@@ -86,7 +86,7 @@ src_install() {
dodoc ${FILESDIR}/webcamrc
fi
- if [ -z "`use nls`" ]
+ if ! use nls
then
rm -f ${D}/usr/share/man/fr
rm -f ${D}/usr/share/man/es
diff --git a/media-tv/xawtv/xawtv-3.88.1.ebuild b/media-tv/xawtv/xawtv-3.88.1.ebuild
index c98d16057218..6f8fe4a887d5 100644
--- a/media-tv/xawtv/xawtv-3.88.1.ebuild
+++ b/media-tv/xawtv/xawtv-3.88.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/xawtv/xawtv-3.88.1.ebuild,v 1.2 2004/01/11 13:49:58 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/xawtv/xawtv-3.88.1.ebuild,v 1.3 2004/06/08 02:03:24 agriffis Exp $
inherit virtualx
@@ -86,7 +86,7 @@ src_install() {
dodoc ${FILESDIR}/webcamrc
fi
- if [ -z "`use nls`" ]
+ if ! use nls
then
rm -f ${D}/usr/share/man/fr
rm -f ${D}/usr/share/man/es
diff --git a/media-tv/xawtv/xawtv-3.88.ebuild b/media-tv/xawtv/xawtv-3.88.ebuild
index ac3501a9586c..fe38bcd6d575 100644
--- a/media-tv/xawtv/xawtv-3.88.ebuild
+++ b/media-tv/xawtv/xawtv-3.88.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/xawtv/xawtv-3.88.ebuild,v 1.5 2004/01/11 13:49:58 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/xawtv/xawtv-3.88.ebuild,v 1.6 2004/06/08 02:03:24 agriffis Exp $
inherit virtualx
@@ -86,7 +86,7 @@ src_install() {
dodoc ${FILESDIR}/webcamrc
fi
- if [ -z "`use nls`" ]
+ if ! use nls
then
rm -f ${D}/usr/share/man/fr
rm -f ${D}/usr/share/man/es
diff --git a/media-tv/xawtv/xawtv-3.90-r1.ebuild b/media-tv/xawtv/xawtv-3.90-r1.ebuild
index 11207ad6e952..7a3a7607c1c0 100644
--- a/media-tv/xawtv/xawtv-3.90-r1.ebuild
+++ b/media-tv/xawtv/xawtv-3.90-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/xawtv/xawtv-3.90-r1.ebuild,v 1.5 2004/03/16 03:20:51 geoman Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/xawtv/xawtv-3.90-r1.ebuild,v 1.6 2004/06/08 02:03:24 agriffis Exp $
inherit virtualx
@@ -76,7 +76,7 @@ src_install() {
dodoc ${FILESDIR}/webcamrc
fi
- if [ -z "`use nls`" ]
+ if ! use nls
then
rm -f ${D}/usr/share/man/fr
rm -f ${D}/usr/share/man/es
diff --git a/media-tv/xawtv/xawtv-3.90.ebuild b/media-tv/xawtv/xawtv-3.90.ebuild
index 791ed3d1a168..dbe36b5d9ee3 100644
--- a/media-tv/xawtv/xawtv-3.90.ebuild
+++ b/media-tv/xawtv/xawtv-3.90.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/xawtv/xawtv-3.90.ebuild,v 1.7 2004/03/16 03:20:51 geoman Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/xawtv/xawtv-3.90.ebuild,v 1.8 2004/06/08 02:03:24 agriffis Exp $
inherit virtualx
@@ -76,7 +76,7 @@ src_install() {
dodoc ${FILESDIR}/webcamrc
fi
- if [ -z "`use nls`" ]
+ if ! use nls
then
rm -f ${D}/usr/share/man/fr
rm -f ${D}/usr/share/man/es
diff --git a/media-tv/xawtv/xawtv-3.91-r1.ebuild b/media-tv/xawtv/xawtv-3.91-r1.ebuild
index 0cacb9010d08..52e6374c3139 100644
--- a/media-tv/xawtv/xawtv-3.91-r1.ebuild
+++ b/media-tv/xawtv/xawtv-3.91-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/xawtv/xawtv-3.91-r1.ebuild,v 1.1 2004/06/04 15:26:29 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/xawtv/xawtv-3.91-r1.ebuild,v 1.2 2004/06/08 02:03:24 agriffis Exp $
inherit virtualx
@@ -76,7 +76,7 @@ src_install() {
dodoc ${FILESDIR}/webcamrc
fi
- if [ -z "`use nls`" ]
+ if ! use nls
then
rm -f ${D}/usr/share/man/fr
rm -f ${D}/usr/share/man/es
diff --git a/media-tv/xawtv/xawtv-3.91.ebuild b/media-tv/xawtv/xawtv-3.91.ebuild
index 8dfde4d1ab6e..4f046149297e 100644
--- a/media-tv/xawtv/xawtv-3.91.ebuild
+++ b/media-tv/xawtv/xawtv-3.91.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/xawtv/xawtv-3.91.ebuild,v 1.2 2004/03/16 03:20:51 geoman Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/xawtv/xawtv-3.91.ebuild,v 1.3 2004/06/08 02:03:24 agriffis Exp $
inherit virtualx
@@ -76,7 +76,7 @@ src_install() {
dodoc ${FILESDIR}/webcamrc
fi
- if [ -z "`use nls`" ]
+ if ! use nls
then
rm -f ${D}/usr/share/man/fr
rm -f ${D}/usr/share/man/es