summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2009-08-17 15:34:49 +0000
committerChristian Faulhammer <fauli@gentoo.org>2009-08-17 15:34:49 +0000
commitca4ea956f8ce67a37cd0edbcc5b529442e5334be (patch)
treea241f723f188443e45135208afdd79c893038d45 /media-tv
parentAdjust default wrapper config (diff)
downloadgentoo-2-ca4ea956f8ce67a37cd0edbcc5b529442e5334be.tar.gz
gentoo-2-ca4ea956f8ce67a37cd0edbcc5b529442e5334be.tar.bz2
gentoo-2-ca4ea956f8ce67a37cd0edbcc5b529442e5334be.zip
install man pages in the correct location, fixes bug 246660
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/nxtvepg/ChangeLog5
-rw-r--r--media-tv/nxtvepg/nxtvepg-2.8.0.ebuild10
2 files changed, 9 insertions, 6 deletions
diff --git a/media-tv/nxtvepg/ChangeLog b/media-tv/nxtvepg/ChangeLog
index 8bd867b0ae9f..02aa1b893d13 100644
--- a/media-tv/nxtvepg/ChangeLog
+++ b/media-tv/nxtvepg/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-tv/nxtvepg
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/nxtvepg/ChangeLog,v 1.20 2009/08/17 15:21:00 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/nxtvepg/ChangeLog,v 1.21 2009/08/17 15:34:49 fauli Exp $
+
+ 17 Aug 2009; Christian Faulhammer <fauli@gentoo.org> nxtvepg-2.8.0.ebuild:
+ install man pages in the correct location, fixes bug 246660
17 Aug 2009; Christian Faulhammer <fauli@gentoo.org> nxtvepg-2.8.0.ebuild:
apply patch correctly if USE=unicode is not set, fixes bug 258783
diff --git a/media-tv/nxtvepg/nxtvepg-2.8.0.ebuild b/media-tv/nxtvepg/nxtvepg-2.8.0.ebuild
index 3e4d8b7ebb15..42831ae28ac0 100644
--- a/media-tv/nxtvepg/nxtvepg-2.8.0.ebuild
+++ b/media-tv/nxtvepg/nxtvepg-2.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/nxtvepg/nxtvepg-2.8.0.ebuild,v 1.3 2009/08/17 15:21:00 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/nxtvepg/nxtvepg-2.8.0.ebuild,v 1.4 2009/08/17 15:34:49 fauli Exp $
inherit eutils toolchain-funcs
@@ -33,17 +33,17 @@ src_unpack() {
src_compile() {
if use X; then
- emake -j1 CC=$(tc-getCC) prefix="/usr" || die "emake failed"
+ emake -j1 CC=$(tc-getCC) prefix="/usr" mandir="/usr/share/man/man1"|| die "emake failed"
else
- emake -j1 CC=$(tc-getCC) prefix="/usr" daemon || die "emake failed"
+ emake -j1 CC=$(tc-getCC) prefix="/usr" mandir="/usr/share/man/man1" daemon || die "emake failed"
fi
}
src_install() {
if use X; then
- emake ROOT="${D}" prefix="/usr" install || die "emake install failed"
+ emake ROOT="${D}" prefix="/usr" mandir="${D}/usr/share/man/man1" install || die "emake install failed"
else
- emake ROOT="${D}" prefix="/usr" install-daemon || die "emake install failed"
+ emake ROOT="${D}" prefix="/usr" mandir="${D}/usr/share/man/man1" install-daemon || die "emake install failed"
fi
dodoc README CHANGES TODO
dohtml manual*.html