summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-03-25 20:37:38 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-03-25 20:37:38 +0000
commit49867ece51020c86b84156eab3631bfc11f1b56d (patch)
tree84268367020c519ae90344952da3cab3e0c754f7 /media-video/2mandvd
parentExcluding alpha patch for bug #309279 (diff)
downloadgentoo-2-49867ece51020c86b84156eab3631bfc11f1b56d.tar.gz
gentoo-2-49867ece51020c86b84156eab3631bfc11f1b56d.tar.bz2
gentoo-2-49867ece51020c86b84156eab3631bfc11f1b56d.zip
Version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-video/2mandvd')
-rw-r--r--media-video/2mandvd/2mandvd-1.3.3.ebuild73
-rw-r--r--media-video/2mandvd/ChangeLog7
2 files changed, 79 insertions, 1 deletions
diff --git a/media-video/2mandvd/2mandvd-1.3.3.ebuild b/media-video/2mandvd/2mandvd-1.3.3.ebuild
new file mode 100644
index 000000000000..6d175b76fe26
--- /dev/null
+++ b/media-video/2mandvd/2mandvd-1.3.3.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/2mandvd/2mandvd-1.3.3.ebuild,v 1.1 2010/03/25 20:37:38 hwoarang Exp $
+
+EAPI="2"
+LANGS="de en he it pl pt ru"
+
+inherit qt4-r2
+
+MY_PN="2ManDVD"
+
+DESCRIPTION="The successor of ManDVD"
+HOMEPAGE="http://kde-apps.org/content/show.php?content=99450"
+SRC_URI="http://download.tuxfamily.org/${PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="dev-lang/perl
+ media-video/dvdauthor
+ media-video/ffmpegthumbnailer
+ media-fonts/dejavu
+ media-sound/sox
+ media-video/mplayer
+ media-libs/netpbm
+ media-video/mjpegtools
+ || ( app-cdr/cdrkit app-cdr/cdrtools )
+ media-libs/xine-lib
+ x11-libs/qt-gui:4
+ x11-libs/qt-webkit:4"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_PN}"
+
+src_prepare() {
+ # fix installation path
+ for file in mainfrm.cpp media_browser.cpp rendering.cpp; do
+ sed -i "s:qApp->applicationDirPath().\?+.\?\":\"/usr/share/${PN}/:" \
+ ${file} || die "sed failed"
+ done
+
+ sed -i "s:qApp->applicationDirPath():\"/usr/share/${PN}/\":" \
+ mainfrm.cpp || die "sed failed"
+
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ eqmake4 ${MY_PN}.pro
+}
+
+src_install() {
+ dobin 2ManDVD || die "dobin failed"
+ dodoc README.txt || die "dodoc failed"
+ insinto /usr/share/${PN}/
+ doins -r Bibliotheque || die "failed to install Bibliotheque"
+ doins -r Interface || die "failed to install Interface"
+ #bug 305625
+ doins fake.pl || "failed to install fake.pl"
+ doicon Interface/mandvdico.png || die "doicon failed"
+ # Desktop icon
+ make_desktop_entry 2ManDVD 2ManDVD mandvdico "Qt;AudioVideo;Video" \
+ || die "make_desktop_entry failed"
+ insinto /usr/share/${PN}
+ for lang in ${LINGUAS}; do
+ for x in ${LANGS}; do
+ [[ ${lang} == ${x} ]] && doins ${PN}_${x}.qm
+ done
+ done
+ [[ -z ${LINGUAS} ]] && doins ${PN}_en.qm
+}
diff --git a/media-video/2mandvd/ChangeLog b/media-video/2mandvd/ChangeLog
index 527f9dda4ca9..48973f4541da 100644
--- a/media-video/2mandvd/ChangeLog
+++ b/media-video/2mandvd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/2mandvd
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/2mandvd/ChangeLog,v 1.6 2010/03/13 14:43:04 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/2mandvd/ChangeLog,v 1.7 2010/03/25 20:37:38 hwoarang Exp $
+
+*2mandvd-1.3.3 (25 Mar 2010)
+
+ 25 Mar 2010; Markos Chandras <hwoarang@gentoo.org> +2mandvd-1.3.3.ebuild:
+ Version bump
*2mandvd-1.3.2 (13 Mar 2010)
*2mandvd-1.3.1-r1 (13 Mar 2010)