summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2004-10-05 13:39:16 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2004-10-05 13:39:16 +0000
commitf9d7e266fc4844e6c830d3693b93ebadef2705a7 (patch)
tree9dedba2cd5079eaf398762ea633c84027b1ed9e1 /media-video/avifile
parentPPC Keyword modification, see changelog for details (Manifest recommit) (diff)
downloadgentoo-2-f9d7e266fc4844e6c830d3693b93ebadef2705a7.tar.gz
gentoo-2-f9d7e266fc4844e6c830d3693b93ebadef2705a7.tar.bz2
gentoo-2-f9d7e266fc4844e6c830d3693b93ebadef2705a7.zip
new version
Diffstat (limited to 'media-video/avifile')
-rw-r--r--media-video/avifile/ChangeLog8
-rw-r--r--media-video/avifile/Manifest2
-rw-r--r--media-video/avifile/avifile-0.7.41.20041001.ebuild138
-rw-r--r--media-video/avifile/files/digest-avifile-0.7.41.200410011
4 files changed, 148 insertions, 1 deletions
diff --git a/media-video/avifile/ChangeLog b/media-video/avifile/ChangeLog
index c4dd5100df67..a4889047b6ec 100644
--- a/media-video/avifile/ChangeLog
+++ b/media-video/avifile/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/avifile
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/avifile/ChangeLog,v 1.71 2004/07/12 05:06:44 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/avifile/ChangeLog,v 1.72 2004/10/05 13:39:16 phosphan Exp $
+
+*avifile-0.7.41.20041001 (05 Oct 2004)
+
+ 05 Oct 2004; Patrick Kursawe <phosphan@gentoo.org>
+ +avifile-0.7.41.20041001.ebuild:
+ New version that works with xvid 1.x and does not unset compiler flags.
*avifile-0.7.38.20030710-r1 (12 Jul 2004)
diff --git a/media-video/avifile/Manifest b/media-video/avifile/Manifest
index 3c5dd565ea18..7be057500ae8 100644
--- a/media-video/avifile/Manifest
+++ b/media-video/avifile/Manifest
@@ -1,6 +1,7 @@
MD5 6d85afc659f23bb2adcebd144400833d avifile-0.7.38.20030710.ebuild 4488
MD5 b80546f1e5f52f38abec15e91478e999 avifile-0.7.38.20030710-r1.ebuild 4008
MD5 ab24ec7446ec73e983a093e98b7f99df avifile-0.7.32.20030219.ebuild 4062
+MD5 57531db1c55dc5ae9c8306ed264dd61d avifile-0.7.41.20041001.ebuild 4012
MD5 70ca25105945695ff9691aad5f5577a1 ChangeLog 12468
MD5 76b95bd390c69f39e5e7b028b3ff69a5 metadata.xml 272
MD5 f003a1fc700f9a79cf12c06d2ac3bedd avifile-0.7.37.20030522-r2.ebuild 4432
@@ -13,5 +14,6 @@ MD5 21e60c1838b04fa1990fe5538569ac4b files/digest-avifile-0.7.38.20030710-r1 71
MD5 5c7a3ea4957036aa1da3db9880a3ed34 files/flvenc-patch 558
MD5 f2e5938361909893d37d1ce0b80fdbfc files/avifile-x86-gcc34.patch 5247
MD5 769b5c63369a3c1bc5b74abe591731fd files/avifile-0.7.38.20030710-sparc.patch 998
+MD5 f19f862b147fa314ed83d4b78e661a5d files/digest-avifile-0.7.41.20041001 71
MD5 21e60c1838b04fa1990fe5538569ac4b files/digest-avifile-0.7.38.20030710 71
MD5 69d7c84947a5ea083f25e43fdacc126e files/avifile-gcc34.patch 5795
diff --git a/media-video/avifile/avifile-0.7.41.20041001.ebuild b/media-video/avifile/avifile-0.7.41.20041001.ebuild
new file mode 100644
index 000000000000..454a6c2a037f
--- /dev/null
+++ b/media-video/avifile/avifile-0.7.41.20041001.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/avifile/avifile-0.7.41.20041001.ebuild,v 1.1 2004/10/05 13:39:16 phosphan Exp $
+
+inherit eutils
+
+MAJ_PV=${PV:0:3}
+MIN_PV=${PV:0:6}
+MY_P="${PN}-${MAJ_PV}-${MIN_PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Library for AVI-Files"
+HOMEPAGE="http://avifile.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0.7"
+KEYWORDS="~x86 ~alpha ~ia64"
+IUSE="3dnow X alsa avi debug dvd esd mmx oggvorbis qt sdl sse static truetype xv zlib"
+
+DEPEND=">=media-libs/jpeg-6b
+ x86? ( >=media-libs/divx4linux-20030428
+ >=media-libs/win32codecs-0.90 )
+ >=media-video/ffmpeg-0.4
+ =media-libs/xvid-1*
+ >=media-sound/lame-3.90
+ >=media-libs/audiofile-0.2.3
+ >=sys-apps/sed-4
+ >=media-sound/madplay-0.14.2b
+ >=sys-devel/patch-2.5.9
+ truetype? ( >=media-libs/freetype-2.1 )
+ xv? ( virtual/x11 )
+ sdl? ( >=media-libs/libsdl-1.2.2 )
+ dvd? ( >=media-libs/a52dec-0.7 )
+ zlib? ( >=sys-libs/zlib-1.1.3 )
+ oggvorbis? ( >=media-libs/libvorbis-1.0 )
+ X? ( virtual/x11 virtual/xft )
+ qt? ( >=x11-libs/qt-3.0.3 )
+ alsa? ( >=media-libs/alsa-lib-0.9.0_rc2 )
+ esd? ( >=media-sound/esound-0.2.28 )"
+
+src_unpack() {
+ unpack ${A}
+ use qt || sed -i 's/qt[a-z]*//g' ${S}/samples/Makefile.am
+
+ # make sure pkgconfig file is correct #53183
+ cd ${S}
+ rm -f avifile.pc
+ sed -i "/^includedir=/s:avifile$:avifile-${PV:0:3}:" avifile.pc.in
+}
+
+src_compile() {
+ local myconf="--enable-oss --disable-xvid --enable-xvid4"
+ local kdepre=""
+
+ if [ "$XINERAMA" = "NO" ]; then
+ myconf="${myconf} --disable-xinerama"
+ fi
+
+ if [ "$DPMS" = "NO" ]; then
+ myconf="${myconf} --disable-dpms"
+ fi
+
+ if [ "$V4L" = "NO" ]; then
+ myconf="${myconf} --disable-v4l"
+ fi
+
+ if [ "$SUN" = "NO" ]; then
+ myconf="${myconf} --disable-sunaudio"
+ fi
+
+ if [ "$SBLIVE" = "NO" ]; then
+ myconf="${myconf} --disable-ac3passthrough"
+ fi
+
+ use debug \
+ && myconf="${myconf} --enable-loader-out" \
+ || myconf="${myconf} --enable-quiet"
+
+ ( use mmx || use sse || use 3dnow ) && myconf="${myconf} --enable-x86opt"
+
+ if [ "$MGA" = "NO" ]; then
+ myconf="${myconf} --disable-mga"
+ fi
+
+ if [ "$DMALLOC" = "YES" ]; then
+ myconf="${myconf} --with-dmallocth"
+ fi
+
+ use qt \
+ && myconf="${myconf} --with-qt-prefix=${QTDIR}" \
+ || myconf="${myconf} --without-qt"
+
+ # Make sure we include freetype2 headers before freetype1 headers, else Xft2
+ # borks, bug #11941.
+ export C_INCLUDE_PATH="${C_INCLUDE_PATH}:/usr/include/freetype2"
+ export CPLUS_INCLUDE_PATH="${CPLUS_INCLUDE_PATH}:/usr/include/freetype2"
+
+ # Fix qt detection
+ sed -i \
+ -e "s:extern \"C\" void exit(int);:/* extern \"C\" void exit(int); */:" \
+ configure
+
+ econf \
+ `use_enable static` \
+ `use_enable truetype freetype2` \
+ `use_enable xv` \
+ `use_enable sdl` `use_enable sdl sdltest` \
+ `use_enable dvd a52` `use_enable dvd ffmpeg-a52` \
+ `use_enable zlib libz` \
+ `use_enable oggvorbis vorbis` `use_enable oggvorbis oggtest` `use_enable oggvorbis vorbistest` \
+ `use_with X x` `use_enable X xft` \
+ --enable-samples \
+ --disable-vidix \
+ --with-fpic \
+ --enable-lame-bin \
+ ${myconf} \
+ || die
+ emake || die
+}
+
+src_install() {
+ dodir /usr/lib /usr/bin
+ use avi && dodir /usr/lib/win32
+
+ make install DESTDIR=${D} || die
+
+ dodoc README INSTALL
+ cd doc
+ dodoc CREDITS EXCEPTIONS TODO VIDEO-PERFORMANCE WARNINGS KNOWN_BUGS
+}
+
+pkg_postinst() {
+ einfo "In order to use certain video modes, you must be root"
+ einfo "chmod +s /usr/bin/aviplay to suid root"
+ einfo "As this is considered a security risk on multiuser"
+ einfo "systems, this is not done by default"
+}
diff --git a/media-video/avifile/files/digest-avifile-0.7.41.20041001 b/media-video/avifile/files/digest-avifile-0.7.41.20041001
new file mode 100644
index 000000000000..019a69ee1a1c
--- /dev/null
+++ b/media-video/avifile/files/digest-avifile-0.7.41.20041001
@@ -0,0 +1 @@
+MD5 a08911965d81a02ded95ddb95f63e1cf avifile-0.7-0.7.41.tar.gz 3498203