summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-07-01 08:41:18 +0000
committerAlexis Ballier <aballier@gentoo.org>2015-07-01 08:41:18 +0000
commit174890bbc36c936ffcfed629fc85b6ed05ae1d15 (patch)
tree4d34af1043c9b20e0da0172fc788826731135d5d /media-video/dvdstyler
parentx86 stable wrt bug #553500 (diff)
downloadgentoo-2-174890bbc36c936ffcfed629fc85b6ed05ae1d15.tar.gz
gentoo-2-174890bbc36c936ffcfed629fc85b6ed05ae1d15.tar.bz2
gentoo-2-174890bbc36c936ffcfed629fc85b6ed05ae1d15.zip
version bump
Signed-off-by: Alexis Ballier <aballier@gentoo.org> (Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-video/dvdstyler')
-rw-r--r--media-video/dvdstyler/ChangeLog9
-rw-r--r--media-video/dvdstyler/dvdstyler-2.9.2.ebuild66
2 files changed, 73 insertions, 2 deletions
diff --git a/media-video/dvdstyler/ChangeLog b/media-video/dvdstyler/ChangeLog
index 6e012d832925..1dbef8414d4f 100644
--- a/media-video/dvdstyler/ChangeLog
+++ b/media-video/dvdstyler/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/dvdstyler
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/dvdstyler/ChangeLog,v 1.62 2014/10/24 04:26:45 ssuominen Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/dvdstyler/ChangeLog,v 1.63 2015/07/01 08:41:18 aballier Exp $
+
+*dvdstyler-2.9.2 (01 Jul 2015)
+
+ 01 Jul 2015; Alexis Ballier <aballier@gentoo.org> +dvdstyler-2.9.2.ebuild:
+ version bump
24 Oct 2014; Samuli Suominen <ssuominen@gentoo.org> dvdstyler-2.7.2.ebuild:
Missing media-video/mjpegtools RDEPEND used for mplexing during authoring.
diff --git a/media-video/dvdstyler/dvdstyler-2.9.2.ebuild b/media-video/dvdstyler/dvdstyler-2.9.2.ebuild
new file mode 100644
index 000000000000..5acd40283937
--- /dev/null
+++ b/media-video/dvdstyler/dvdstyler-2.9.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/dvdstyler/dvdstyler-2.9.2.ebuild,v 1.1 2015/07/01 08:41:18 aballier Exp $
+
+EAPI=5
+
+MY_P=${P/dvds/DVDS}
+WX_GTK_VER=2.8
+
+inherit wxwidgets
+
+DESCRIPTION="A cross-platform free DVD authoring application"
+HOMEPAGE="http://www.dvdstyler.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +udev"
+
+COMMON_DEPEND=">=app-cdr/dvd+rw-tools-7.1
+ media-libs/libexif:=
+ >=media-libs/wxsvg-1.2:=
+ >=media-video/dvdauthor-0.7.1
+ >=media-video/xine-ui-0.99.7
+ virtual/cdrtools
+ >=virtual/ffmpeg-9-r1[encode]
+ virtual/jpeg:0
+ >=x11-libs/wxGTK-2.8.7:2.8=[gstreamer,X]
+ udev? ( >=virtual/libudev-215:= )"
+RDEPEND="${COMMON_DEPEND}
+ >=app-cdr/dvdisaster-0.72.4
+ media-video/mjpegtools"
+DEPEND="${COMMON_DEPEND}
+ app-arch/zip
+ app-text/xmlto
+ sys-devel/gettext
+ virtual/yacc
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ # disable obsolete GNOME 2.x libraries wrt #508854
+ sed -i -e '/PKG_CONFIG/s:libgnomeui-2.0:dIsAbLeAuToMaGiC&:' configure || die
+ # rmdir: failed to remove `tempfoobar': Directory not empty
+ sed -i -e '/rmdir "$$t"/d' docs/Makefile.in || die
+ # fix underlinking wrt #367863
+ sed -i -e 's:@LIBS@:& -ljpeg:' wxVillaLib/Makefile.in || die
+ # silence desktop-file-validate QA check
+ sed -i \
+ -e '/Icon/s:.png::' -e '/^Encoding/d' -e '/Categories/s:Application;::' \
+ data/dvdstyler.desktop || die
+}
+
+src_configure() {
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable debug) \
+ --with-wx-config=${WX_CONFIG}
+}
+
+src_install() {
+ default
+ rm -f "${ED}"/usr/share/doc/${PF}/{COPYING*,INSTALL*}
+}