summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2005-12-29 01:23:41 +0000
committerMark Loeser <halcy0n@gentoo.org>2005-12-29 01:23:41 +0000
commitcdc1a94caaea9a8a722ee753bf439142418897e9 (patch)
treeaa1e3b3143a2594037ec503a2d36be1840d12ca9 /media-video/dvdstyler
parentsh love (diff)
downloadgentoo-2-cdc1a94caaea9a8a722ee753bf439142418897e9.tar.gz
gentoo-2-cdc1a94caaea9a8a722ee753bf439142418897e9.tar.bz2
gentoo-2-cdc1a94caaea9a8a722ee753bf439142418897e9.zip
Fix compilation with gcc-4.0; bug #113927
(Portage version: 2.1_pre2)
Diffstat (limited to 'media-video/dvdstyler')
-rw-r--r--media-video/dvdstyler/ChangeLog6
-rw-r--r--media-video/dvdstyler/Manifest3
-rw-r--r--media-video/dvdstyler/dvdstyler-1.4.ebuild8
-rw-r--r--media-video/dvdstyler/files/dvdstyler-1.4-gcc4.patch41
4 files changed, 55 insertions, 3 deletions
diff --git a/media-video/dvdstyler/ChangeLog b/media-video/dvdstyler/ChangeLog
index 5f9f088c626f..6ea7ad9c1782 100644
--- a/media-video/dvdstyler/ChangeLog
+++ b/media-video/dvdstyler/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/dvdstyler
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/dvdstyler/ChangeLog,v 1.20 2005/12/15 04:31:14 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/dvdstyler/ChangeLog,v 1.21 2005/12/29 01:23:41 halcy0n Exp $
+
+ 29 Dec 2005; Mark Loeser <halcy0n@gentoo.org>
+ +files/dvdstyler-1.4-gcc4.patch, dvdstyler-1.4.ebuild:
+ Fix compilation with gcc-4.0; bug #113927
15 Dec 2005; Donnie Berkholz <spyderous@gentoo.org>; dvdstyler-1.4.ebuild:
Port to modular X. Remove virtual/x11, it comes in from gtk+.
diff --git a/media-video/dvdstyler/Manifest b/media-video/dvdstyler/Manifest
index 71aa176545c1..08bfd5c68089 100644
--- a/media-video/dvdstyler/Manifest
+++ b/media-video/dvdstyler/Manifest
@@ -1,4 +1,5 @@
MD5 ee4bc19f3f1e6c52ed473e98754dee5f ChangeLog 3889
-MD5 0e28de3d50878ccdba77e6e7ca8b70c3 dvdstyler-1.4.ebuild 1133
+MD5 f08954ea1cf2c0393034c5cea1874110 dvdstyler-1.4.ebuild 1202
MD5 0a61283275c4c6e267cc98a00f00f8cc files/digest-dvdstyler-1.4 65
+MD5 79431e1c10a19f2b62b4725c81e3dcce files/dvdstyler-1.4-gcc4.patch 1439
MD5 59aae5dcb06a68bd02cec60c627dbe53 metadata.xml 253
diff --git a/media-video/dvdstyler/dvdstyler-1.4.ebuild b/media-video/dvdstyler/dvdstyler-1.4.ebuild
index 4d251da28047..619dc67143f1 100644
--- a/media-video/dvdstyler/dvdstyler-1.4.ebuild
+++ b/media-video/dvdstyler/dvdstyler-1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/dvdstyler/dvdstyler-1.4.ebuild,v 1.3 2005/12/15 04:31:14 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/dvdstyler/dvdstyler-1.4.ebuild,v 1.4 2005/12/29 01:23:41 halcy0n Exp $
inherit eutils
@@ -36,6 +36,12 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}
+src_unpack()
+{
+ unpack ${A}
+ epatch "${FILESDIR}"/${P}-gcc4.patch
+}
+
src_install() {
make DESTDIR=${D} install || die "failed to install"
rm ${D}usr/share/doc/${PN}/COPYING ${D}usr/share/doc/${PN}/INSTALL
diff --git a/media-video/dvdstyler/files/dvdstyler-1.4-gcc4.patch b/media-video/dvdstyler/files/dvdstyler-1.4-gcc4.patch
new file mode 100644
index 000000000000..c884361220d8
--- /dev/null
+++ b/media-video/dvdstyler/files/dvdstyler-1.4-gcc4.patch
@@ -0,0 +1,41 @@
+diff -Naur DVDStyler-1.4.org/src/ButtonPropDlg.cpp DVDStyler-1.4/src/ButtonPropDlg.cpp
+--- DVDStyler-1.4.org/src/ButtonPropDlg.cpp 2005-05-17 13:41:34.000000000 +0200
++++ DVDStyler-1.4/src/ButtonPropDlg.cpp 2005-06-06 18:25:29.000000000 +0200
+@@ -7,6 +7,8 @@
+ // Copyright: (c) Alex Thuering
+ // Licence: GPL
+ /////////////////////////////////////////////////////////////////////////////
++
++#include <stdint.h>
+
+ #include "ButtonPropDlg.h"
+ #include <wx/statline.h>
+@@ -115,14 +117,14 @@
+ int ButtonPropDlg::GetTsi()
+ {
+ if (m_titlesetChoice->GetSelection() >= 0)
+- return ((int) m_titlesetChoice->GetClientData(m_titlesetChoice->GetSelection()))-1;
++ return ((intptr_t) m_titlesetChoice->GetClientData(m_titlesetChoice->GetSelection()))-1;
+ return 0;
+ }
+
+ int ButtonPropDlg::GetPgci()
+ {
+ if (m_targetChoice->GetSelection() >= 0)
+- return (int) m_targetChoice->GetClientData(m_targetChoice->GetSelection());
++ return (intptr_t) m_targetChoice->GetClientData(m_targetChoice->GetSelection());
+ return 0;
+ }
+
+@@ -296,9 +298,9 @@
+ return false;
+ }
+ int n = 1;
+- int tsi = ((int)GetClientData(n++))-1;
++ int tsi = ((intptr_t)GetClientData(n++))-1;
+ m_object->SetActionTsi(tsi != m_tsi ? tsi : -2);
+- m_object->SetActionPgci((int)GetClientData(n++));
++ m_object->SetActionPgci((intptr_t)GetClientData(n++));
+ m_object->SetActionChapter(GetInt(n++));
+ if (GetBool(n++))
+ m_object->SetCustomAction(GetString(n));