summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Stelling <blubb@gentoo.org>2007-02-16 11:57:24 +0000
committerSimon Stelling <blubb@gentoo.org>2007-02-16 11:57:24 +0000
commit9213244122e58f18933157406d9d7906078c8b13 (patch)
tree793cba18d29b4e77cc719659d7026c5fe871447d /media-video/ffmpeg/ffmpeg-0.4.9_p20061016.ebuild
parentStable on ppc64; bug #167020 (diff)
downloadgentoo-2-9213244122e58f18933157406d9d7906078c8b13.tar.gz
gentoo-2-9213244122e58f18933157406d9d7906078c8b13.tar.bz2
gentoo-2-9213244122e58f18933157406d9d7906078c8b13.zip
depend on >=portage-2.1.2 on amd64 to make sure the mmx USE flag is unmasked
(Portage version: 2.1.2-r9)
Diffstat (limited to 'media-video/ffmpeg/ffmpeg-0.4.9_p20061016.ebuild')
-rw-r--r--media-video/ffmpeg/ffmpeg-0.4.9_p20061016.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/media-video/ffmpeg/ffmpeg-0.4.9_p20061016.ebuild b/media-video/ffmpeg/ffmpeg-0.4.9_p20061016.ebuild
index 3cb56e5ca2a6..34792c4276a8 100644
--- a/media-video/ffmpeg/ffmpeg-0.4.9_p20061016.ebuild
+++ b/media-video/ffmpeg/ffmpeg-0.4.9_p20061016.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-0.4.9_p20061016.ebuild,v 1.12 2007/02/12 11:19:58 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-0.4.9_p20061016.ebuild,v 1.13 2007/02/16 11:57:24 blubb Exp $
inherit eutils flag-o-matic multilib toolchain-funcs
@@ -38,6 +38,9 @@ DEPEND="${RDEPEND}
doc? ( app-text/texi2html )
test? ( net-misc/wget )
amr? ( app-arch/unzip )"
+# Make sure the mmx USE flag is unmasked
+# Remove this once default-linux/amd64/2006.1 is deprecated
+DEPEND="${DEPEND} amd64? ( >=sys-apps/portage-2.1.2 )"
src_unpack() {
unpack ${A} || die
@@ -93,7 +96,7 @@ src_compile() {
#disable mmx accelerated code if not requested, or if PIC is required
# as the provided asm decidedly is not PIC.
- if ( gcc-specs-pie || ! use mmx ) && ( ! use amd64 ); then
+ if ( gcc-specs-pie || ! use mmx ) ; then
myconf="${myconf} --disable-mmx"
fi