summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-08-02 13:07:26 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-08-02 13:07:26 +0000
commitf7b3823579f2553bf8fbd3b6d2cb5be430856be0 (patch)
treea01bce955036f1abc5b4e3e39170d5f32e0630f9 /media-video/ffmpeg/ffmpeg-9999.ebuild
parentUse system media-sound/cdparanoia instead of internal copy wrt #206939 by Die... (diff)
downloadgentoo-2-f7b3823579f2553bf8fbd3b6d2cb5be430856be0.tar.gz
gentoo-2-f7b3823579f2553bf8fbd3b6d2cb5be430856be0.tar.bz2
gentoo-2-f7b3823579f2553bf8fbd3b6d2cb5be430856be0.zip
add flite useflag
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'media-video/ffmpeg/ffmpeg-9999.ebuild')
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index 37a3087e11fb..91038b9183e7 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.100 2012/07/23 22:44:14 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.101 2012/08/02 13:07:26 aballier Exp $
EAPI="4"
@@ -30,7 +30,7 @@ if [ "${PV#9999}" = "${PV}" ] ; then
fi
IUSE="
aac aacplus alsa amr avresample bindist bluray +bzip2 cdio celt
- cpudetection debug doc +encode faac fontconfig frei0r gnutls gsm
+ cpudetection debug doc +encode faac flite fontconfig frei0r gnutls gsm
+hardcoded-tables iec61883 ieee1394 jack jpeg2k libass libcaca libv4l
modplug mp3 network openal openssl opus oss pic pulseaudio rtmp schroedinger
sdl speex static-libs test theora threads truetype v4l vaapi vdpau vorbis
@@ -68,6 +68,7 @@ RDEPEND="
x264? ( >=media-libs/x264-0.0.20111017 )
xvid? ( >=media-libs/xvid-1.1.0 )
)
+ flite? ( app-accessibility/flite )
fontconfig? ( media-libs/fontconfig )
frei0r? ( media-plugins/frei0r-plugins )
gnutls? ( >=net-libs/gnutls-2.12.16 )
@@ -185,6 +186,7 @@ src_configure() {
use ${i} && myconf="${myconf} --enable-${i}"
done
use truetype && myconf="${myconf} --enable-libfreetype"
+ use flite && myconf="${myconf} --enable-libflite"
# Threads; we only support pthread for now but ffmpeg supports more
use threads && myconf="${myconf} --enable-pthreads"