summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-03-21 15:10:10 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-03-21 15:10:10 +0000
commit633ac6595bee7ea52db6b997e1499142b54e12f2 (patch)
tree1ad5febd6a28e4af6ad66a3bc2d636668db0d373 /media-video/ffmpeg
parentgst dep fixes (diff)
downloadgentoo-2-633ac6595bee7ea52db6b997e1499142b54e12f2.tar.gz
gentoo-2-633ac6595bee7ea52db6b997e1499142b54e12f2.tar.bz2
gentoo-2-633ac6595bee7ea52db6b997e1499142b54e12f2.zip
Use --cc option instead of overwriting CC variable to respect the compiler, pass --extra-ldflags to respect LDFLAGS (only 20060302 respect them entirely). Add patch to allow using --as-needed flag.
(Portage version: 2.1_pre6-r5)
Diffstat (limited to 'media-video/ffmpeg')
-rw-r--r--media-video/ffmpeg/ChangeLog9
-rw-r--r--media-video/ffmpeg/ffmpeg-0.4.9_p20051216.ebuild16
-rw-r--r--media-video/ffmpeg/ffmpeg-0.4.9_p20060302.ebuild11
-rw-r--r--media-video/ffmpeg/files/ffmpeg-0.4.9_p20051216-asneeded-configure.patch13
4 files changed, 40 insertions, 9 deletions
diff --git a/media-video/ffmpeg/ChangeLog b/media-video/ffmpeg/ChangeLog
index 318ef1bff6ff..dc54474974a4 100644
--- a/media-video/ffmpeg/ChangeLog
+++ b/media-video/ffmpeg/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-video/ffmpeg
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.131 2006/03/08 23:55:31 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.132 2006/03/21 15:10:10 flameeyes Exp $
+
+ 21 Mar 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/ffmpeg-0.4.9_p20051216-asneeded-configure.patch,
+ ffmpeg-0.4.9_p20051216.ebuild, ffmpeg-0.4.9_p20060302.ebuild:
+ Use --cc option instead of overwriting CC variable to respect the compiler,
+ pass --extra-ldflags to respect LDFLAGS (only 20060302 respect them
+ entirely). Add patch to allow using --as-needed flag.
08 Mar 2006; Diego Pettenò <flameeyes@gentoo.org>
ffmpeg-0.4.9_p20051216.ebuild, ffmpeg-0.4.9_p20060302.ebuild:
diff --git a/media-video/ffmpeg/ffmpeg-0.4.9_p20051216.ebuild b/media-video/ffmpeg/ffmpeg-0.4.9_p20051216.ebuild
index 525d7ef2694b..5f1e65250438 100644
--- a/media-video/ffmpeg/ffmpeg-0.4.9_p20051216.ebuild
+++ b/media-video/ffmpeg/ffmpeg-0.4.9_p20051216.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-0.4.9_p20051216.ebuild,v 1.20 2006/03/08 23:55:31 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-0.4.9_p20051216.ebuild,v 1.21 2006/03/21 15:10:10 flameeyes Exp $
inherit eutils flag-o-matic multilib toolchain-funcs
@@ -51,6 +51,7 @@ src_unpack() {
epatch ${FILESDIR}/ffmpeg-unknown-options.patch
epatch ${FILESDIR}/ffmpeg-soname-symlink.patch
+ epatch "${FILESDIR}/${P}-asneeded-configure.patch"
# ffmpeg doesn'g use libtool, so the condition for PIC code
# is __PIC__, not PIC.
@@ -111,14 +112,17 @@ src_compile() {
$(use_enable zlib) \
$(use_enable sdl ffplay) \
$(use_enable aac faad) $(use_enable aac faac) --disable-faadbin \
+ --cc=$(tc-getCC) \
--enable-gpl \
--enable-pp \
--disable-opts \
--disable-strip"
cd ${S_STATIC}
- econf --disable-shared-pp --disable-shared --enable-static ${myconf} || die "Configure failed"
- emake CC="$(tc-getCC)" || die "static failed"
+ econf --disable-shared-pp --disable-shared --enable-static \
+ "--extra-ldflags=${LDFLAGS}" \
+ ${myconf} || die "Configure failed"
+ emake || die "static failed"
# Specific workarounds for too-few-registers arch...
if [[ $(tc-arch) == "x86" ]]; then
@@ -133,8 +137,10 @@ src_compile() {
fi
cd ${S_SHARED}
- econf --enable-shared-pp --enable-shared --disable-static ${myconf} || die "Configure failed"
- emake CC="$(tc-getCC)" || die "shared failed"
+ econf --enable-shared-pp --enable-shared --disable-static \
+ "--extra-ldflags=${LDFLAGS}" \
+ ${myconf} || die "Configure failed"
+ emake || die "shared failed"
}
src_install() {
diff --git a/media-video/ffmpeg/ffmpeg-0.4.9_p20060302.ebuild b/media-video/ffmpeg/ffmpeg-0.4.9_p20060302.ebuild
index 77deb18f21c1..9821a0ad9387 100644
--- a/media-video/ffmpeg/ffmpeg-0.4.9_p20060302.ebuild
+++ b/media-video/ffmpeg/ffmpeg-0.4.9_p20060302.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-0.4.9_p20060302.ebuild,v 1.8 2006/03/08 23:55:31 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-0.4.9_p20060302.ebuild,v 1.9 2006/03/21 15:10:10 flameeyes Exp $
inherit eutils flag-o-matic multilib toolchain-funcs
@@ -72,6 +72,7 @@ src_unpack() {
sed -i s:\#define\ HAVE_X11:\#define\ HAVE_LINUX: ffplay.c
epatch ${FILESDIR}/ffmpeg-unknown-options.patch
+ epatch "${FILESDIR}/${PN}-0.4.9_p20051216-asneeded-configure.patch"
# ffmpeg doesn'g use libtool, so the condition for PIC code
# is __PIC__, not PIC.
@@ -144,10 +145,12 @@ src_compile() {
--prefix=/usr \
--mandir=/usr/share/man \
--enable-static --disable-shared \
+ "--cc=$(tc-getCC)" \
+ "--extra-ldflags=${LDFLAGS}" \
${myconf} || die "static failed"
- emake CC="$(tc-getCC)" || die "static failed"
+ emake || die "static failed"
# Specific workarounds for too-few-registers arch...
if [[ $(tc-arch) == "x86" ]]; then
@@ -170,9 +173,11 @@ src_compile() {
--prefix=/usr \
--mandir=/usr/share/man \
--disable-static --enable-shared \
+ "--cc=$(tc-getCC)" \
+ "--extra-ldflags=${LDFLAGS}" \
${myconf} || die "shared failed"
- emake CC="$(tc-getCC)" || die "shared failed"
+ emake || die "shared failed"
}
src_install() {
diff --git a/media-video/ffmpeg/files/ffmpeg-0.4.9_p20051216-asneeded-configure.patch b/media-video/ffmpeg/files/ffmpeg-0.4.9_p20051216-asneeded-configure.patch
new file mode 100644
index 000000000000..ba733bc4f17d
--- /dev/null
+++ b/media-video/ffmpeg/files/ffmpeg-0.4.9_p20051216-asneeded-configure.patch
@@ -0,0 +1,13 @@
+Index: ffmpeg-0.4.9-p20051216/configure
+===================================================================
+--- ffmpeg-0.4.9-p20051216.orig/configure
++++ ffmpeg-0.4.9-p20051216/configure
+@@ -987,7 +987,7 @@ int main( void ) { return (lrintf(3.999f
+ EOF
+
+ have_lrintf="no"
+-if $cc $CFLAGS $LDFLAGS $extralibs -o $TMPE $TMPC 2> /dev/null ; then
++if $cc $CFLAGS $LDFLAGS -o $TMPE $TMPC $extralibs 2> /dev/null ; then
+ have_lrintf="yes"
+ # allanc@chickenandporn.com: cannot execute cross-compiled
+ # code on the host. Only execute if not cross-compiling.