summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-12-01 17:31:27 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-12-01 17:31:27 +0000
commitb76d957a1ba4ee74ca0d49f121a8f42e56481d64 (patch)
tree5b1e1e6c9cc42d3f12e2e1073942855471557fbd /media-video/griffith/griffith-0.10-r1.ebuild
parentRevbump for minor ommision in bash-completion.sh file which didn't clean up t... (diff)
downloadgentoo-2-b76d957a1ba4ee74ca0d49f121a8f42e56481d64.tar.gz
gentoo-2-b76d957a1ba4ee74ca0d49f121a8f42e56481d64.tar.bz2
gentoo-2-b76d957a1ba4ee74ca0d49f121a8f42e56481d64.zip
Depend to libglade instead of glade ( bug #295291 ). Drop old ebuilds
(Portage version: 2.2_rc54/cvs/Linux x86_64)
Diffstat (limited to 'media-video/griffith/griffith-0.10-r1.ebuild')
-rw-r--r--media-video/griffith/griffith-0.10-r1.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/media-video/griffith/griffith-0.10-r1.ebuild b/media-video/griffith/griffith-0.10-r1.ebuild
new file mode 100644
index 000000000000..8d93623dc1c6
--- /dev/null
+++ b/media-video/griffith/griffith-0.10-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/griffith/griffith-0.10-r1.ebuild,v 1.1 2009/12/01 17:31:27 hwoarang Exp $
+
+EAPI="2"
+
+inherit eutils versionator python multilib
+
+ARTWORK_PV="0.9.4"
+
+DESCRIPTION="Movie collection manager"
+HOMEPAGE="http://griffith.berlios.de/"
+SRC_URI="mirror://berlios/griffith/${P/_/-}.tar.gz
+ mirror://berlios/griffith/${PN}-extra-artwork-${ARTWORK_PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="csv doc spell"
+
+RDEPEND="dev-python/imaging
+ gnome-base/libglade
+ dev-python/pyxml
+ >=dev-python/pygtk-2.6.1
+ dev-python/pysqlite:2
+ >=dev-python/sqlalchemy-0.5.2
+ >=dev-python/reportlab-1.19
+ csv? ( dev-python/chardet )
+ spell? ( >=dev-python/gnome-python-extras-2.0 )"
+DEPEND="${RDEPEND}
+ doc? ( app-text/docbook2X )"
+
+S="${WORKDIR}"/"${P/_/-}"
+src_prepare() {
+ sed -i \
+ -e 's#/pl/#/pl.UTF-8/#' \
+ "${S}"/docs/pl/Makefile || die "sed failed"
+
+ sed -i \
+ -e 's/ISO-8859-1/UTF-8/' \
+ "${S}"/lib/gconsole.py || die "sed failed"
+ epatch "${FILESDIR}/$(get_version_component_range 1-2)-fix_lib_path.patch"
+}
+
+src_compile() {
+ # Nothing to compile and default `emake` spews an error message
+ true
+}
+
+src_install() {
+ use doc || sed -i -e '/docs/d' Makefile
+
+ python_version
+ emake \
+ LIBDIR="${D}/usr/$(get_libdir)/griffith" \
+ DESTDIR="${D}" DOC2MAN=docbook2man.pl install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README THANKS TODO NEWS TRANSLATORS
+
+ cd "${WORKDIR}/${PN}-extra-artwork-${ARTWORK_PV}/"
+ emake DESTDIR="${D}" install || die "emake install artwork failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/$(get_libdir)/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/${PN}
+}