summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-05-02 00:13:32 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-05-02 00:13:32 +0000
commita6a8817dc9a9fb90ff70826f26a937affb8f358a (patch)
tree05b40ffd72708e0c23e802914a1758e957508955 /media-video/helixplayer/helixplayer-1.0.4.ebuild
parentversion bump, fixes bug #75586. thanks to <vanquirius@gentoo.org> for the patch. (diff)
downloadgentoo-2-a6a8817dc9a9fb90ff70826f26a937affb8f358a.tar.gz
gentoo-2-a6a8817dc9a9fb90ff70826f26a937affb8f358a.tar.bz2
gentoo-2-a6a8817dc9a9fb90ff70826f26a937affb8f358a.zip
Removed vulnerable versions and related files. Moved patch and files for latest version into a patchset tarball.
(Portage version: 2.0.51.20-r5)
Diffstat (limited to 'media-video/helixplayer/helixplayer-1.0.4.ebuild')
-rw-r--r--media-video/helixplayer/helixplayer-1.0.4.ebuild21
1 files changed, 9 insertions, 12 deletions
diff --git a/media-video/helixplayer/helixplayer-1.0.4.ebuild b/media-video/helixplayer/helixplayer-1.0.4.ebuild
index e59107731a0f..13cffa9f5dba 100644
--- a/media-video/helixplayer/helixplayer-1.0.4.ebuild
+++ b/media-video/helixplayer/helixplayer-1.0.4.ebuild
@@ -1,14 +1,17 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/helixplayer/helixplayer-1.0.4.ebuild,v 1.2 2005/04/21 16:29:20 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/helixplayer/helixplayer-1.0.4.ebuild,v 1.3 2005/05/02 00:13:31 flameeyes Exp $
inherit nsplugins eutils
MY_PKG=${P/helixplayer/hxplay}
+PATCHLEVEL="1"
DESCRIPTION="A free open-source media player by real"
HOMEPAGE="http://www.helixplayer.org/"
-SRC_URI="https://helixcommunity.org/download.php/1138/${MY_PKG}.tar.bz2"
+SRC_URI="https://helixcommunity.org/download.php/1138/${MY_PKG}.tar.bz2
+ http://digilander.libero.it/dgp85/gentoo/${PN}-patches-${PATCHLEVEL}.tar.bz2"
+
LICENSE="GPL-2"
SLOT="0"
# -sparc -amd64: 1.0_beta1: build fails on both platforms... --eradicator
@@ -28,14 +31,8 @@ src_unpack() {
unpack ${A}
cd ${S}
- #adjust strange naming for helixplayer tarball
- epatch ${FILESDIR}/installer-naming.patch
-
- #fixes the .bif file to create a gentoo_player custom target
- epatch ${FILESDIR}/${PN}-1.0.3-bif.patch
-
- #fixes sem_t based issues
- use nptl && epatch ${FILESDIR}/${PN}-1.0.3-sem_t.patch
+ use nptl || EPATCH_EXCLUDE="03_all_sem-t.patch"
+ EPATCH_SUFFIX="patch" epatch ${WORKDIR}/${PV}
#fixes icon name in .desktop file
sed -i -e 's:hxplay.png:hxplay:' ${S}/player/installer/common/hxplay.desktop
@@ -45,7 +42,7 @@ src_compile() {
#copies our buildrc file over with information on where
#ogg and theora libs are kept
- cp ${FILESDIR}/buildrc ${S}
+ cp ${WORKDIR}/${PV}/buildrc ${S}
export BUILDRC="${S}/buildrc"
export BUILD_ROOT="${S}/build"
@@ -68,7 +65,7 @@ src_install() {
inst_plugin /opt/netscape/plugins/nphelix.so
fi
- doenvd ${FILESDIR}/50helix
+ doenvd ${WORKDIR}/${PV}/50helix
for res in 16 192 32 48; do
insinto /usr/share/icons/hicolor/${res}x${res}/apps