summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-03-15 15:16:34 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-03-15 15:16:34 +0000
commit479c8acd2a34ba52e2080a8d0b667f880dc3ac85 (patch)
tree5869d03c0b323fb347f1b359057b0cd4705b5f60 /media-video/kmplayer
parentRemoved the double KEYWORDS entry. (diff)
downloadgentoo-2-479c8acd2a34ba52e2080a8d0b667f880dc3ac85.tar.gz
gentoo-2-479c8acd2a34ba52e2080a8d0b667f880dc3ac85.tar.bz2
gentoo-2-479c8acd2a34ba52e2080a8d0b667f880dc3ac85.zip
Fix -npp compilation issue. Per bugs #258870 and #259996.
(Portage version: 2.2_rc25/cvs/Linux x86_64)
Diffstat (limited to 'media-video/kmplayer')
-rw-r--r--media-video/kmplayer/ChangeLog6
-rw-r--r--media-video/kmplayer/files/0.11.0a-npp.patch13
-rw-r--r--media-video/kmplayer/kmplayer-0.11.0a.ebuild7
3 files changed, 23 insertions, 3 deletions
diff --git a/media-video/kmplayer/ChangeLog b/media-video/kmplayer/ChangeLog
index 879e8ef937b1..26f8cf33200b 100644
--- a/media-video/kmplayer/ChangeLog
+++ b/media-video/kmplayer/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/kmplayer
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/kmplayer/ChangeLog,v 1.121 2009/02/18 10:41:47 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/kmplayer/ChangeLog,v 1.122 2009/03/15 15:16:34 scarabeus Exp $
+
+ 15 Mar 2009; Tomas Chvatal <scarabeus@gentoo.org>
+ +files/0.11.0a-npp.patch, kmplayer-0.11.0a.ebuild:
+ Fix -npp compilation issue. Per bugs #258870 and #259996.
18 Feb 2009; Tomas Chvatal <scarabeus@gentoo.org>
+files/0.11.0a-fix_linking.patch, kmplayer-0.11.0a.ebuild:
diff --git a/media-video/kmplayer/files/0.11.0a-npp.patch b/media-video/kmplayer/files/0.11.0a-npp.patch
new file mode 100644
index 000000000000..979baaa27fe5
--- /dev/null
+++ b/media-video/kmplayer/files/0.11.0a-npp.patch
@@ -0,0 +1,13 @@
+diff -urN kmplayer-0.11.0a.old/src/kmplayerprocess.cpp kmplayer-0.11.0a/src/kmplayerprocess.cpp
+--- kmplayer-0.11.0a.old/src/kmplayerprocess.cpp 2009-01-25 20:57:46.000000000 +0100
++++ kmplayer-0.11.0a/src/kmplayerprocess.cpp 2009-03-15 16:13:23.000000000 +0100
+@@ -2829,9 +2829,6 @@
+
+ #else
+
+-KDE_NO_CDTOR_EXPORT NpStream::NpStream (NpPlayer *p, uint32_t sid, const QString &u)
+- : QObject (p) {}
+-
+ KDE_NO_CDTOR_EXPORT NpStream::~NpStream () {}
+ void NpStream::slotResult (KJob*) {}
+ void NpStream::slotData (KIO::Job*, const QByteArray&) {}
diff --git a/media-video/kmplayer/kmplayer-0.11.0a.ebuild b/media-video/kmplayer/kmplayer-0.11.0a.ebuild
index 5c6536292a50..4c9f08e3de0a 100644
--- a/media-video/kmplayer/kmplayer-0.11.0a.ebuild
+++ b/media-video/kmplayer/kmplayer-0.11.0a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/kmplayer/kmplayer-0.11.0a.ebuild,v 1.3 2009/02/18 10:41:47 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/kmplayer/kmplayer-0.11.0a.ebuild,v 1.4 2009/03/15 15:16:34 scarabeus Exp $
EAPI="2"
@@ -30,7 +30,10 @@ RDEPEND="${DEPEND}
S="${WORKDIR}/${MY_P}"
-PATCHES=( "$FILESDIR/${PV}-fix_linking.patch" )
+PATCHES=(
+ "$FILESDIR/${PV}-fix_linking.patch"
+ "$FILESDIR/${PV}-npp.patch"
+)
src_prepare() {
# fixup icon install