summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-06-23 16:17:31 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-06-23 16:17:31 +0000
commit7f4759ba866cda35b52d168f7c012fcfd74ef3b7 (patch)
tree37017420930e3c0adeda579c911057c34ce66de3 /media-video/mplayer
parentRemove old ebuilds. Requested by Arfrever (diff)
downloadgentoo-2-7f4759ba866cda35b52d168f7c012fcfd74ef3b7.tar.gz
gentoo-2-7f4759ba866cda35b52d168f7c012fcfd74ef3b7.tar.bz2
gentoo-2-7f4759ba866cda35b52d168f7c012fcfd74ef3b7.zip
use git-2.eclass for ffmpeg
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'media-video/mplayer')
-rw-r--r--media-video/mplayer/ChangeLog5
-rw-r--r--media-video/mplayer/mplayer-9999.ebuild7
2 files changed, 7 insertions, 5 deletions
diff --git a/media-video/mplayer/ChangeLog b/media-video/mplayer/ChangeLog
index 2f13b1c37930..225be5dd4181 100644
--- a/media-video/mplayer/ChangeLog
+++ b/media-video/mplayer/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-video/mplayer
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/ChangeLog,v 1.794 2011/06/23 16:11:12 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/ChangeLog,v 1.795 2011/06/23 16:17:31 aballier Exp $
+
+ 23 Jun 2011; Alexis Ballier <aballier@gentoo.org> mplayer-9999.ebuild:
+ use git-2.eclass for ffmpeg
23 Jun 2011; Alexis Ballier <aballier@gentoo.org> mplayer-9999.ebuild:
do not default enable faac, its non free, not compatible with binary
diff --git a/media-video/mplayer/mplayer-9999.ebuild b/media-video/mplayer/mplayer-9999.ebuild
index 52bf120b9453..82ba440a81a6 100644
--- a/media-video/mplayer/mplayer-9999.ebuild
+++ b/media-video/mplayer/mplayer-9999.ebuild
@@ -1,13 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/mplayer-9999.ebuild,v 1.103 2011/06/23 16:11:12 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/mplayer-9999.ebuild,v 1.104 2011/06/23 16:17:31 aballier Exp $
EAPI=4
EGIT_REPO_URI="git://git.videolan.org/ffmpeg.git"
-EGIT_PROJECT="ffmpeg" # git eclass sets it to PN otherwise
ESVN_REPO_URI="svn://svn.mplayerhq.hu/mplayer/trunk"
-[[ ${PV} = *9999* ]] && SVN_ECLASS="subversion git" || SVN_ECLASS=""
+[[ ${PV} = *9999* ]] && SVN_ECLASS="subversion git-2" || SVN_ECLASS=""
inherit toolchain-funcs eutils flag-o-matic multilib base ${SVN_ECLASS}
@@ -237,7 +236,7 @@ src_unpack() {
subversion_src_unpack
cd "${WORKDIR}"
rm -rf "${WORKDIR}/${P}/ffmpeg/"
- ( S="${WORKDIR}/${P}/ffmpeg/" git_src_unpack )
+ ( S="${WORKDIR}/${P}/ffmpeg/" git-2_src_unpack )
cd "${S}"
cp "${FILESDIR}/dump_ffmpeg.sh" . || die
chmod +x dump_ffmpeg.sh