summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Bornkessel <hd_brummy@gentoo.org>2014-06-15 17:30:37 +0000
committerJörg Bornkessel <hd_brummy@gentoo.org>2014-06-15 17:30:37 +0000
commitb76cf1c9254c9321f63c64956d83da918fb60086 (patch)
tree510325fc0cefb226353bd6fe7b2139b12bdd79d0 /media-video/noad
parentsys-kernel/aufs-sources: Bump to latest aufs3, genpatches and linux release (diff)
downloadgentoo-2-b76cf1c9254c9321f63c64956d83da918fb60086.tar.gz
gentoo-2-b76cf1c9254c9321f63c64956d83da918fb60086.tar.bz2
gentoo-2-b76cf1c9254c9321f63c64956d83da918fb60086.zip
bump
(Portage version: 2.2.10/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 34C2808A)
Diffstat (limited to 'media-video/noad')
-rw-r--r--media-video/noad/ChangeLog9
-rw-r--r--media-video/noad/noad-0.8.6.ebuild76
2 files changed, 83 insertions, 2 deletions
diff --git a/media-video/noad/ChangeLog b/media-video/noad/ChangeLog
index 3e3983b6a87c..19fb61d32e2f 100644
--- a/media-video/noad/ChangeLog
+++ b/media-video/noad/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/noad
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/noad/ChangeLog,v 1.60 2013/05/14 09:38:01 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/noad/ChangeLog,v 1.61 2014/06/15 17:30:37 hd_brummy Exp $
+
+*noad-0.8.6 (15 Jun 2014)
+
+ 15 Jun 2014; Joerg Bornkessel <hd_brummy@gentoo.org> +noad-0.8.6.ebuild:
+ bump
14 May 2013; Agostino Sarubbo <ago@gentoo.org> noad-0.7.3-r1.ebuild:
Stable for x86, wrt bug #464564
diff --git a/media-video/noad/noad-0.8.6.ebuild b/media-video/noad/noad-0.8.6.ebuild
new file mode 100644
index 000000000000..ff617fa212f0
--- /dev/null
+++ b/media-video/noad/noad-0.8.6.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/noad/noad-0.8.6.ebuild,v 1.1 2014/06/15 17:30:37 hd_brummy Exp $
+
+EAPI=5
+inherit autotools eutils toolchain-funcs confutils
+
+DESCRIPTION="Mark commercial breaks in VDR recordings"
+HOMEPAGE="http://noad.net23.net/"
+SRC_URI="http://noad.net23.net/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ffmpeg imagemagick libmpeg2"
+
+RDEPEND="
+ libmpeg2? ( media-libs/libmpeg2:= )
+ ffmpeg? ( virtual/ffmpeg )
+ imagemagick? ( media-gfx/imagemagick )
+ !media-plugins/vdr-markad"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ if has_version '>=media-video/vdr-1.7.15'; then
+ sed -i -e 's:2001:6419:' svdrpc.cpp main.cpp || die
+ fi
+ eautoreconf
+}
+
+src_configure() {
+ confutils_require_any ffmpeg libmpeg2
+ econf \
+ $(usex imagemagick '--with-magick') \
+ $(usex ffmpeg '' '--without-ffmpeg') \
+ $(usex libmpeg2 '' '--without-libmpeg2') \
+ --with-tools
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)" # see bug #469810
+}
+
+src_install() {
+ dobin noad showindex checkMarks
+ use imagemagick && dobin markpics
+
+ dodoc README INSTALL
+ # example scripts are installed as dokumentation
+ dodoc allnewnoad allnoad allnoadnice clearlogos noadcall.sh noadifnew stat2html statupd
+
+ newconfd "${FILESDIR}"/confd_vdraddon.noad vdraddon.noad
+
+ insinto /usr/share/vdr/record
+ doins "${FILESDIR}"/record-50-noad.sh
+
+ insinto /usr/share/vdr/shutdown
+ doins "${FILESDIR}"/pre-shutdown-15-noad.sh
+
+ insinto /etc/vdr/reccmds
+ doins "${FILESDIR}"/reccmds.noad.conf
+
+ exeinto /usr/share/vdr/bin
+ doexe "${FILESDIR}"/noad-reccmd
+}
+
+pkg_postinst() {
+ elog
+ elog "To integrate noad in VDR you should do this:"
+ elog
+ elog "start and set Parameter in /etc/conf.d/vdraddon.noad"
+ elog
+ elog "Note: You can use here all parameters for noad,"
+ elog "please look in the documentation of noad."
+}