summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-02-05 04:13:18 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-02-05 04:13:18 +0000
commitfb26e1a5e5489988b3a90af24867d427eb43f6ee (patch)
tree3d5e7524cc029e98904107d54ac6b11d1b716818 /media-video/nvidia-glx
parentFirst ebuild. Thanks Matthew Kennedy. (diff)
downloadgentoo-2-fb26e1a5e5489988b3a90af24867d427eb43f6ee.tar.gz
gentoo-2-fb26e1a5e5489988b3a90af24867d427eb43f6ee.tar.bz2
gentoo-2-fb26e1a5e5489988b3a90af24867d427eb43f6ee.zip
New NVIDIA GLX/kernel driver setup from Arcady Genkin that fixes lots of
problems, eliminates files being overwritten in /usr/X11R6 and allows the NVIDIA drivers to be cleanly uninstalled without requiring an X reinstall!
Diffstat (limited to 'media-video/nvidia-glx')
-rw-r--r--media-video/nvidia-glx/files/09nvidia2
-rw-r--r--media-video/nvidia-glx/files/README.gentoo7
-rw-r--r--media-video/nvidia-glx/files/digest-nvidia-glx-1.0.23131
-rw-r--r--media-video/nvidia-glx/files/libGL.la32
-rw-r--r--media-video/nvidia-glx/nvidia-glx-1.0.2313.ebuild78
5 files changed, 120 insertions, 0 deletions
diff --git a/media-video/nvidia-glx/files/09nvidia b/media-video/nvidia-glx/files/09nvidia
new file mode 100644
index 000000000000..1fcbef41fc7c
--- /dev/null
+++ b/media-video/nvidia-glx/files/09nvidia
@@ -0,0 +1,2 @@
+# Has to precede X11's own libraries!
+LDPATH=/opt/nvidia/lib
diff --git a/media-video/nvidia-glx/files/README.gentoo b/media-video/nvidia-glx/files/README.gentoo
new file mode 100644
index 000000000000..ca3370c62b6e
--- /dev/null
+++ b/media-video/nvidia-glx/files/README.gentoo
@@ -0,0 +1,7 @@
+Make sure that in your XF86Config in "Files" section you add the
+following:
+
+ ModulePath "/opt/nvidia/modules"
+ ModulePath "/usr/X11R6/lib/modules"
+
+For more information read the README file.
diff --git a/media-video/nvidia-glx/files/digest-nvidia-glx-1.0.2313 b/media-video/nvidia-glx/files/digest-nvidia-glx-1.0.2313
new file mode 100644
index 000000000000..9d8bd5668c01
--- /dev/null
+++ b/media-video/nvidia-glx/files/digest-nvidia-glx-1.0.2313
@@ -0,0 +1 @@
+MD5 511f76c01d83cae0917088bdda8a4bc6 NVIDIA_GLX-1.0-2313.tar.gz 1508184
diff --git a/media-video/nvidia-glx/files/libGL.la b/media-video/nvidia-glx/files/libGL.la
new file mode 100644
index 000000000000..f79c05c0853e
--- /dev/null
+++ b/media-video/nvidia-glx/files/libGL.la
@@ -0,0 +1,32 @@
+# libGL.la - a libtool library file
+# Generated by ltmain.sh - GNU libtool 1.4 (1.920 2001/04/24 23:26:18)
+#
+# Please DO NOT delete this file!
+# It is necessary for linking the library.
+
+# The name that we can dlopen(3).
+dlname='libGL.so.1'
+
+# Names of this library.
+library_names='libGL.so.${PV} libGL.so.1 libGL.so'
+
+# The name of the static archive.
+old_library=''
+
+# Libraries that this one depends upon.
+dependency_libs=' -L/usr/X11R6/lib -lm -lX11 -lXext -ldl '
+
+# Version information for libGL.
+current=${ver1}
+age=${ver2}
+revision=${ver3}
+
+# Is this an already installed library?
+installed=yes
+
+# Files to dlopen/dlpreopen
+dlopen=''
+dlpreopen=''
+
+# Directory that this library needs to be installed in:
+libdir='/opt/nvidia/lib'
diff --git a/media-video/nvidia-glx/nvidia-glx-1.0.2313.ebuild b/media-video/nvidia-glx/nvidia-glx-1.0.2313.ebuild
new file mode 100644
index 000000000000..be4feecdafcc
--- /dev/null
+++ b/media-video/nvidia-glx/nvidia-glx-1.0.2313.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Arcady Genkin <agenkin@thpoon.com>
+# /space/gentoo/cvsroot/gentoo-x86/skel.build,v 1.14 2002/02/01 19:50:13 gbevin Exp
+
+# This portage installs binary XFree drivers for video cards
+# with NVIDIA chipsets. The driver is provided by NVIDIA corporation.
+
+S="${WORKDIR}/${P}"
+
+DESCRIPTION="Linux kernel module for the NVIDIA's X driver"
+
+NV_PACKAGE=NVIDIA_GLX-1.0-2313
+NV_ARCHIVE="${NV_PACKAGE}.tar.gz"
+
+SRC_URI="http://205.158.109.140/XFree86_40/1.0-2313/${NV_ARCHIVE}"
+HOMEPAGE="http://www.nvidia.com/"
+
+DEPEND="virtual/glibc >=x11-base/xfree-4.0.2 >=media-video/nvidia-kernel-1.0.2314"
+
+src_unpack() {
+ unpack "${NV_ARCHIVE}"
+ mv "${NV_PACKAGE}" "${P}"
+}
+
+src_install () {
+ # NVIDIA's stock makefile overwrites headers and libraries
+ # that come with XFree. I don't like it and prefer to keep
+ # NVIDIA's stuff in a totally separate place, hence it goes
+ # into /opt
+ local NVIDIA_ROOT=/opt/nvidia
+
+ # The X module
+ exeinto "${NVIDIA_ROOT}/modules/drivers"
+ doexe usr/X11R6/lib/modules/drivers/nvidia_drv.o
+ exeinto "${NVIDIA_ROOT}/modules/extensions"
+ doexe "usr/X11R6/lib/modules/extensions/libglx.so.${PV}"
+ (cd "${D}/${NVIDIA_ROOT}/modules/extensions"
+ ln -s "libglx.so.${PV}" libglx.so)
+
+ # The GLX libraries
+ exeinto "${NVIDIA_ROOT}/lib"
+ doexe "usr/lib/libGL.so.${PV}" "usr/lib/libGLcore.so.${PV}"
+ (cd "${D}/${NVIDIA_ROOT}/lib"
+ ln -s "libGL.so.${PV}" libGL.so
+ ln -s "libGL.so.${PV}" libGL.so.1
+ ln -s "libGLcore.so.${PV}" libGLcore.so
+ ln -s "libGLcore.so.${PV}" libGLcore.so.1)
+
+ # Not sure whether installing the .la file is neccessary;
+ # this is adopted from the `nvidia' ebuild
+ local ver1="`echo ${PV} |cut -d '.' -f 1`"
+ local ver2="`echo ${PV} |cut -d '.' -f 2`"
+ local ver3="`echo ${PV} |cut -d '.' -f 3`"
+ sed -e "s:\${PV}:${PV}:" \
+ -e "s:\${ver1}:${ver1}:" \
+ -e "s:\${ver2}:${ver2}:" \
+ -e "s:\${ver3}:${ver3}:" \
+ "${FILESDIR}/libGL.la" > "${D}/${NVIDIA_ROOT}/lib/libGL.la"
+
+ # Make sure /opt/NVIDIA/lib gets into ld.so.conf before xfree's libs
+ insinto /etc/env.d
+ doins "${FILESDIR}/09nvidia"
+
+ # Includes
+ insinto "${NVIDIA_ROOT}/include/GL"
+ doins usr/include/GL/*.h
+
+ # Docs
+ dodoc "${FILESDIR}/README.gentoo" usr/share/doc/*
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Make sure to read documentation in /doc/share/${P}"
+ einfo "before you attempt to tweak your XF86Config file!"
+ einfo
+}