summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Hildebrand <zypher@gentoo.org>2004-03-25 09:10:15 +0000
committerMarc Hildebrand <zypher@gentoo.org>2004-03-25 09:10:15 +0000
commitda05cbf30c0a6eede52462264aeebed0cb14012d (patch)
treea9aa74b5abd6deaf0865af9665ee0e0abd2355fa /media-video/piave/piave-0.2.4-r1.ebuild
parentWAY out of date package. Added an ebuild for 5.2. (Manifest recommit) (diff)
downloadgentoo-2-da05cbf30c0a6eede52462264aeebed0cb14012d.tar.gz
gentoo-2-da05cbf30c0a6eede52462264aeebed0cb14012d.tar.bz2
gentoo-2-da05cbf30c0a6eede52462264aeebed0cb14012d.zip
Bugfix in configure
Diffstat (limited to 'media-video/piave/piave-0.2.4-r1.ebuild')
-rw-r--r--media-video/piave/piave-0.2.4-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-video/piave/piave-0.2.4-r1.ebuild b/media-video/piave/piave-0.2.4-r1.ebuild
new file mode 100644
index 000000000000..c32cadbdd3c2
--- /dev/null
+++ b/media-video/piave/piave-0.2.4-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/piave/piave-0.2.4-r1.ebuild,v 1.1 2004/03/25 09:10:15 zypher Exp $
+
+DESCRIPTION="PIAVE - Piave Is A Video Editor"
+HOMEPAGE="http://modesto.sourceforge.net/piave/index.html"
+SRC_URI="mirror://sourceforge/modesto/${P}.tar.gz"
+
+IUSE="nls"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+DEPEND="virtual/x11
+ >=dev-util/pkgconfig-0.15.0
+ >=dev-libs/libxml2-2.5.11
+ >=dev-cpp/libxmlpp-0.21.0
+ >=media-libs/gdk-pixbuf-0.22.0
+ >=media-libs/libsdl-1.2.6-r2
+ >=media-libs/sdl-image-1.2.3
+ >=media-libs/libdv-0.99-r1
+ >=media-libs/libsndfile-1.0.5
+ >=media-libs/libvorbis-1.0.1
+ >=sys-libs/libraw1394-0.9.0
+ >=sys-libs/libavc1394-0.4.1"
+
+
+src_compile() {
+ cd ${S}
+ epatch ${FILESDIR}/piave-0.2.4-include-arts.diff
+ `use_enable nls` \
+ myconf=${myconf}" --with-gnu-ld"
+ econf ${myconf} || die "configure failed"
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog README TODO
+}